New answers tagged

0

Another way to do this would be to clone gvfs user-mounts git clone /run/user/<username>/gvfs/path_to_repo/repo.git This avoids mounting issues See also: Where can I find the mount point for SMB shares in 13.04?


-1

You should check smb.conf file on server.


0

You can use sticky for the other file permission in samba share file. or you can also add the guest user and change the permission for them on share folder.


1

If you have a Guest account without a password: smb://Guest:@server_name If you have a user account with a password: smb://user_name:password@server_name If you have a user account but only want to be prompted for the password: smb://user_name:*@server_name


1

After some helpful suggestions (thanks @mikewhatever) and a bit more investigation Ive worked it out. The way to reference this share is in the location bar of the file manager use: smb://ip address/username/sharename/ The username and sharename you get from the user settings page of the routers web interface when you set up the share - at that stage ...


0

I use a linux machine to move files to several windows machines. After a ubuntu update when I tried to connect to windows machines I am prompted for a password. The prompt says: Computer Name____________ and under it Password_______. When I put the computer name and password in they don't work. Solution: The computer name [Robyn] that you find on windows ...


0

You are almost there. Open FSTAB by using: sudo nano /etc/fstab In the last line ( or on of the last lines) place: //192.168.0.5/storage /media/myname/TK-Public/ cifs username=YOURUSERNAME,password=YOURPASSWORD,iocharset=utf8,file_mode=0777,dir_mode=0777 *** (this is all one long line) Ctrl-X to close, Y to save and Enter to seal the deal. Now ...


1

This question is a duplicate of this one. The answer: you must explicitly set client use spnego = no in /etc/samba/smb.conf.


0

Im not 100% sure what your asking is achievable, somebody else might be able to point you in a better direction but here is my solution. You could add a DNS record in your domain controller (Ensure replication is setup if you have multiple Domain Controllers), this would enable your users to browse to http://argo.mydomain.net The problem lies where if ...


0

The first step is to install winbind (If not already installed) a simple sudo apt-get install winbind Should do the job, but I cant confirm that while i'm at work. This is not be confused with winbindd which is a similar program. Then you will need to edit a file called /etc/nsswitch.conf to look something like this; Then restart the winbind ...


0

Thank you all. I have the same problem. This thread provide me the right direction and here is how I got to the fix. I tried use smbclient to see what happened I got this: " SMB server does not support EXTENDED_SECURITY but 'client use spnego = yes and 'client ntlmv2 auth = yes' " I think this means samba client is telling the samba server use features ...


1

I had the exact problem after upgrading to 16.04, first showed many errors as yours, something like: dpkg: error processing package samba (--configure) After I changed software sources to ubuntu main server, I can reinstall samba and the following commands without error: sudo /etc/init.d/smbd status sudo apt-get install libnss-winbind* libpam-winbind* ...


-1

It seems that at some update someone enabled a firewall in Ubuntu 14.04 LTS. By typing the command "sudo ufw allow samba" samba all sprang into life. I could see my samba shares from the machine which is running ubuntu and see other computers / phones in my house. I have been using samba for many years and thought I knew all the gotchas (of which there are ...


0

I first added the line client use spnego = no at the end of file /etc/samba/smb.conf, but it did not work. After I placed the line near the beginning of the file, the network drives worked.


2

I was having the same issue after upgrading to 16.04. What I did was change the permissions on gvfsd-smb-browse so that it can only be executed as sudo or by root. Now gvfsd-smb-browse doesn't run on startup. Below is how you can change the permissions. sudo chmod 744 /usr/lib/gvfs/gvfsd-smb-browse Not sure if it is a real solution to the underlying ...


4

I've found something in the GVFS man page that states that it's for browsing windows file shares. • gvfsd-smb-browse - browses Windows Shares Filesystem volumes GVFS is the gnome virtual filesystem: GIO provides a VFS API to GLib applications. It includes a 'local' implementation using POSIX. gvfs provides implementations that go beyond that and allow to ...


0

Debian and debian-derivatives changed the service name from 'samba' to 'smbd'. Try service smbd restart.


0

Try to use initial directory option (--directory Public/Offline)


0

Yes after the latest update I did yestarday samba was not able to connect as a client via the nautilus. Mounting via the mount direct command still was working. I had to change the smb.conf file as suggested above by adding client use spnego = no Then you have to restart the samba network stack (just reboot). Everything is working now.


0

It seems there's a bug in the latest samba version: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1572876?comments=all For the moment, the only workaround I found was to remove samba and then install the previous packages using: apt-get install samba=2:4.1.6+dfsg-1ubuntu2 samba-common=2:4.1.6+dfsg-1ubuntu2 samba-libs=2:4.1.6+dfsg-1ubuntu2 ...


4

iocharset=utf8 sets what encoding to use when mounting drives or network shares. According to Wikipedia: UTF-8 is a character encoding capable of encoding all possible characters, or code points, defined by Unicode. It's pretty much a safety feature just to make sure Ubuntu can present all text in a readable format (shows it correctly), and save ...


0

Check that you have winbind installed. Install it if haven´t got it and restart samba-ad-dc again. You should be fine after that. https://lists.samba.org/archive/samba/2016-April/199291.html


1

Try commenting out the line security=share from your smb.conf file. That's what it took to get mine working again. Don't forget to restart smbd and nmbd afterwards.


2

Due to the recent fixes for the Badlock Samba vulnerability, and many of the changes necessary to address it, there are a large number of regressions. This is one of the things hit by the regressions as a result of the fix. (It is not likely a case of your configuration being wrong) There is a bug open on this on Launchpad, but as of yet there is no fix. ...


0

possibly related and see my answer there: Samba Share user/password error after update I will update this answer, if this is indeed the solution. (plus, probably the questions should be marked as duplicates then?)


0

possibly related and see my answer there: Samba Share user/password error after update I will update this answer, if this is indeed the solution.


3

I had exactly the same problem. Adding client use spnego = no to the [global] section of /etc/samba/smb.conf solved the problem in my case. Apparently the default value changed to "yes" after the update to v.4.3.8, so I needed to explicitly set it. See the online manpage for reference.


1

I have the same problem: http://serverfault.com/questions/771388/how-can-i-fix-samba-3-6-25-the-trust-relationship-between-this-workstation-and A workaround is to reinstall the old packages (see the link).


0

We have the same problem. The only workaround is matener we thought the old samba packages where our DOMAIN worked properly. To do reinstall the following packages that were updated: These are the packages that were automatically updated. Start-Date: 2016-04-19 06:42:23 Upgrade: smbclient:amd64 (3.6.3-2ubuntu2.17, 3.6.25-0ubuntu0.12.04.2), ...


0

have similar problem with Windows machines in Samba3 domain which lost trust after USN-2950-1 update. More info here: Samba 2:3.6.25-0ubuntu0.12.04.2 as PDC (samba3 NT4 domain) Windows machines lost trust after USN-2950-1 update any help appreciated. Thank you Martin


0

This applies if your remote VPN is running on a different computer than the SMB share. I think that what you want is the following to your OpenVPN config file. push "route 192.168.1.0 255.255.255.0" This allows your remote computer to see the rest of the Remote 192.168.1.* network, if you don't have this line, then it will only be able to access remote ...


0

When entering the server name, do not include the smb:// I hope this helps


0

I think the reason of problem is user permissions. When I used Active Control List (Shared folders for all users), problem has been solved partially. But now if one user create a folder, others cannot delete it but they can write into it.


1

Getting the users net rpc user Getting the shares per user Less verbose than smbclient -L is net rpc share list -U $USERNAME You'll need both because the list of visible shares differs per user.


1

rsync has an option to keep permission -p, --perms preserve permissions If you use gRsync, the same option is under Basic Options tab, mine is in spanish and looks like this: gRsync Basic Options Hope it helps.


1

create mask only defines the maximum rights a file can be created with. If the windows user creates a file with 0750, that's the right that's going to be applied with your settings, since it's being bitwise ANDed. You probably want to combine your settings with the force (directory) create mode = 0777 setting. For more info check man 5 smb.conf: ...


0

Since you are on 14.04, your packages (in main) get security upgrades for 5 years. I guess the Ubuntu team is already working on that. You'll only need the ppa if you have reason to believe it's going to be exploited at your site before the fix hits official Ubuntu packages.


0

Are you sure you can contact the server VIA the VPN? Have you tried pinging it by IP address and by hostname? (To get the Internal IP address of your server go to your command line and type ipconfig) if you can ping via IP address and not by hostname you will need to map the drive as such \XXX.XXX.XXX.XXX\Sharename (Replacing the X's with your internal IP ...


1

As far as im aware there isn't any software to administer GPO (Group Policy Objects) from a mac and requires windows. One way would be to install Vmware Player and install a windows machine inside of that and use it to administer users and GPO's. Underneath active directory it uses LDAP to authenticate users, so if you aren't interested in administering ...


0

I dont have the definitive answer to this problem, but i experienced a similar problem with the follow system links enabled in the smb.conf file. What are the specs of the machine you are using? ( I doubt this has a major effect) Have you tried using a system monitoring tool like Glances to watch the performance of your server as you access these folders, ...


2

Your share is not correctly configured in Samba, this is no fault of the SSH server. Here is how a share that allows anyone on the network to view, read, and write should look: [Downloads] comment = Downloads path = "/home/pi/Downloads" writeable = yes guest ok = yes create mask = 0644 directory mask = 0755 force user = pi If you would like to force users ...



Top 50 recent answers are included