Hot answers tagged

4

I've found something in the GVFS man page that states that it's for browsing windows file shares. • gvfsd-smb-browse - browses Windows Shares Filesystem volumes GVFS is the gnome virtual filesystem: GIO provides a VFS API to GLib applications. It includes a 'local' implementation using POSIX. gvfs provides implementations that go beyond that and allow to ...


4

iocharset=utf8 sets what encoding to use when mounting drives or network shares. According to Wikipedia: UTF-8 is a character encoding capable of encoding all possible characters, or code points, defined by Unicode. It's pretty much a safety feature just to make sure Ubuntu can present all text in a readable format (shows it correctly), and save ...


3

I had exactly the same problem. Adding client use spnego = no to the [global] section of /etc/samba/smb.conf solved the problem in my case. Apparently the default value changed to "yes" after the update to v.4.3.8, so I needed to explicitly set it. See the online manpage for reference.


2

Due to the recent fixes for the Badlock Samba vulnerability, and many of the changes necessary to address it, there are a large number of regressions. This is one of the things hit by the regressions as a result of the fix. (It is not likely a case of your configuration being wrong) There is a bug open on this on Launchpad, but as of yet there is no fix. ...


2

I was having the same issue after upgrading to 16.04. What I did was change the permissions on gvfsd-smb-browse so that it can only be executed as sudo or by root. Now gvfsd-smb-browse doesn't run on startup. Below is how you can change the permissions. sudo chmod 744 /usr/lib/gvfs/gvfsd-smb-browse Not sure if it is a real solution to the underlying ...


2

Your share is not correctly configured in Samba, this is no fault of the SSH server. Here is how a share that allows anyone on the network to view, read, and write should look: [Downloads] comment = Downloads path = "/home/pi/Downloads" writeable = yes guest ok = yes create mask = 0644 directory mask = 0755 force user = pi If you would like to force users ...


1

create mask only defines the maximum rights a file can be created with. If the windows user creates a file with 0750, that's the right that's going to be applied with your settings, since it's being bitwise ANDed. You probably want to combine your settings with the force (directory) create mode = 0777 setting. For more info check man 5 smb.conf: ...


1

rsync has an option to keep permission -p, --perms preserve permissions If you use gRsync, the same option is under Basic Options tab, mine is in spanish and looks like this: gRsync Basic Options Hope it helps.


1

Getting the users net rpc user Getting the shares per user Less verbose than smbclient -L is net rpc share list -U $USERNAME You'll need both because the list of visible shares differs per user.


1

If you have a Guest account without a password: smb://Guest:@server_name If you have a user account with a password: smb://user_name:password@server_name If you have a user account but only want to be prompted for the password: smb://user_name:*@server_name


1

As far as im aware there isn't any software to administer GPO (Group Policy Objects) from a mac and requires windows. One way would be to install Vmware Player and install a windows machine inside of that and use it to administer users and GPO's. Underneath active directory it uses LDAP to authenticate users, so if you aren't interested in administering ...


1

I have the same problem: http://serverfault.com/questions/771388/how-can-i-fix-samba-3-6-25-the-trust-relationship-between-this-workstation-and A workaround is to reinstall the old packages (see the link).


1

Try commenting out the line security=share from your smb.conf file. That's what it took to get mine working again. Don't forget to restart smbd and nmbd afterwards.


1

I had the exact problem after upgrading to 16.04, first showed many errors as yours, something like: dpkg: error processing package samba (--configure) After I changed software sources to ubuntu main server, I can reinstall samba and the following commands without error: sudo /etc/init.d/smbd status sudo apt-get install libnss-winbind* libpam-winbind* ...


1

This question is a duplicate of this one. The answer: you must explicitly set client use spnego = no in /etc/samba/smb.conf.


1

After some helpful suggestions (thanks @mikewhatever) and a bit more investigation Ive worked it out. The way to reference this share is in the location bar of the file manager use: smb://ip address/username/sharename/ The username and sharename you get from the user settings page of the routers web interface when you set up the share - at that stage ...


1

Add browseable = yes to the [share] block in smb.conf to allow Windows computers to successfully browse the share. It should fix your issue with clients being able to write but not read. After changing the config file, restart samba services: sudo restart smbd sudo restart nmbd



Only top voted, non community-wiki answers of a minimum length are eligible