Tag Info

New answers tagged

0

From boot meny, select recovery mode (ususally second from top), wait for the boot-up till you are presented with the Recovery Menu. Select the root option from the menu and you will drop in the root shell. Re-mount the file system as read-write mount -o rw,remount / Add your user to sudo group adduser username sudo And, exit. exit You will go ...


0

I had the same problem after changing to ubuntu-desktop from lubuntu on my imac. It seems, that 'policykit-1-gnome' was missing. After reinstalling sudo apt-get install policykit-1-gnome and logout-login it works flawlessly.


3

Couldn't you simply run it in the background, inside a while loop: while true do [command] sleep [number of seconds] done So the construction would be: Add a line in /etc/rc.local to call your script (your ShellScript.sh) + "&" to make it exit Run the commands you want the ShellScript.sh to execute in a while loop (inside Shellscript.sh): ...


0

You have to connect to your android phone through adb Then you can type in your terminal "adb shell" and then "su" to have root access to your phone's files through your Ubuntu terminal.


1

When you boot into recovery mode, the root partition (/) is mounted in read-only mode as to cause the least possible damage. This command simply remounts it in read-write mode so that you can persist changes (eg a new password) to disk. Without warranty or guarantee, I can say with 110% certainty that this will not hurt your data... But remember that you ...


0

Wine by default runs programs as admin within itself, but wine can even be broken by trying to run it as root. Never run it as root. To tell if it is "rooted" just see what command you use to launch it. If it includes "sudo" or "gksudo" or even "kdesudo" you are running it as root. Wine is subject to viruses in the same way a non admin windows account can ...


2

In addition there are logging considerations to consider between sudo and su. Being su simply does everything as root with no entry other than one line in the auth log saying you became root. Sudo on the other hand - always gets logged as your user ID with escalated priveleesw.


0

There are many examples online so I will not repeat them.. The one thing they do not say is you need ssh-add [path_to_key] when using a custom name (not default) for the key. If you insist on only using a password not a public-private key pair: ssh root@server-ip-or-hostname and type your pass. SIMPLE!


1

If you insist on having to log in as root, I'd suggest logging in as a normal user, running sudo tail -f /var/log/auth.log and then (without closing that session), trying to log in as root via SSH and observe the authentication error messages appearing in the first session. You should be able to figure out the reason you're unable to log in as root from ...


2

This doesn't answer the question directly, but if your intent is simply to administer your machine remotely, it is generally considered preferable and safer to log in as a non-root user, then elevate your privileges once you have started a session on the server. In other words, instead of using ssh root@yourserver, you may wish to log in as yourself (your ...


7

The default on Ubuntu 14.04 in /etc/ssh/sshd_config is PermitRootLogin without-password which forbids root logins using password authentication. This is a good idea because brute-force login attempts against the root user are extremely common. To login as root, I recommend setting up key-based SSH login. Another (dangerous!) possibility is to change ...


0

For this user case probably the best "solution" is to re-install Ubuntu with full encryption (LUKS). This would secure the data and prevent changing the root/users password(s). This could be defeated with a few methods, both hardware (key loggers) and software (custom kernels), but both of those options are unlikely. The OP can assess these risks. With ...


-1

Yes. Set the root password. Open a terminal, and do: sudo passwd Enter a password. Then the root shell in recovery mode will always ask for this password. Note that all this is futile as he can boot into a live USB and change your password. Ultimately, given physical access, the security battle is lost.


2

If you don't trust someone to have full shell access on your system, don't give them shell access at all. You want to stop cp command what about other commands that acts like cp , what about if admins use scp command . Am not saying its impossible to block this command , but a play around trick will defeat your goal .


0

You can edit /etc/security/limits.conf and add: root hard maxlogins 1 This will limit the total number of root login shells to 1, and it includes both local and remote access.


0

One way would be to limit the terminals through which root login is allowed. This is done by editing /etc/securetty. Just let securetty contain any two TTYs and you're done.


-2

Nevert tried this but would go the following way: Make bin/bash and other shells unaccessible to root. Create script that would run bash if not already running, otherwise exit. Assign this script as root shell.


1

You seem like you may be confused about how Ubuntu installs software. Software installed by Ubuntu (eg, by any of its package managers) will be installed system-wide, for all users. Ubuntu doesn't have an official concept of installing software for just one user. Most software that needs to store user preferences (particularly desktop GUI software) will ...


-2

If you lose control of root: Before you format again, check /etc/passwd, e.g., gvim /etc/passwd you should see a line like root:x:0:0:root:/root:/bin/csh sometimes this gets incorrectly modified, e.g.: root:x:0:0:root:/root:csh Essentially the system cannot find the location of the installed shell from where to invoke root. Correct it! You ...


5

Yes the root user is an official one. That user comes from a long line of historical influences. It's the conventional name of the user who has all rights or permissions. Most Unix-linke operating systems have a root user. It's not always called "root". You may know the Administrator of Windows operating systems. Some Linux derivates like Ubuntu allow ...


1

It is root. In Ubuntu root defaults to having no password set so you have to sudo su - or sudo -s to login as root. Or if you really wanted, set a password for root and bypass the need for sudo (not adviseable) sudo su - Open the root users default environment, So you get the root users shell etc.. sudo -s Will open the shell defined in the ...


0

Something is strange with your system. The installer complains, that it can not find the binary locale, which is located at /usr/bin/locale, which is packaged in libc-bin, that you are just about to install. So how did you get rid of libc-bin? Isn't it installed? Can you run dpkg -l libc-bin


2

You will need root access to the trash to be able to delete these files - the easiest way to do this in a temporary sense, is to open a terminal window alt+ctrl+t, and enter the command gksudo nautilus This will execute the file manager with super-user permissions and you should be able to empty the trash from here. When you are done, remember to close ...


1

First enable the root account by setting a password: sudo passwd Then enable manual login in LightDM (assuming 14.04): sudo tee /usr/share/lightdm/lightdm.conf.d/50-allow-manual.conf <<EOF [SeatDefaults] greeter-show-manual-login=true EOF Restart LightDM: sudo service lightdm restart Login as root. You'll have to type both username and ...


0

For 14.04 you would have to comment below line in /etc/ssh/sshd_config StrictModes yes Jitendra


0

Go through the boot options dialog and select the option that says "Boot to root shell" or something similar. That should drop you straight into a root shell, where you can attempt to repair the damage. If that's also broken and you can't get a root shell, you may screwed.


-2

I would give 40-50GB for / and mabey 100GB for /home with the rest as an NTFS volume for movies/music/whatever so you can get to it from either OS. Putting /home on it's own partition allows you to upgrade or distro hop without losing all your linux data.


1

In order to fix your problem, simply move your line: fizzbuzz ALL=NOPASSWD: ALL chadmin ALL=NOPASSWD: ALL form sudoers file to sudo visudo -f /etc/sudoers.d/myOverrides This is better approach than edit sudoers. Use always visudo, if you insert errors in the file, you may not longer be able to run sudo. Your directive doesn't work because are ...


0

If multiple entries match for a user the last one is used. So if fizzbuzz and chadmin are members of the groups admin or sudo they will be still asked for a password. Put the two lines at the end of the sudoers file after the #includedir line.


2

The root account in Ubuntu is defaultly disabled. When you enabled the root account (set a password for it) then you can disble it easy by the following command: sudo passwd -dl root -d means to delete the password (make it empty) -l means lock the password of the account


1

user10962 is right, "nuclear" approaches like reinstalling aren't necessary, but may be the best approach because this error message can indicate a larger problem. As an example, a friend of mine had this exact problem when he accidentally changed ownership of EVERYTHING in /usr/bin to . In this case, user10962's solution restores sudo permissions but ...


1

Short answer: don't do that. If you want to run several commands as root, you can use sudo su - to get a root shell. This is useful if you're doing system maintenance, I personally do this when administering servers. Other than that, it's a good habit to use sudo if and only if it's really necessary. This is both for security reasons and you're less likely ...


-2

Type this command sudo usermod -u 0 -o your-username now you-user account works same as root user.


1

Root user already exist in PC but password is not setup. Just you need to do sudo passwd root that's it. then you can do as normal logs as user.


0

I you want to disable shutdown command. cp /sbin/shutdown /sbin/shutdown-backup rm /sbin/shutdown this is because if someone tries to forcefully want to use this command, then also he cant now no one will be able to use shutdown command. it will display a message command not found install it. vim /etc/bash.bashrc Add a line in last of ...


1

You are asking no other user can do sudo to be a root user. you just need to edit a line in sudoers file. vim /etc/sudoers change the line from %admin ALL=(ALL) ALL to your-username ALL:(ALL) ALL after editing no other user except you can use sudo command. This is kicking all other users from sudoers file. except you.


0

Lshell is configured via an INI file. By default, it holds a whitelist of allowed commands, but it can be easily configured to prohibit user from using a specific command. http://unix.stackexchange.com/questions/90998/block-particular-command-in-linux-for-specific-user


0

You need to give each user a separate account (or create at least one non-admin user). Users in the admin group will be able to access root, via sudo -i or any other method.


1

Found the answer and maybe it's useful to somebody else. The thing is that, even after uninstalling the mysql server in order to install it again and try it over, the system didn't allow me to create a password. So I did uninstall it using sudo apt-get remove mysql-server and after that sudo apt-get autoremove, but that wasn't enough. The error was still ...


1

Don't be root, and don't use sudo -i when using SSH or sshfs. It may be that you're not in the fuse group, and so you don't have the permissions to use FUSE mounting. Do sudo usermod -aG fuse username, where username is your username, to add yourself into the group. Then, log out and log back in, and use SSH and/or sshfs under your user account.


2

The best thing to do is sudo su or su, then cd to /root. You can (if you want) string together commands like this: su -c "cd /root; dostuff", but the first way is easier if you need to get into /root.


1

What operation you are trying to do? You can run program as admin by typing sudo programname on a terminal. To open a terminal, press CtrlAltT.


0

I posted the same question on here. Again, a big thanks to grahammechanical for solving my problem. The solution: Delete the .bluefish folder from your root directory (since the problem occurred while I had root privileges): sudo rm -r /root/.bluefish Or, if you want to do it with the file manager, type sudo nautilus in your terminal press Ctrl + H (to ...



Top 50 recent answers are included