Hot answers tagged

17

That's not an error - it's telling you that you do not have permission to read the files in that directory as a normal user as you will see if you click on it. If you want to see the contents of the directory you must do so as root. In a terminal type: sudo -i nautilus You notice that you have to enter your password. Now you have root privilege you ...


4

Welcome to Security Whack-A-Mole, the game where you try to enumerate ALL the ways you can get hurt, and try to wrap each one in bubble wrap. You can never win. Rather, learn to use Unix/Linux tools, understand what your system does, and don't run scripts (or anything) you don't understand (that comes from an untrusted-for-system-upgrades source). Your ...


3

This is normal ... the X indicates you do not have permissions to view root folder ... If you want to use the file manager (nautilus) while logged in as root then from a terminal issue sudo -i then in same terminal issue nautilus once there you can see there is no longer the X


3

You may add your very own User with sudo rights. You can create a User and add this User to the sudo Group. sudo adduser youruser sudo Or if you already have a user, you can add this to the sudo Group. sudo usermod -a -G sudo youruser After this log in to this user with su youruser and try to run the installation again with sudo yourinstallcommand. ...


3

I think you're spending your effort on trifles. If Bad Guy can attach a terminal, Bad Guy can boot from his USB. But, since man securetty says securetty - file which lists terminals from which root can log in it implies that you could comment out all but TTY1. Commenting out (or not) lines for hardware you don't have makes no difference. Since, if you ...


3

In order to log in with a password to the root account over SSH, as well as setting the root password you need to set PermitRootLogin yes in the remote system's /etc/ssh/sshd_config file. NOTE: this is not recommended because it opens the root account to brute-force attack: if you need to log in to the root account directly over SSH (instead of logging ...


2

Fortunately this question has an answer that works. Using the root account is insecure and I understand that. The accepted answer there is going to help me a lot. Thank you for your suggestions, criticism, and help, bobbyblackblech, Pilot6, Serg, and Parto.


2

Your desktop is running under normal user and not as root user that is why you can access files created by root only via terminal


1

Ubuntu comes with sudo by default. sudo is a package/command that allows you to run any command/application as root (sudo stands for SuperUser Do). Your user is by default in sudoers file if you are administrator (who installs the system, per example). Simply type: sudo <command> Example: sudo gedit This runs gedit as root. BE EXTREMELY CAREFUL ...


1

You might likely solve with a sudo chown USERNAME:USERNAME -R /home/USERNAME where you substitute to USERNAME your user's name (the short one, without spaces and such that you can see at the beginning of the terminal line).


1

Following this post when I'm here I need to enter E (don't hit enter) to edit the setting. And then I navigate to this screen and go to the fourth line(starting with linux /boot/vm....to revovery \nomodeset) from the end and replace recovery \nomodeset with quiet splash rw init=/bin/bash. Last hit F10 to resume the booting, and you'll see a prompt and ...


1

You might want to think about why the members of the 'client' group can access root privileges in the first place. As far as sudo is concerned, those user's privileges are defined in the sudoers file, that you can edit with visudo (provided you have the neccessary privileges yourself). The sudoers file can be seen as a whitelist: Only those privileges ...


1

Since you've used a non-standard name for the key file (id_rsa_root instead of plain id_rsa) you will need to give it explicitly on the ssh command line i.e. ssh -i ~/.ssh/id_rsa_root root@slave Alternatively, you could set up a ~/.ssh/config file containing an entry for slave with the appropriate IdentityFile entry. See man ssh_config for details. As ...


1

If you don't want to install apps from the app store, because you don't want an Ubuntu One account, then you will have to build the packages from source and side-load them. You can side-load an app if you have the click package for it, by putting the click on the device, and running pkcon install-local --allow-untrusted foo.click for example. You can use ...


1

I also did this almost exactly. The way I solved it was I first restarted my device, went to advanced options, and launched recovery mode. This gives you a root shell to work with. In the root shell, you can use chmod 755 / (the default) and it will go back to normal. It works because root can read, write, or execute anything regardless of permissions.



Only top voted, non community-wiki answers of a minimum length are eligible