Hot answers tagged

21

NetworkManager is the program which (via the resolvconf utility) inserts address 127.0.1.1 into resolv.conf. NM inserts that address if an only if it is configured to start an instance of the dnsmasq program to serve as a local forwarding nameserver. That dnsmasq instance listens for queries at address 127.0.1.1. If you do not want to use a local forwarding ...


6

In Ubuntu 12.04 and later, /etc/resolv.conf is dynamically generated by the resolvconf utility. (Actually, resolvconf generates /run/resolvconf/resolv.conf and /etc/resolv.conf is a symbolic link to that. That's the default configuration; it is also possible to run with a static file at /etc/resolv.conf but that is non-standard.) Nameserver information ...


4

This was on Ubuntu server 12.04 LTS and Ubuntu 12.04 LTS Thanks all for the help. Turns out to be a result of a difference in the way host and the glibc resolver read /etc/resolv.conf. I was managing resolv.conf with a puppet module that edited the appropriate files in /etc/resolvconf/resolv.conf.d/. Said puppet module resulted in an /etc/resolv.conf ...


4

I think it would be beneficial to step back, teach a man how to fish instead of just telling you what's wrong. There are many components involved in making a good network connection It can be the hardware: ethernet card, cable contacts, network interface on your directly connected switch, etc. It can be the low level software: the kernel driver for your ...


4

It is possible that resolvconf is misconfigured. This is especially likely if you have been playing around with its configuration files without really understanding how resolvconf and NetworkManager work. For background information, please read the resolvconf documentation and Stéphane Graber's blog post. ...


3

The resolvconf records have names that follow the pattern IFACE.CONFIGURER So to force eth1* records to come before other eth* records you need to replace eth* with eth1* eth* After making this change, do sudo resolvconf -u


3

OK, I found a solution here which is to run sudo dpkg-reconfigure resolvconf In the interaction with dpkg-reconfigure, I answered YES to the first question and NO to the second one. This bug report may be relevant to the problem I had.


2

It worked for my grandfather, it worked for my father and it works for me. rm /etc/resolv.conf vi /etc/resolv.conf search yourdomain.com nameserver 8.8.8.8 nameserver 8.8.4.4


2

The /run mountpoint is supposed to be a tmpfs mounted during early boot, available and writable to for all tools at any time during bootup. What does this mean? This means /run is tmpfs which means data on it is not a permanent storage, it looks like the /tmp, so you can depend on saving any data there since this dir will completely wiped with ...


2

To undo the damage, do sudo rm -f /etc/resolv.conf sudo dpkg-reconfigure resolvconf


2

There can be only three nameservers in resolv.conf. If you remove one of the IPv4 nameservers the second IPv6 nameserver will be added.


2

Resolvconf generates /etc/resolv.conf using files in /etc/resolvconf/resolv.conf.d/ in the order: head, base, tail. The head file is almost always present and contains just the warning message about generated files. The base file may also be present, but is empty by default. There might be a tail file, and this is likely the culprit in your case given that ...


2

If you absolutely can't have resolv.conf be in an inconsistent state, here's what I did: The "state" of the resolver generated from the dns- lines in your /etc/network/interfaces is stored in /var/run/resolvconf/interface/(interfacename).inet - this file was truncated. The same data (search, nameserver, etc, same stuff that's in a completed resolv.conf) ...


1

Test this: Open a terminal,Press Ctrl+Alt+T Run it: sudo -i wget http://fr.archive.ubuntu.com/ubuntu/pool/main/r/resolvconf/resolvconf_1.69ubuntu1_all.deb dpkg -i resolvconf_1.69ubuntu1_all.deb


1

I think I have found myself the solution: adding supersede domain-name-servers 127.0.0.1; to /etc/dhcp/dhclient.conf does the job. So maybe it can be useful for someone else if I write my short howto to have pdnsd work in ubuntu with fixed (say, opendns) domain name server, regardless of the used connection. Disable dnsmasq by editing ...


1

Found it! Since a Ubuntu server autoconfigure itself via DHCP on installation it creates the file /run/resolvconf/interface/eth0.dhclient with the information about the wth.local domain : domain wth.local nameserver 172.31.0.5 Configuring a static IP won't delete the file and when you restart the network with the following command : ~$ sudo ifdown eth0 ...


1

As you quote it, your dhclient.conf lacks a terminating semicolon after each supersede statement.


1

I was initially thinking this was a bug, but I'm going to assume @Sander's answer is correct here. I'm not sure if resolvconf uses resolv.h or something else for the maximum nameserver value, though. Generally, instead of using resolv.conf, Here are a couple things to try: You could try editing dhclient.conf as suggested in the Google dev docs : prepend ...


1

A solution would be to run a local DNS server that can forward queries to other DNS servers based on subdomain/domain. Ubuntu's network-manager already runs a local DNS server (dnsmasq-base) however the required options are not available so disable it then install and configure the full dnsmasq package as follows: 1) Comment out dns=dnsmasq from ...


1

I contacted my VPS provider and they told me all DNS servers except their own are blocked in order to provide better DDoS protection.


1

First of all, you generally don't need to edit files in /etc/resolvconf/resolv.conf.d/ in order to obtain the desired behavior. Editing those files should be regarded as a temporary hack. Generally you want to configure your interface configurer (in your case NetworkManager) to behave the way you want. To remove nameserver 127.0.1.1 you did the right thing, ...


1

The rationale behind the introduction of dnsmasq as a local DNS relay is stated here in a blogpost by Stéphane Graber. Citing the main reason: This was done to better support split DNS for VPN users and to better handle DNS failures and fallbacks. This dnsmasq server isn’t a caching server for security reason to avoid risks related to local cache ...


1

One of the problems is that resolvconf did not get configured properly. Ref: https://bugs.launchpad.net/ubuntu/+source/resolvconf/+bug/1000244. To fix this, run sudo dpkg-reconfigure resolvconf This, however, can't be the reason that you cannot ping other machines by IP address.


1

It happens because the search feature supersedes the domain feature. Unlike domain, search accepts multiple arguments. Consider domain to be obsolete.


1

Make /etc/resolvconf/resolv.conf.d/base empty. The information in it is provided dynamically by dhclient to resolvconf. If you don't need to be running named locally, uninstall the bind9 package. If you need to run named locally and you don't want to use it to resolve names locally, set RESOLVCONF=no in /etc/default/bind9 and then reboot. Setting ...



Only top voted, non community-wiki answers of a minimum length are eligible