Tag Info

Hot answers tagged

70

I too had the problem that I could connect to a Windows 7 machine and suddenly (after weeks) I got this error: Unable to connect to RDP server In my case I deleted the entry from ~/.freerdp/known_hosts and it then worked fine.


37

Click Advanced tab in your Remote Desktop Preferences and choose RDP in Security drop down menu and save. So far it works for me.


17

Try to press right Ctrl and your keyboard will be fully functional in remote computer. You will be able to use Alt+Tab. Clicking on the "keyboard" icon (which means "Grab all keyboard events") does the same.


12

I have no idea why it worked, but I started changing settings one at a time. When I edited the connection properties, I looked on the "advanced" tab and changed the security from "negotiate" to "TLS", and voila, everything works. Strangely, "negotiate" still works on the laptop, but at least I'm back in business with my bigger monitor :)


9

I had a similar problem, getting the "Unable to connect to RDP server" message using Remmina and Ubuntu 12.04 to a Windows 7 machine. It worked fine for weeks and then suddenly stopped. What fixed it was going to ~/.freerdp/certs and deleting the problem server from that file. The next time it connected, it asked for a new cert and worked fine.


8

I found the key in a file called ~/.remmina/remmina.prefs and the encrypted passwords are in ~/.remmina/nnnnnnnnnnn.remmina. I wrote a code (in Go) which can be used for decryption. The code can be run online, but then you are trusting golang.org.


8

I was able to use the Go solution by @michaelcochez to decrypt it with Python: import base64 from Crypto.Cipher import DES3 secret = base64.decodestring('<STRING FROM remmina.prefs>') password = base64.decodestring('<STRING FROM XXXXXXX.remmina>') print DES3.new(secret[:24], DES3.MODE_CBC, secret[24:]).decrypt(password)


6

Does anybody knows how to avoid these messages Right-click to edit the connection Under the "Advanced" tab, set security to either: RDP (less secure, good for local networks) TLS (more secure, better for remote/WAN connections) Neither of these options will prompt you ever :)


6

I was able to install tsclient by downloading the natty package here: http://packages.ubuntu.com/natty/tsclient and installing all the dependencies. You'll notice that there is no libpanel-applet2-0 package anymore so when you install the .deb file run: sudo dpkg --force-all -i tsclient_0.150-4ubuntu2_amd64.deb


5

Remmina uses FreeRDP for RDP connections, but it looks like Network Level Authentication support was just added to FreeRDP in version 1.0. The best option would be to upgrade to Ubuntu 12.04, which includes Remmina 1.0. There's an updated version of remmina here, although I can't vouch for its stability: https://launchpad.net/~freerdp-team/+archive/freerdp ...


5

I had this problem. Like you I had no output when running remmina on the command line and the debug window was blank. I solved this by removing the line in the file ~/.freerdp corresponding to the problem server.


5

What you could try is in 'edit' 'preferences' 'applet' tab, uncomment the 'disable tray icon'. You should now get the icon in your panel, which you can click to unminimize. Hope this helps


5

You can use Remmina, which is default application for remote desktop in Ubuntu from version 11.04. From Remmina main menu select Tools -> Import and select your .rdp file. It will be imported and added to your saved connections in Remmina and you can use it anytime you start Remmina.


5

This just happened to me, and I found this answer which resolved the issue. Just rm ~/.freerdp/known_hosts and try again. Apparently this happens when the keys on the tunnel server change. See this bug.


5

Install Team Viewer application on both Ubuntu systems. You can view and control systems in bidirectional. TightVNC is a opensource remote control software package. With TightVNC, you can see the desktop of a remote machine and control it. You can get it here. You need to configure router


4

Vinagre (available in the Ubuntu repositories, goes with the builtin VNC server Vino) supports scaling the screen down. However, even when scaled, VNC works at the host's real resolution; so you're still sending quite a lot of data over the network in this case.


4

Yes, it is - in main! Remmina 1.0 was released on February 11, 2012 (source: Official Homepage) Remmina switched to FreeRDP since 0.8 (source: Official Wiki) The recent "change to FreeRDP" which may have confused you is just their moving to the FreeRDP GitHub for hosting their source code RDP support in Remmina is through FreeRDP only, via a plugin with ...


3

I have no idea why it worked, but I started changing settings one at a time. When I edited the connection properties, I looked on the "advanced" tab and changed the security from "negotiate" to "TLS", and voila, everything works. Strangely, "negotiate" still works on the laptop, but at least I'm back in business with my bigger monitor :)


3

I had the same problem. My solution was to use Windows-Key on my keyboard to deactivate the shortcuts. With Windows-Key + F it seems to can be activated again. Try it. Additional: The Num-block (NumPad) is working/active only if the Num-Button/Key is deactivated. I hope it helps. Regards Alexej


3

As far as I know, Remmina doesn't allow for RemoteApp client access. You can however do it with xfreerdp. Just use something like this on the command line: xfreerdp -u --app --plugin ./usr/local/lib/freerdp/rail.so --data "%windir%\system32\cmd.exe" -- <ip of your windows machine> or /usr/bin/xfreerdp -u --app --plugin rail.so --data "||" ...


3

The files you need are in ~/.remmina (the hidden .remmina folder in your home directory). For SSH, the known hosts are stored in ~/.ssh/known_hosts.. All your user settings, preferences, etc for your user are stored in your home directory, as that is the only folder you by default have permissions to access.


3

You can do it with FreeRDP (freerdp-x11 package) via terminal: xfreerdp +drives /u:username /v:server_address:server_port +drives tells FreeRDP to connect all your local drives. If you dont have it you can install it: sudo apt-get install freerdp-x11


3

You can record a vnc session without even opening a VNC client using vnc2flv: http://www.unixuser.org/~euske/python/vnc2flv/ It does record in flv but there should not be a problem to convert the output to anything else you need.


3

I found out the solution: just rename the Quick Connect appearing in the TextBox to your favorite name, and it is done!


3

Summarizing from comments The two computers are connected to the Internet by mobile (cell phone) data network. I will refer to the cell data service provider as the "Internet Service Provider" or ISP. There are two issues: The ISP is providing the NAT (Network Address Translation) service such that the computer has an internal IP address and an external ...


2

Forgettaboutit! You've done nothing wrong. You are just geting NATed by your mobile providers. On both ends. with no control over the routers. That's the worst case imaginable. I recommend splitting your question in two: How can you get any connection running between the machines. If you got that far, you can see how to get a desktop connection. I ...


2

Did you "Open Main Window" -> select the connection, and then click the "Edit" button? I've had better luck with the settings 'sticking' by using this dialog, while the connection is not open, rather than by using the "Jump to" menu item, 'quick connect' thing.


2

This might help how to save passwords in remmina Go to dash type 'passwords' and click password and keys. We need to create a new key for ssh logins, so select 'Secure Shell Key' Type in any name for your ssh key. Type in a new pass-phrase for the key, this can be anything string or even empty which is not recommended of course. Now that the ssh key-ring ...


2

I copied the .remmina files back over when upgrading from 11.10 to 12.04 I found that this is happening only on Windows 2008. Possibly a RDP6 issue. This was solved because security somehow got reset to 'Negotiate'. I changed Advanced/Security to 'RDP', and all is working again.



Only top voted, non community-wiki answers of a minimum length are eligible