Tag Info

Hot answers tagged

32

Realtek is making the official Linux driver available unofficially (via Dropbox) Support for the RTL8273AE-BT has been added by Realtek in the 92-series driver, version 0006.0514.2012. For unknown reasons, neither the Windows nor Linux drivers are available on their website (yet). But Realtek tech support has been providing a Dropbox link with the source ...


18

Ubuntu 13.04 and newer As of 13.04, the driver need not be compiled and installed separately, and comes integrated with the kernel as the rest of the drivers. 12.10 and older Congratulations, you have the super-brand-new RTL8723AE-BT card! As far as I am aware, even hardware requiring proprietary drivers to function would at least be recognized in ...


15

Update: as of 14.10 utopic, there is a semi-working driver included by default, but it frequently disconnects and has difficulty reconnecting. The best solution is to continue to build the lwfinger driver as described below and then blacklist the driver included in Ubuntu. That how-to link is outdated; the latest version of the rtl8723au wireless driver ...


12

Download the official realtek driver. http://www.realtek.com/downloads/downloadsView.aspx?Langid=1&PNid=5&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false#2 Then remove the r8169 module from the linux kernel. # rmmod r8169 <Quick install with proper kernel settings> Unpack the tarball : # tar vjxf r8168-8.aaa.bb.tar.bz2 ...


9

Commenting out/removing the IEEE80211_HW_BEACON_FILTER (line 320 in base.c) makes it possible to compile when using the 3.4 kernel. So far I haven't experienced any problems. The card seems to work as it did before, although it might be less power-efficient. I can't guarantee it won't cause any problems, but it's better than nothing. Well, then ...


8

Just so I can find this next time my SSD blows up. Here are instructions for removing the broken r8169 and inserting r8168 on Ubuntu w/Linux Kernel 3.x. Kernel 3.x Download r8168 Apply this patch if it is still marked unresolved. STOP: If you plan to use DKMS, skip to the DKMS section now. Run sudo ./autogen.sh, it will build the module, remove the old ...


8

to solve the "linux/smp_lock.h not found" error you need to edit this two files into the archive driver/rtl8192_8188CU_linux_v3.1.2590.20110922.tar.gz file 1: include/rtw_io.h Change osdep_service.h (line 49) linux/smp_lock.h to linux/smp.h file 2: include/osdep_service.h Change file rtw_io.h (line 36) linux/smp_lock.h to linux/smp.h


8

Apparently the Linux headers have changed enough since 13.04 to break this driver. After many days of work I have finally fixed the compile issues and gotten the driver working. You can find the fixed driver, along with the detailing of all of my changes from the original version released by Realtek, at my Github repo here: ...


7

Do sudo apt-get install firmware-realtek and the problem should be solved


7

I think you may be confused by what you read on forums, AU, etc. because there are two revisions of the USB-N13: A1 (with a Ralink chipset), and B1 (with a Realtek chipset). Based on the lsmod output you included (rtl8192...), and the WikiDevi page linked above, you have the B1 revision with the RTL8192CU chipset. A. Downloading, compiling and ...


7

I finally found the cause thanks to this link: https://bbs.archlinux.org/viewtopic.php?id=149817 It seems that one shouldn't have spaces in the folder names (containing the driver of course) when building the driver. Replacing the spaces with underscores fixed the issue. I could build just like that. Strange... but it worked ! Many thanks for the help in ...


6

The author merged in DKMS support a few months ago, but didn't integrate it into the make install process. Following these commands will add it to DKMS so you don't have to manually recompile after every kernel update. From https://github.com/lwfinger/rtl8723au/blob/master/README.dkms: To get DKMS to work: Install dkms Copy this source to the directory ...


6

The driver code from Realtek uses some functions (kernel_thread() and daemonize()) that have been removed from newer kernels. Fortunately, a helpful person on Github has ported the Realtek driver to the new APIs that accomplish the same thing in 3.8+ kernels. The port is available at: https://github.com/dz0ny/rt8192cu To install the ported driver (assuming ...


6

I encountered the same problem after upgrading to 12.04. The following solution worked for me: Open this file in a text editor as root: gksu gedit /etc/network/interfaces Add these lines to the file: auto eth0 iface eth0 inet dhcp Save the file and quit the text editor. Now restart the network: How to restart the networking service?


5

The ALFA AWUS036H adapter is based on the Realtek RTL8187 chipset. The drivers should be built into Ubuntu, but you may want to try installing the latest from Realtek: Download the "Linux driver for Kernel 3.0.0/3.1.0/3.2.0" from the Realtek website here. It will open in Archive Manager; extract the rtl8187L_linux_1041.0209.2012 folder to your Downloads ...


5

I've emailed Realtek techsupport, and they've sent me some new driver (zip), that should suit this card. Download - http://www.mediafire.com/?sanq19s3vv1d9c9 I'm actually trying to get my Yoga's onboard Wi-Fi with this. Hope that helps someone.


5

12.04 & 14.04+: you can view these instructions or just do as I say. (use these instructions when your wireless USB device [rtl8192cu] is not automatically recognized by Ubuntu) sudo modprobe rtl8192cu echo "2001 330D" | sudo tee /sys/bus/usb/drivers/rtl8192cu/new_id echo "rtl8192cu" | sudo tee -a /etc/modules Then, edit /etc/rc.local by opening the ...


5

If you run into this problem, what worked for me was installing the following driver: https://github.com/pvaret/rtl8192cu-fixes From the README.md file: Installation Ensure you have the necessary prerequisites: sudo apt-get install linux-headers-generic build-essential dkms Clone this repository: git clone ...


5

We are going to need more info to be able to help you. Like what type of wireless adapter are you using and what Ubuntu version are you using. ------ TRY 1: Failed One generic tip is to System->Administration->Hardware Drivers. Maybe you need to download some driver. If your wireless card is listed in the window that opens, please click the button to ...


5

A bit late in the day but I recently got similar static background noise issue with my laptop's internal microphone (same Realtek chipset I believe but solution should work for all soundcards). After looking around, there is indeed a way to reduce noise in realtime in pulseaudio using webrtc echo-cancel plugin (the default speex echo-cancel in Ubuntu/Mint ...


5

First in your router change 802.11bgn to 802.11bg. Second change the wep encryption to just wpa2 (CCMP)(AES) not (TKIP) if you have that option it will work best. Third set your wireless channel in the router to 1 or 11 then save the router configuration and reboot it. Fourth go into network manager at top right corner of the screen and click on edit ...


4

This is a problem that I have also been experiencing. To solve it you need to upgrade your kernel manually. I upgraded to 3.14.1 personally. Here is a guide on upgrading the kernel manually: How to update kernel to the latest mainline version without any Distro-upgrade? EDIT: I also didn't realise when I posted this, but I have the same wireless card as ...


4

There's a solution at http://www.davidgis.fr/blog/index.php?2011/05/06/800--resolu-solved-w-possible-missing-firmware-lib-firmware-rtl_nic-rtl8105e-1fw-for-module-r8169. Essentially you need to do: git clone git://git.kernel.org/pub/scm/linux/kernel/git/romieu/linux-firmware.git sudo cp -r linux-firmware/rtl_nic/ /lib/firmware/ and then sudo ...


4

I finally fixed this problem by compiling and installing the latest drivers from Linux Wireless in Ubuntu 12.04, in my case the "compat-wireless-3.5.1-1-snpc.tar.bz2" package: http://wireless.kernel.org/en/users/Download/stable/ One needs the header files for his kernel and the build-essentials package. I recommend also to run the script "driver-select" ...


4

I had the same problem and here's how I solved it. The summary is the built-in driver didn't work work completely, and I downloaded installed the manufacturer's driver instead, making sure the new driver was set to start on boot while the built-in driver was blacklisted. Search on the Realtek site for your hardware. For me, I used lshw -c network to see ...


4

I talked with a support guy from Realtek and received the very same files hosted on Dropbox submitted by another user on this question. I compiled the drivers as the readme instructed and it worked, you might need to copy the 8723* firmware files into the rtlwifi folder. It should be said however that this solution is not perfect, I have some pretty shaky ...


4

I just had this exact same problem a couple weeks ago, so I put a working driver up on my Git Hub. I also changed it so that it does away with the 20 dBm Tx Power limit and let's you go up to 33 dBm. The instructions are in the repo. You can clone this with: git clone https://github.com/FreedomBen/rtl8188ce-linux-driver.git If you don't have Git ...


3

Anatol, I experience a similar problem with my laptop. However, when I do sudo iwconfig wlan0 txpower 30 ...then, sudo iwconfig wlan0 essid MyESSID key xxxxxxxxxxxx ...I get connected. I have a modem very close to my desktop, with no wall interfering, and sometimes I connect, sometimes not. Then I guessed maybe a power issue was the cause. In my case, ...


3

I was getting this error while trying to compile the rtl8192cu driver under Linux 3.8.X: I have patched the osdep_service.h file. I have added this line: void daemonize(char *, char *); just before these lines: inline static void thread_enter(void *context) { #ifdef PLATFORM_LINUX //struct net_device *pnetdev = (struct net_device *)context; ...


3

Putting this into /etc/modprobe.d/rtl8192.conf options rtl8192ce ips=0 fwlps=0 debug=2 then restart, fixed it for me.



Only top voted, non community-wiki answers of a minimum length are eligible