Tag Info

New answers tagged

0

You can create a python script from any text editor. I spend most of my time in shell so I use nano. nano test.py Python scripts end in .py The first line is your shebang. In this case it would be #!/usr/bin/env python After you write the script you will want to make it executable chmod +x test.py From here you can run the script by calling ...


0

1. To create a python program. - Type the name of your favourite text editor and the path to your new file. For example, nano /home/username/Documents/ newfile.py Python scripts should have .py extension. 2. To edit a python script. - Again the name of a text editor a path to your existing file. nano /home/username/Documents/ newfile.py 3. To ...


1

I was able to resolve this issue by removing my matplotlib font cache (both the Python 3 and Python 2 font caches), e.g., rm /home/arthur/.cache/matplotlib/fontList*.cache I can now use any other following environment initializations without errors: ipython3 --pylab ipython3 --matplotlib tk ipython3 --matplotlib qt4


0

py3clean and py3compile should be in python3-minimal. Try to install it first: sudo apt-get install python3-minimal Update question if you get any error.


3

You can use pip3 (which is just normal pip but in system's Python3 packages). Normally I would suggest avoiding using pip for installing stuff globally but given there are no packages for this that could overwrite the files, there's nothing to lose. It's quick and simple: sudo apt-get install python3-pip sudo pip3 install sympy


0

Finally, I considered installing iPython Notebook system-wide (outside a virtual environment). I had previously tried just install pyzmq system-wide but this wasn't enough. When I considered install iPython Notebook outside the virtual environment, I realized, "How do I get pip to discriminate between Python 2.7 and Python 3.4?" I went searching and found ...


1

Ubuntu 14.10 comes with Python 2.7.8 (available as python, python2 and python2.7) and Python 3.4.2 (available as python3 and python3.4) installed by default. As many programs depend on them you can't remove any of them without breaking your system.


0

Ubuntu 14.04 comes with mod_wsgi 3.4. According to https://code.djangoproject.com/ticket/22948#comment:2 we need to use mod_wsgi version 4.2+ for Python 3.4. The best way to install mod_wsgi to the latest version is to get it with pip (can be in virtualenv) and then install its module to apache system-wide. In my case I use virtualenv set in /venv_path. 1) ...



Top 50 recent answers are included