Tag Info

Hot answers tagged

13

You can also run init-checkconf to check syntax init-checkconf /etc/init/job.conf File /etc/init/job.conf: syntax ok


9

It usually means you have an error in the .conf file - for instance I'm not sure the pid stanza is supported in 10.04, stop can't be used in the script etc. I'd try starting the file from scratch (with only start, stop etc), and then slowly building it up by adding more and more lines and testing it via start pure-ftpd. For example: # cat pure-ftpd.conf ...


9

First, you can check that your job is actually known to upstart: sudo initctl list | grep your_job_name If it's not found, you can try reloading the configuration and then re-checking: sudo initctl reload-configuration # re-check sudo initctl list | grep your_job_name Then try again to start your job: sudo start your_job_name If you weren't getting ...


5

The most relevant reference for job file syntax will be available when you run the command: man 5 init on your system. For Ubuntu 10.04, as you found in the previous answer, the pid file syntax is incorrect. Any time you get that 'unknown job" error back, its a good idea to check the logs (pre 11.04, /var/log/daemon.log, 11.04 and greater everything goes ...


3

Most services allow you to change startup params in /etc/default/NAME. If not, you'll have to edit /etc/init.d/NAME (or /etc/init/NAME.conf for Upstart scripts). Do not forget to restart the service, that's not automatically done for you.


3

The following command gives you the installed version, if you installed the package via the ubuntu repository apt-cache policy pure-ftpd


2

Anyway I'am here because i had the same problem, but my syntax was 100% correct. After some debugging I discovered another issue that can cause this "Unknown job" error: upstarts uses inotify to monitor .conf file changes and auto install jobs, this is very cool (for this you don't need something like update.rc with upstart!) but can be not perfect if you ...


2

Install Pure-FTPd root@www:~# aptitude -y install pure-ftpd run as a daemon root@www:~# echo "yes" > /etc/pure-ftpd/conf/Daemonize prohibit Anonymous root@www:~# echo "yes" > /etc/pure-ftpd/conf/NoAnonymous enable chroot root@www:~# echo "yes" > /etc/pure-ftpd/conf/ChrootEveryone only IPV4 root@www:~# echo "yes" > /etc/pure-ftpd/conf/IPV4Only ...


2

I found the default IPTABLES configuration at /etc/default/iptables and added the following and restarted the iptables service and ftp is now working: -A INPUT -p tcp --dport 20 -j ACCEPT -A INPUT -p tcp --dport 21 -j ACCEPT


1

Yes, some ftp servers can handle virtual users, ex. vsftpd and pureftpd.


1

Open your Terminal and type the following command apt-cache showpkg pure-ftpd


1

The problem is the HTTP server since (by default) scripts are run as the www-data user. To continue your analogy, Steve likely has file permissions for /var/www/steve/somefile set to 755 - which grants read and execute permissions to any user. Because Apache executes PHP scripts as the www-data user, PHP scripts won't encounter any problems accessing the ...


1

I have solved my own issue. Though i would not recommend this, After all the un-install processes failed, i eventually gave in and manually located all the remaning files that had anything to do with pure-ftpd and removed them all manually, this then allowed the removal to complete. Using Webmin file manager I did a search for everything that matched ...



Only top voted, non community-wiki answers of a minimum length are eligible