New answers tagged

0

Same problem here. a2dp not working properly. This workaround solve for me.


-1

Same problem right here. Do you have fixed it already?


1

As of 16.04, things become a lot simpler :) Just install qjackctl and pulseaudio-module-jack module: apt-get install qjackctl pulseaudio-module-jack Then configure qjackctl to run the following command after startup. Copy it into "Setup..." > "Options" > "Execute script after Startup": pactl set-default-sink jack_out And that is. Pulseaudio will ...


1

Case 1 - Tick EQEnabled and keep settings Case 2 - If it not save open dash and search for startup application search for pulse audio sound system if it disabled enable it. Case 3 - if the pulse audio sound system not found add click add In name section type: PulseAudio Sound System. In command type: start-pulseaudio-x11. In comment type: Start the ...


0

Before anything, make sure your sound is not muted. ALSA and Pulse don't get together well. They are conflicting each other most of the times. Unless ALSA is specifically required by an app or hardware i recommend using only Pulse (it's newer and better). First, remove alsa completely by opening a Terminal window and typing: sudo apt-get remove ...


0

sudo apt-get install pavucontrol, can you try?


2

There are several bugs opened about this, check for example this one (started in 15.05) and this other one, quite older; the causes in general are not well understood. The fix that worked for me is the following --- thanks to user RobertFM in launchpad and SimFox3 in Arch forums. All the following instructions must be executed from a root shell (sudo -i). ...


0

Funny enough for me in similar situation helps changing display resolution from 1280x720 16x9 to 800x600 4x3. HDMI sound appears in 100% cases! Then I switch resolution back, sound sometimes stays. Not for long though. aplay -l **** List of PLAYBACK Hardware Devices **** card 0: PCH [HDA Intel PCH], device 0: ALC662 rev3 Analog [ALC662 rev3 Analog] ...


0

Found out that somehow my output was changed from the internal sound card to the HDMI output. I had to go into pulseaudio and change the output which solved my problems.


0

Alright, I think I've got something you can try. If you search for Multimedia Systems Select on the Dash. Open it and go to the Audio tab, where you can select the default audio Input and Output devices. This should be installed by default. If it isn't, you can always run sudo apt-get install gnome-media. If it is not shown in the Dash, run: gksudo gedit ...


0

In my case, this was solved by: pactl load-module module-bluetooth-policy pactl load-module module-bluetooth-discover


0

After searching and fiddling around some more, I finally found an interesting Archlinux wiki entry, which allowed me to come up with this piece of code to be added at the end of /etc/pulse/default.pa: load-module module-remap-sink sink_name=KompleteAudio6_12 sink_properties=device.description="Komplete\ Audio\ 6\ Output\ 1/2\ (Main)" remix=no ...


2

Yes you can create a pulseaudio profile to get the Focusrite 18i8 working in stereo. Create the file /lib/udev/rules.d/91-pulseaudio.rules: SUBSYSTEM!="sound", GOTO="pulseaudio1_end" ACTION!="change", GOTO="pulseaudio1_end" KERNEL!="card*", GOTO="pulseaudio1_end" SUBSYSTEMS=="usb", ATTRS{idVendor}=="1235", ATTRS{idProduct}=="8014", ...


0

Well, something must have happened in an update lately, because now it works properly. Plugging in headphones even comes up with a new dialogue asking if it is a set of headphones or a headset being plugged in (something I've never seen before).


1

For me, Tim's code didn't quite work. I had to do this: import alsaaudio m = alsaaudio.Mixer(alsaaudio.mixers[0]) # alsaaudio.mixers = ["PCM"] for me. m.setvolume(90) # Or whatever It may be due to my weird / broken .asoundrc config file. But given that there is no actual reference documentation for .asoundrc - just some random examples - I don't think ...


0

Based on the line "active profile: <off>" the sound profile didn't activate. One program that is easy to use to change the profile is pavucontrol. You can install it with sudo apt install pavucontrol -y. Then run pavucontrol from the command line or Alt+F2 if you are on Kubuntu and entering pavucontrol. Select the configuration tab and then try ...


0

First install pulseaudio using apt (sudo apt-get install pulseaudio). Then set it as the default audio system where you set the default programs in Lubuntu (it will replace alsamixer) and then install pulseaudio-equlizer (sudo apt-get install pulseaudio-equalizer).


0

If your sound devices are 0 - HDMI and 1 - analog, you can switch to headphones with $ pacmd set-sink-port 1 analog-output-headphones To make it permanent, edit /etc/pulse/default.pa and at the bottom under ### Make some devices default put: set-default-sink 1 set-sink-port 1 analog-output-headphones Everything should work now as desired. Make sure ...


0

Ich bin enttäuscht mit den immer gleichen Problemen ob Windows oder Ubuntu.ich habe Ubuntu 16.04 installiert weil bei Windows 10 gibst Problem mit Nvidia Grafik jetzt mit Ubuntu habe ich kein Ton, aber mit einem Bluetooth Lautsprecher habe ich wieder Ton. Trotzdem hoffe ich auf eine Lösung von Ubuntu.


1

I follow MttG in #2 but not work, it only show HDMI card, my system: core i5 6500 skylake, realtek ALC887 and using gtx 950 with HDMI to monitor, so, AFTER LONG TIME I FOUND: sudo gedit /etc/asound.conf That show: defaults.pcm.card 1 defaults.pcm.device 1 BUT my device 1 is HDMI, and DEVICE 0 is REALTEK, I edit that to: defaults.pcm.card 1 ...


0

I finally figured it out! You'll probably need to change the "grep -v" part of lines 3 and 4 depending on your sinks (and use egrep -v "sink1|sink2|sink3" to exclude multiple sinks). To run the script: bash (not sh) /path/to/script [-headphones, -speaker]. I set up custom keybinds in the settings menu that run the script with the different arguments. The ...


0

My take on this would be the following taking advantage of PulseAudio. Assuming that when you log in Ubuntu, you always have your headphones connected, then the following will make sure that when you boot to Ubuntu it will automatically set it as the default Input and Output (Assuming you want both). On Ubuntu go to the terminal and type the following from ...


0

I have the same issue. The funny thing is that I can hear the sound of the login screen. What I also figured out is that VLC works if I configure audio to use ALSA. That makes me think the pulsaudio stuff is broken. After knowing that I started pulseaudio. I switched configuration, internal device, to Analog Stereo Duplex. It was configured to use Digital ...


0

I still do not understand why there was a problem, but reinstallation of alsa worked for me. sudo apt-get remove alsa-utils sudo apt-get install alsa-utils


1

The issue is that Ubuntu 16.04 defaults to HDMI as default audio if HDMI is present on your computer. In my case, it does see my Sound Blaster Audigy 2 card, but HDMI (from my video cards) is set as default; and the way to change that differs from how you did that in 14.04. The files, folders and procedures almost work, but don't if you follow 14.04's "No ...


0

The following should help you workaround the problem until you find a fix to your issue. The following are a couple of scripts which do not do what you want, but probably contain all the pieces for what you need. The second one contains a bunch of pulseaudio stuff that works, but which I don't really understand. I apologize in advance. ;) Here's a script ...


0

the fact is that is really simple: the graphic card isn't a sound card, so the solution is connect the spdif motherboard's/soundcard's connector to the nvidia's connector spdif in and select spdif in audio output in sound preferences.


1

Close any open audio programs. Stop the daemon from respawning: sudo nano /etc/pulse/client.conf Uncomment the line that reads: ; autospawn = yes to say: autospawn = no Then press CTRL+X to save these changes. Stop the existing PulseAudio daemon from running: pulseaudio --kill Now try playing an audio file from a media player of your choice. ...


0

The HDA audio chips need sometimes a manual intervention to make them work correctly. Try the following and see if it corrects your issues: sudo modprobe -r snd_hda_intel sudo modprobe snd_hda_intel model=dell repeat both steps with model=lifebook and model=laptop-amic instead of model=dell if the first step was not successful. If you are happy with one ...


0

Try this: sudo /etc/init.d/bluetooth restart pulseaudio -k pulseaudio --start Then go to the audio manager, and make sure the program that's generating audio has the Bluetooth "sink" as output. Reference link - https://github.com/blueman-project/blueman/issues/304


0

I had this problem when I installed pulseaudio and then removed it. I am not sure how to fix it myself, but installing pulseaudio might do the trick. pulseaudio is needed for skype and maybe other programs. So maybe you removed them. Hopefully someone can comment or edit this answer to fix the problem better.


0

You can use amixer to read the pulseaudio volume by using the mixer option like this. $ amixer -c $CARD -M -D $MIXER get $SCONTROL # CARD is your sound card number, mixer is either alsa or pulse and scontrol is the alsa device name, Master if you want to use pulse. $ amixer -c 1 -M -D pulse get Master Simple mixer control 'Master',0 Capabilities: pvolume ...


1

I deleted pulse directory inside .config directory in my home directory and then my sound is flying like rocket now .


0

What worked for me was moving ~/.config/pulse to ~/.config/pulseold. Re-installed my base system and seems that pulseaudio kept crashing trying to use my old configs.


0

In addition to changing default-sample-channels in /etc/pulse/daemon.conf, it was also necessary to launch alsamixer and change the number of channels to 6: Note: you may need to restart between changing daemon.conf and using alsamixer.


1

Basic system software packages like ubuntu-desktop, unity-control-center and unity-control-center-signon depend on the pulseaudio package. If you uninstall pulseaudio, those packages will be removed too, leaving your system pretty empty. To fix this, you could reinstall those packages using the package manager: sudo apt-get install ubuntu-desktop ...


2

The problem turned out to be more complicated than originally thought and kept re-appearing on reboot. Thanks a lot to @nakasya for pointing out that it's a bug in fwupd that appeared when upgrading to Ubuntu 16.04. Refer to Problems with Audio device - Ubuntu 16.04 . The temporary workaround until the fix is included in the main release is to run sudo ...


0

I was having this exact same issue after upgrading to 16.04 with my Focusrite Saffire 2i4, I finally found this and fixed it with this command, then rebooting: sudo apt-get remove fwupd You probably don't want to do that if you actually need fwupd, but it looks like there's already a bug report out there, hopefully it will get fixed soon.


0

I've had the same problem with elementary 0.3.2. It looks like the cause of the problem is not the buffer size, but rather the network manager, which apparently intermittently has the WiFi device scan for networks. This seems to interrupt the stream, so independently of the buffer size there are little parts of the stream missing, which produces the ...


10

I had the same problem after upgrading to 16.04. For me, there isn't a real fix, but I can get the speaker to work. I'm running Kubuntu so these steps are for KDE, and I'm not sure what the equivalent Unity steps are, but I'd imagine they're similar. Here's what I did: Let the speaker connect. In your audio settings, change the profile to "Headset Head ...


0

I found an answer that worked for me with a similar issue. Changing default-fragment-size-msec to 5 instead of the default 25 in /etc/pulse/daemon.conf (on Ubuntu 16.04, at least) and restarting the PulseAudio daemon helped fix the issue for my needs. Might be worth a shot if you haven't found another solution yet.


0

I had the same problem. On https://wiki.archlinux.org/index.php/Bluetooth_headset I found this: Note: The device may be off by default. Select its audio profile (OFF, A2DP, HFP) in the "Configuration" tab of pavucontrol. After selecting A2DP there was sound.


2

I started reading a lot about PulseAudio and "hidden" options it had so I could find one that was similar to this question. The one I found was the noise-cancellation module, which is one that dramatically lowers any static noise on the microphone and even A LOT of the background noise, basically giving you the benefit of only recording your own voice with ...


0

I had a similar problem but I after trying many things including uninstalling and reinstalling alsa-base and pulseaudio, what finally worked is the removal of the pulse folder under the .config folder inside my home folder.


0

Hi i think you should install ubuntu-restricted-extras package At first you should update the repositories with this: sudo apt-get update and then: sudo apt-get install ubuntu-restricted-extras


0

In the file /usr/bin/start-pulseaudio-x11 I have /usr/bin/pactl load-module module-x11-xsmp "display=$DISPLAY session_manager=$SESSION_MANAGER" > /dev/null That > /dev/null is in several spots of that file. Entering pactl load-module module-bluetooth-discover in terminal has worked after I made the changes suggested above, but sometimes not. The ...


0

I had the issue. For me worked to remove the bluetooth device and search for it again and reconnect.


1

It seems that this user-interface aspect is being redesigned at the moment. There is a blog post that is describing the problem, proposing a solution, and requesting feedback. Do check it out here: http://davidrosca.blogspot.ca/2016/04/audio-volume-improvements-in-plasma-57.html



Top 50 recent answers are included