Tag Info

Hot answers tagged

2

you are tying to use a http_proxy environment variable with HTTPS url https://install.meteor.com/ . To set your HTTPS proxy use HTTPS_PROXY environment variable (all upper case) from manual for curl Curl reads and understands the following environment variables: http_proxy, HTTPS_PROXY, FTP_PROXY


1

You're using sudo in the wrong place, doubly so: sudo resets some environment variables, so your HTTPS_PROXY is not reaching curl in the first place. The sh command should be run with sudo, if the script needs it. Do: curl https://install.meteor.com | sudo sh


1

According to the connect manpage: ENVIRONMENT SOCKS5_USER, SOCKS5_PASSWORD, HTTP_PROXY_USER, HTTP_PROXY_PASSWORD, CONNECT_PASSWORD, LOGNAME, USER So it looks like you could export your proxy password in the HTTP_PROXY_PASSWORD variable. Something like: export HTTP_PROXY_PASSWORD=mypassword in ~/.profile.


1

You are facing two problems: add-apt-repository is relying on the existence of the correct http_proxy and https_proxy values. sudo will not use all of the current environment values. Probably for security reasons. There are two possibilities how to overcome this: Call sudo -E add-apt-repository <additional-options> This will use all of the ...


1

Okay, Here is what i did... I just needed a 'Proxy Mode Changer'... Setting the proxies , i did through gui... Now i just needed changing mode... Here is the script i made... SIMPLE as anything -> #!/bin/bash state=$(gsettings get org.gnome.system.proxy mode) if [ $state == "'none'" ]; then gsettings set org.gnome.system.proxy mode 'manual' ...



Only top voted, non community-wiki answers of a minimum length are eligible