Hot answers tagged

3

dconf is the place to check in this situation. dconf is a low-level configuration system and settings management. Its main purpose is to provide a back-end to GSettings and KSettings on platforms that don't already have configuration storage systems. It depends on GLib. It is part of GNOME 3 and is a replacement for GConf. ~Wikipedia For this you ...


3

When a machine goes into the suspend state the kernel freezes (stops) user space programs and kernel threads. Then the kernel will traverse all the devices and calls the suspend methods on each driver. Each driver has the know-how to put the hardware into a deep sleep state (or even power it off) (and the converse to bring it back to a sane running state ...


2

This was tested and validated to work on Ubuntu 12.04 x64 - 14.04 x64 and Linux Mint 16 x64 - 17.3 x64 and Samsung NP300E5Z laptop. Essentially, we need to change content of /sys/devices/platform/samsung/battery_life_extender file to 1 or 0. To turn on Battery Life Extender (run command from bash console): sudo tee /sys/devices/platform/samsung/...


2

You can use gsettings for enabling and disabling monitor from going to sleep: Disable turning off screen gsettings set org.gnome.desktop.session idle-delay 0 Enable turning off screen with 5 min delay gsettings set org.gnome.desktop.session idle-delay 300


2

CLI version of @Dhaval-Simaria's answer: gsettings set org.gnome.desktop.media-handling automount-open false Note that Ubuntu comes with gsettings; it does not need to be installed. Edit for updated info: Since the error messages are reporting a failure to mount, try disabling automount: gsettings set org.gnome.desktop.media-handling automount false


1

I had the exact same problem a few months ago, I resolved it by installing : sudo apt-get install laptop-mode-tools. I'm not sure why it worked but I forgot to care Other thing you could try is disabling the Wake-On-Lan feature of your motherboard, if the solution above doesn't do the trick. To do this, you should get to your BIOS (Usually press F2 or DEL ...


1

Caffeine You could give caffeine a try - quoting the launchpad page: A status bar application able to temporarily prevent the activation of both the screensaver and the "sleep" powersaving mode.


1

I had the exact same problem last year for backups that took several hours! You can try Keep.Awake https://launchpad.net/keep.awake It can monitor CPU load, network traffic and user activity for minimum thresholds. I still haven't gotten around to creating a snap or deb for it. However temporarily you can download the program from Launchpad here The ...


1

This error occurs because the ACPI _PMC (Power Meter Capabilities) object for that device ACPI000D (the power meter) has bit 0 set that indicates that the device supports power measuring capability, however, the kernel driver has detected that the hardware does not support this feature and hence reports that the power capability is probably dubious and so ...


1

Install tlp or laptop-mode-tools but not both.


1

What you're describing has to be a failure of either the battery voltage sensor, Ubuntu's driver or handler for that sensor, or of the battery itself. Long run life rules out bad cells that would display as a dead battery, so it's either a sensor failure or a software issue. Try booting from live media (DVD or USB) and see if the battery display still ...


1

The installation of tp-smapi-dkms failed at some point. As you have a T460s i reckon you're using a 4.6 kernel. tp-smapi-dkms 0.41-1 from the Xenial repos doesnt't compile with that kernel. Only 0.42-1 from Yakkety or Debian unstable will do. BUT: tp-smapi won't work on the T460s anyway (and is not needed), so just remove it and you'll be fine: sudo apt-...


1

Seems to match something I've seen already for 14.04: https://bugs.launchpad.net/ubuntu/+source/xubuntu-default-settings/+bug/1303736 File a new bug, and for now try the workaround from here: map some key combination to: xrandr --auto and you'll get your screen back by pressing it.


1

Try adding the following: [Service] StandardOutput=tty ....


1

Note: All command below need root power, so switch to root shell first using sudo -i or sudo su. If you want to run directly with sudo <cmd>, see When using sudo with redirection, I get 'permission denied'. Set udev rule for libmtpto ignore your phone model: sed 's/LABEL="libmtp_usb_rules"/LABEL="libmtp_usb_rules"\n\n#Masi, ignore my phone\...


1

If you run Xubuntu this is really easy because it has a configuration panel to select automount behaviour. Just go to Settings > Hardware > Removable Drives and Media, then untick the relevant options:


1

You should look into udev rules. With them you can block one device without affecting any other USB devices. You can define your own udev rules by creating a file in /etc/udev/rules.d/, e.g. /etc/udev/rules.d/51-block-phone-mount.rules Now find the idVendor and idProduct of the device. Those are good to use since they are mostly unique to the product, so ...



Only top voted, non community-wiki answers of a minimum length are eligible