Hot answers tagged

10

Just installed the same printer on Quantal 32bit edition (canon pixma IP1300).... These are the steps you should try: 1) Add repo: sudo add-apt-repository ppa:michael-gruz/canon-stable 2) Remove the printer installed in cups. And disconnect the printer. 3) sudo apt-get install cnijfilter-ip2200series 4) restart cups: sudo service cups restart 5) ...


6

If you want ScangearMP to appear in the Dash, you can create a .desktop file for it. Copy the following into a text editor: [Desktop Entry] Version=1.0 Name=ScanGear MP Comment=Cannon's scanner software Exec=scangearmp Icon=scanner Terminal=false Type=Application Categories=Utility;Application;Graphics;Scanning; Save the file with filename scangearmp....


5

I have managed to install both the printer and scanner drivers for my Canon MX452, you can grab them from here, Printer: http://support-sg.canon-asia.com/contents/SG/EN/0100515301.html Scanner: http://support-sg.canon-asia.com/contents/SG/EN/0100517701.html In both cases, you will have to extract the tar balls, and run the install.sh script. To run the ...


4

There is a command line tool ink reading ink levels from a variety of printers including Canon printers using libinklevel5. List of supported printers. Unfortunately the graphical tool inkblot to display ink levels is deprecated and available for 10.04 only.


4

The only way to improve quality of the print is to do the research of reverse engineering the specific driver related instructions and updating the pixma foomatic driver. Currently we don't have any Canon documentation to work from to get printers working. I have a Canon iP5000 and have a limit of 600dpi too. Unfortunately it's a lot of work to reverse ...


4

The drivers already mentioned in the question are just fine, only they cannot be used with the Simple San or Xsane tools, but they install a tool called ScanGear that can be launched with the command scangearmp. Outputs: png, pdf, pnm. To add a .desktop launcher for that: sudo gedit /usr/share/applications/scan.desktop and paste this: [Desktop ...


3

This site is from Canon Australia and it has both scan and print drivers for Canon MG6300 series printers. For Ubuntu choose the Debian drivers. http://support-au.canon.com.au/P/search?model=PIXMA+MG6360&menu=download&filter=0&tagname=g_os&g_os=Linux It has been my experience that Canon USA doesn't support Linux, but often you can find ...


3

I recommend to install the original Canon Drivers. I've got a Canon Pixma MP630 and it works without problems. You should install the scanner and the printer driver. (Scroll down and click the Download button. If the links don't work, go to canon.com and search under Support for your driver.) For the Canon driver I've had a little bit struggle and had to ...


3

I do not know why, but I can print now -- also wireless. once supplied the PPD from the canon driver source archive, but deleted the printer again as it complained about missing filter tried to compile source as stated above tried to force install of i386 packages as above added the printer once again and it found it as shown in the screenshot below ...


2

http://support-sg.canon-asia.com/contents/SG/EN/0100393702.html try with this one! You have deb file inside. Just choos correct one and simply install


2

I have Ubuntu 14.04 and these are what I did to install the printer: I followed the steps of @hellyeah's answer but it failed at step 3. It worked only after trying the updated instruction of user 317642's answer Finally, the Kohjah Breese's tip also helped a lot. The summary of steps I did: Add the repository sudo add-apt-repository ppa:michael-gruz/...


2

I suggest adding the SANE daily build ppa to your system and updating. This gained functionality of a Canon multifunction printer/scanner on our system in xsane. Everything works except the document feeder, which I have posted a separate question about. If Canon provides scangearmp2 for your printer, does that work? It works on our system, including ...


1

Canon lP1800 Series You can try the following ppa however it seems it hasn't been updated in ubuntu 14.04 first make sure you have the correct ppa. Check at least twice.Then.... Open the terminal under Ubuntu and run these commands to install printer drivers: sudo apt-add-repository ppa:michael-gruz/canon-trunk sudo apt-get update sudo apt-get ...


1

select [Create] - [ScanGear MP...] from the [File] menu in Gimp or run in terminal: scangearmp form their documentation: Only GIMP can start ScanGear. No other application software can start ScanGear. If GIMP is not installed, you must install the software.


1

There could be multiple issues here. It could be a driver related issue, or a hardware issue. Download the driver, and install the package. Then make sure the proper driver is selected for the printer. If you have done that, you could try to connect the printer via a USB cable to rule out wireless issues. If that still doesn't fix the issue, you may ...


1

That exact printer does not exist on the official Canon USA support page but you could try going to the official Canon support page for the apparently similar MG5620 printer and downloading the Linux drivers. These drivers appear to be the same ones Canon supplies for my Maxify 2300 printer, which works well with Ubuntu. I think there is a fair chance they ...


1

You might need to do some changes (might be the first step of the procedure in installation because this it the folder where you download the file) to make it work for you because the steps he posted are for ubuntu users. http://ubuntuforums.org/showthread.php?t=2209879 This is what he posted: Re: Trouble installing Canon Pixma MG3500 printer driver So if ...


1

Solution to CANON MX395 for UBUNTU 12.04 connected via USB Download from the canon website the .deb.tar.gz drivers listed below: cnijfilter-common_3.90-1_i386.deb cnijfilter-mx390series_3.90-1_i386.deb scangearmp-common_2.10-1_i386.deb scangearmp-mx390series_2.10-1_i386.deb From: http://www.canon-europe.com/Support/Consumer_Products/products/...


1

For anyone stuck on stage 5, installing the printer means: Go to localhost:631 Go to administration and enter your OS user and password. Click on the Add Printer button (with the printer plugged in). Select your printer from the local printers. Press Continue. Press Continue. Where it says Or Provide a PPD File, click Choose File and navigate to and select:...


1

This printer has experimental support in gutenprint. I was able to install it regular way from localhost:631 on Arch linux after installing gutenprint. But this drivers only have 600*600 DPI resolution for printing which gives really bad results with color prints. There are also official drivers from Canon for Linux but this drivers have even less ...


1

The best thing you can do is download the printer driver and scanner driver from the Canon Asia website. After you downloaded the packages follow the Canon installation guides: Printerdriver installation Scannerdriver installation I recomend using the method Installing the ScanGear by specifying the package, since you seem to have trouble with the ...


1

Try to download the official tar.gz from canon-asia.com (I had to choose the MP237 instead of the MP230, but that works too) , uncompress it, enter into the recent created directory, and then execute the following command: sudo ./install.sh It will install (in order) two packages that are inside the subdirectory 'packages', in first place the "common" ...


1

After doing some serious digging I have found the solution to this for Canon Printers. Mine is an MP495 but these two command are worth documenting. cngpig -P cngpigmonmp495 **This one gives me my ink levels*** It is installed in the /usr/bin directory.


1

I now succeeded in connecting the printer with correct driver by downloading the driver from canon home page http://software.canon-europe.com/. From there I selected the driver for PIXMA MG8150 and downloaded the file *MG8100series-printer_driver.tar*. I extracted the folder cnijfilter-mg8100series-3.40-1-deb. In the folder I run the install.sh script and ...


1

Canon has chosen not to provide official support for Ubuntu, and this limits what you can do. You can't use it with gscan2pdf, for example. To make a PDF of a scanned document: Scan it in GIMP Save the .jpg image Drag the .jpg image into a new document in Libre Office Export the document as a PDF Experiment with both the image scan quality, as well ...


1

On canon site search for i.e. cnijfilter-mg5300series-3.60-1-deb (I have a MG 5350 printer, wifi only attached now on ubuntu 11.10) or i.e.: - canon your(series)type debian Downloadded it, extracted to desktop see files, right click the one ending on .sh open in terminal execute in terminal it does its thing, now my printer works for both text and ...


1

My MX350 on 11.04 wasn't working either. I had ia32-libs installed, but the install of cnijfilter-common_3.30-1_i386.deb still complained of missing i386 deps. I tried manually installing a few but they were already present. So I went ahead and added the "--force-depends" option sudo dpkg -i --force-architecture --force-depends cnijfilter-common_3.30-...


1

Have you installed the sudo apt-get install ia32-libs package? That's what I need for my printer on 64 bit Ubuntu.



Only top voted, non community-wiki answers of a minimum length are eligible