Tag Info

New answers tagged

0

Can you try forcing the use of your password instead of the public key authentication? E.g.: ssh -o PreferredAuthentications=password -o PubkeyAuthentication=no user@host.com The ~/.ssh/authorized_keys2 syntax is one pubkey per line, so simply adding another public key to the next line shouldn't have broken anything. See ssh(1) and sshd(8) man pages ...


0

Clear your history and cache https://support.mozilla.org/en-US/kb/how-clear-firefox-cache https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox If that won't help, proceed to step 2. What often help in terms of firefox issues is creating a new profile: open terminal type: firefox -p create new profile and set it as ...


0

Have you tried to do this you can mount hdd drive to another, and then alter the fstab to mount the directory to the hdd whit this: # /etc/fstab: static file system information. # # Use 'blkid' to print the universally unique identifier for a # device; this may be used with UUID= as a more robust way to name devices # that works even if disks are added and ...


0

The second issue is because you do not have rights to write in the root folder. To give yourself permission, open a terminal (ctrl+alt+t) and enter: whoami it will show your username, then navigate to the parent folder of your projects folder(if /home/projects then /home), and type sudo chown <yourusername> <directoryname>


1

Copying things as root will make things become owned by root (gksudo I think is just to stop program settings etc becoming owned by root - see here) - you should be able to fix it usiin the following : sudo chown -R $USER:$USER /<PATH>/<TO>/<COPIED>/<FOLDER> It: Uses chown -R - recursively modify directories and files $USER is ...


0

After little more effort I'm able to work with my htdocs folder. First i set my owner of my htdocs from root to My User after that i set permission of my htdocs 755 (drwx-rx--rx-) for my all directories in htdocs User this code to do that find htdocs -type d -exec chmod 755 {} \; and for files i set 644 (rw-r-r) User this code to do that find htdocs ...


0

Looks like you already created a Postgres role called UbuntuUsername. Trying to do that the second time will result in an error as the role already exists. I think you can proceed with the instructions. (the first error - "could not change directory..." is probably unimportant and harmless and is caused by sudo -u postgres ... executed in your home ...


3

chmod will change the permissions, while chown will change the owner and group of a file. In this case you're erroneously using chmod where you should be using chown. This is an error in the tutorial you're following, you didn't really do anything wrong but the instructions were mistaken. I suggest you find a book on basic Unix commands so you can learn ...


4

In addition to http://askubuntu.com/a/643030/218015 you might can also define an alias inside your .bashrc for small, often used tasks. E.g. alias ll='ls -l' alias ls='ls --color=auto' will create you a "command" ll, which is doing ls -l and ls will be coloured after defining the alias. https://wiki.ubuntuusers.de/alias is having some more examples and a ...


13

What are my options? Is there another path with the same "run from anywhere" capability, which I can access without sudo, or another way to achieve something equivalent? How to do it? Create some dir in your home to hold your scripts normally named as bin as convention. mkdir ~/bin Now move your scripts to bin mv somescript ~/bin Now how to ...


0

In general to change file and/or directories permissions you need to use chmod command (you already knew that). There is two way to use chmod more information in official ubuntu docs page. In the nutshell either use letters e.g r read (readable) w write (writeable) x execute (executable) OR use numbers 4 == r 2 == w 1 == x Here are some example ...


1

I can't comment yet, and I am not sure I understand the problem but I'll give it a shot. Set the directories as executable for all users (source) add the user you login as to the www-data group if the directories are executable for the group (Or do you not want to change executable permissions either?) then, assuming the directory has enabled execute for ...


1

These applications are likely using Polkit, not sudo (or gksudo or a similar frontend), for authorization. The default rule on Ubuntu for Polkit uses membership in sudo or admin groups: $ cat /etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf [Configuration] AdminIdentities=unix-group:sudo;unix-group:admin Just create a new configuration file in ...


0

You can move the directory from /opt to your home using comand: sudo cp -r /opt/android-studio ~/ Or to give permissions you have to use chmod: sudo chmod +w /opt/android-studio/some-file to add permissions to all dir recursive: sudo chmod +w -R /opt/android-studio/some-file Take a look on my answer http://askubuntu.com/a/638799/150504 that explain a ...


1

Don't move anything. Just use links. For example, say your normal user is usera and your second one is userb. Presumably, userb is a brand new account and doesn't have any data you want to keep. So, delete the directories in question and recreate them as links, then set up the right permissions: Delete the directoriess and recreate as links sudo rmdir ...


3

How to encrypt your /home folder: Before doing any of this, you should ensure you have a backup of your home directory and important files. install the encryption utilities: Open a terminal,Press Ctrl+Alt+T Run it: sudo apt-get update sudo apt-get install ecryptfs-utils cryptsetup You’ll have to encrypt your home directory while you’re not logged in. ...


10

You can't do that. If you give sudo permission for user, he can execute any command or access any files on that system. If you don't trust your user, give him restrictive sudo access to execute only a few commands by editing /etc/sudoers file. Create a new group admins Add lines to /etc/sudoers %admins ALL = <Full path to command 1>, <Full path ...


1

You can easily change the permissions for your home directory to protect your private files. To check the permissions on your home directory, press Ctrl + Alt + T to open a Terminal window. Type the following line at the prompt and press Enter. Replace <username> (aka lori) with your own username. ls –ld /home/lori At the beginning of the line, the ...


2

You could assign a group ownership to a parent folder and then make inside files inherit properties. Assigning group ownership could be set by sudo chmod -R 660 myself:somegroup /path/to/parent The group ownership can be inherited by new files and folders created in your folder /path/to/parent by setting the setgid bit using chmod g+s like this: chmod ...


1

I think your testing results for Xubuntu are the expected/desired behaviour; while a user is logged in (mounting/decrypting their home folder) then root can also see their files. Otherwise, when a user's logged out their files are supposed to remain encrypted/unmounted. Why that's not happening... I doubt it's a disk cache keeping the files visible after ...


0

On your host is where you must connect to the WiFi and you will see that the virtual machine connects directly to your wifi but appears as wired connection. Select the wifi you want to use on your host machine not the virtual machine :)


0

I had a similar problem to this. I needed two PCs, one on Ubuntu and another on Arch, to sync files through Unison but ran into the same permission denied error. Just for the sake of those who are having the same problem as I was, here's what I did: First: Installed the same version of Unison on both PCs. This was a bit challenging as the one available on ...


0

The following command worked for me: pkexec chmod 0440 /etc/sudoers


0

Create a Ubutnu live cd, mount the drive Ubutnu is installed on and do chown -R root: /media/ubuntu/YourDriveName/etc. Repeat this but replace etc with usr. I think there is no reason the change the owners of /etc and /usr.


3

Take a look at http://www.cyberciti.biz/open-source/command-line-hacks/linux-run-command-as-different-user/ then just write a sh script which you chmod +x so that you can execute it then just use the script to launch the other script.


3

Strictly, the directory: / is the "root" directory of all directories. That includes all sub- directories, so includes your home directory as well. You need additional privileges for all directories outside ~ (your homedirectory), so either you need to: be member of a specific group (e.g. to share files or directories), or, more drastically, you need sudo ...


3

All of what you have is just change ownership of that directory back to your user. sudo chown -R username:username /home/deepak/php/ So in your caser username=deep sudo chown -R deep:deep /home/deepak/php/ And for the command2 sudo chmod -R 755 /home/deepak/php/ this permission will be just fine for your now, but you probably change some ...


2

Yes you can do it using pmount. man pmount NAME pmount - mount arbitrary hotpluggable devices as normal user pmount <device> [ label ] Example: pmount /dev/sdb1 flash_drive This will mount the device /dev/sdb1 at /media/flash_drive. Policy: The mount will succeed if all of the following conditions are met: · device is a block ...


1

Easily what you can do, just play with permissions: Create a group for all users allowed to use the application, let's say sslusers. sudo groupadd sslusers Find the terminal program (use which), for example, openssl. Change its ownership accordingly : sudo chown root:sslusers /usr/bin/openssl Allow execution for the owner, and the group. Deny for ...


0

The root filesystem is read-only and you have to remount it in read-write mode with this command sudo mount -o remount, rw / and copy the ringtone afterwards. After that you can restart the phone and the root filesystem will be read-only again.


2

useradd / usermod command have an option to specify the primary group( -g). If you create a user without -g option a primarygroup will be created with the same name as the new username and the new user will be added to this group. When user creates a file/directory it gets the group of user's primary group. You can have only one primary group assigned to a ...


1

AppArmor should be able to do things like this. It's a access control layer that can add additional conditioons on user and processes. I've never used it before though so you might have some trial and error ahead of you. There's a fairly thorough guide on all of this on the AppArmor wiki. You'll need to layer more and more on but here's a starting point. ...


1

sudo chown -R user:user path This recursively changes the owner and group of everything under path to user.


0

A bind mount always has type none. If you don't want type none, don't use bind mounts. Using a bind mount doesn't change permissions or ownerships.


0

I've also had significant ttrouble getting audio ripping working using 14.04 (which is now the latest stable release). RipOff doesn't find any plugins to encode, asunder freezes very frequently etc. The asunder problems at least are fixed in Doug McMahon's CD Ripping PPA and that also contains a version of rubyripper - I recommend using this PPA


0

If some one interested in , the answer http://www.cyberciti.biz/faq/debian-ubuntu-restricting-ssh-user-session-to-a-directory-chrooted-jail/


11

This has nothing to do with Samba. This is related to file permissions. There are three types of access restrictions: Permission Action chmod option ====================================== read (view) r or 4 write (edit) w or 2 execute (execute) x or 1 There are also three types of user restrictions: User ls ...


3

A file can only have one group Only the owner of the file can do that. $ sudo touch ~/tmp/test $ sudo chown root:aboettger ~/tmp/test $ ls -la ~/tmp/test -rw-rw-r-- 1 root aboettger 853 Jun 19 08:26 /home/aboettger/tmp/test $ chmod g-w ~/tmp/test chmod: changing permissions of 'test': Operation not permitted You have rwx access rights And you should ...


0

It seems it may be a problem with AppArmor; I would recommend removing it then restarting your computer / server and trying again. You can remove it via typing sudo /etc/init.d/apparmor kill sudo update-rc.d -f apparmor remove Hope this helps!


0

Edit: After reading what happened before the fast-forward. I think I would reinstall the whole OS. Too much different permissions in the whole /var structure. (And why would anybody advice a "chmod -R 777 /var"?)


0

You could consider making your application a startup service. Here is a good guide to get you started.


0

sudo works both ways, root can also act as a regular user sudo -u userName -g groupName I haven't used it but it looks like gksudo has the same functionality for desktop top applications


0

I wish you had mentioned if it is a part of a bigger automation project or simply something you wanna do. You can simply do the following in a directory: chmod u+x * This adds executable status to all files inside a folder for "your user". You can try to add it for "everyone" by chmod a+x * Note, your user should have permission to change files ...


2

It's a simple find command with chmod: find . -type f ! -perm -u+x -exec chmod u+x {} \; or only for the current folder: find . -maxdepth 1 -type f ! -perm -u+x -exec chmod u+x {} \; Explanation . Start the search in the current folder -maxdepth Not recursive -type f Only files, no folders ! -perm -u+x Only files without the executable flag for ...


2

The idea you have seems legit but unnecessarily large and complex, rather you can use this: #!/bin/bash for file in *; do [[ -x $file ]] || chmod u+x "$file" done This will read all files (*) in the current directory Then it will check if the file is executable by the user running the script ([[ -x $file ]]) If not (||), it will make the file ...


0

You need to use chmod command to change the permission, How to use Chmod command, or You can lunch the app as Root, How to launch application as root


1

Many many thanks for all the input - Im truly grateful. I've managed to resolve all the issues about accessing and mounting "Disk2" etc I edited fstab thanks to Maythux and commented out the offending lines. Special thanks to user5570 for your patience with my ignorance. /|\ paul


0

You have lot of confusion in your question? Did you remove the swap partition and make it ext4 as new partition?! From your fstab: swap was on /dev/sda2 during installation And you say: I've created a ext4 partition. Gparted confirms (mount point: /media sda2, /mnt/sda2) (label: disk2) And how would you get two mounting points?!! (mount ...


0

Its good that you found the solution to the permission issue. About the startup issue, try running cat /etc/fstab to inspect your mount settings. If you are mounting removable media in your /etc/fstab, you can comment that item in the fstab file. Try to comment out this line in the /etc/fstab UUID=6e692a08-9b12-4e0a-94f4-209a864d819b /media/sda2 ext4 ...


-2

A normal user can not have full access to an ext4 partition, unless you have became root with sudo command. I guess that you tried to open lost+found folder. This one is a possible duplicate: link. It is somthing like "System Volume Information" in Windows. You should try to create a directory. It should work with the default mount options.



Top 50 recent answers are included