Tag Info

Hot answers tagged

9

The reason of the poor performance The problem will be this: GLX Renderer: Gallium 0.4 on AMD KABINI GLX Version: 3.0 Mesa 10.1.3 Unfortunately the KABINI APUs still have quite poor open source driver support, so I suggest installing the proprietry fglrxdriver, which yields better 3D support. Gallium is the open source radeon driver, if this was not ...


3

Yes, all you have to do is: first, set tlp "governer" to performance for both ac and batt in your /etc/default/tlp file and while you are there, go ahead and enable turbo boost as well then, edit /etc/default/grub and insert intel_pstate=disable after GRUB_CMDLINE_LINUX_DEFAULT= like this example GRUB_CMDLINE_LINUX_DEFAULT="intel_pstate=disable ...


1

Im going to stick my neck out here and say that this isnt possible on Linux in general. In SMP systems there is a scheduler running on each core, which is why you are still getting context switches. If your application is really that critical, perhaps you should be using some kind of RTOS, rather than linux.


1

Take a look at the schedtool package. It offers CPU locking facilities, and a choice of CPU schedulers to the user. Worried about the GUI affecting things? From a virtual terminal, kill X and see. Probably with an i7 CPU, there are enough cores to make that irrelevant. It's all a matter of controlling shared resources, with the CPU being only one ...


1

Another good way to boost performance is to install CompizConfig Settings Manager, and disable animation effects, Fading Windows, and Window Decorations. Desktop wall and Expo are an option, too. Also, use fast texture filter under OpenGL


1

I cannot comment, so I had to resort to a new answer. For immediate results, make sure you do sudo /etc/init.d/cpufrequtils restart for the new frequency to kick in after you follow all of Dennie's steps.



Only top voted, non community-wiki answers of a minimum length are eligible