New answers tagged

1

Yes, sudo uses PAM and PAM supports configuration for each application. Authentication and logging The sudoers security policy requires that most users authenticate themselves before they can use sudo. A password is not required if the invoking user is root, if the target user is the same as the invoking user, or if the policy has disabled ...


0

I'm using Passwords & Keys in U14, click the +, select PGP, ok, then wait a few minutes, and click on PGP and your key pair should appear. I thought it was strange too with no status to let you know something's happening.


1

Create a folder in the /etc/lightdm/ folder called lightdm.conf.d: sudo mkdir -p /etc/lightdm/lightdm.conf.d Next, create a file and call it 10-ubuntu.conf: sudo gedit /etc/lightdm/lightdm.conf.d/10-ubuntu.conf and add the following lines to it: [SeatDefaults] user-session=ubuntu greeter-show-manual-login=true greeter-hide-users=true ...


0

https://www.freeipa.org/page/Main_Page this may be the answer to that topic


0

I too have faced similar problem. I tried to login and I get back to main screen again. Try this: CTRL+ALT+F1 to F6 any that is available for you Now you login with your user login. After that you will find in your home directory for that user a file named .Xauthority by, usually you will be on your home directory but you may want to visit it by doing cd ~ ...


0

There is an existing bug which causes this login loop issue. Please search it in this forum. I get rid of this kind of issues by undoing the last action and i try to do only action at a time so this way i can undo. Based on the information you have provided it seems that it is a fresh install so your best bet it to re-install. Otherwise as mentioned in the ...


0

I did not find a solution for automatically unlocking a keyring other than the "Login"-keyring. A workaround I came up with requires setting the passwords of both keyrings to blank temporarily, thus having plain-text-access to both files in .local/share/keyrings/ (make sure to make backups). I manually merged both files into the "Login"-keyring with a text ...


2

The issue was related to the fact that the NFS was not configured correctly on the Ubuntu machines. When I did ls -l the file owner and group were nobody nogroup. Once I fixed the NFS configuration, everything went well.


0

Do Ctrl + Alt + F1 to go to prompt.Login with your username and password.Then do sudo chmod -R ug+rwx /home/[username] Then do Ctrl + Alt + F7 to login


0

I DO NOT TAKE CREDIT FOR THIS ANSWER From http://askubuntu.com/a/84697/448562: If Jorge's method didn't work for you, as it didn't for me, here is another method. I had to try something different because: My USB keyboard did not work at the root prompt ⋯ probably hardware either keyboard or mainboard. To fix I used an old PS/2 keyboard (the little round ...


3

There is no way to get true randomness from a deterministic machine! Any algorithm in existence today (not using non-deterministic hardware) generates pseudo-random noise, not true randomness, so the answer to your question is: No, the passwords generated using the pwgen -s -y command are not truly random! Sorry, one of my pet-peeves: they are very random ...


0

In python this would be done like import grp import pwd print([x for x in grp.getgrnam('sudo').gr_mem if pwd.getpwnam(x).pw_shell not in ('/bin/false', '/bin/nologin')]) Where grp.getgrnam('sudo').gr_mem would return all group members of group sudo and pwd.getpwnam(USER).pw_shell returns the users shell from /etc/passwd. But only group membership in ...


2

I found my answer here. Since these questions have different phrases I thought of not deleting my question. This might help somebody else. Run sudo grep nopasswd /etc/* This will display at least 2 lines: /etc/group:nopasswdlogin:x:112:`<login name>` /etc/gshadow:nopasswdlogin:!::`<login name>` Edit those files with sudo and remove only ...


1

From your question, it is not fully clear if you need to be inside the directory of CMDexecutable (and thus cd first) or if the full path would do, but the only option I see is to add the script to the sudoers file, as described here. Then you can run the script with sudo, without having to enter the password. You can simply run the (python) script then by ...


0

You must install LDAP extension module to have password quality check feature. There are some other extension modules available for Ubuntu. May this article Password quality check for OpenLDAP help you.


1

Work in progress This can be accomplished by using: a custom X session which starts a basic window manager and runs the script a custom configuration for LightDM which will autologin your user and use the above session a custom service for LightDM which will use the above configuration appropriate kernel parameters to disable the normal LightDM service ...


3

There is two types of accounts, system and regular user. System accounts belong to services and daemons, such as lightdm, dnsmasq, etc.Typically you cannot login into those accounts (although there are ways). Regular users, such as your account or other people accounts, can login and interact with the OS through shell (could be bash, ksh, mksh, csh, or ...


0

You can use a per-user ssh-config file located in ~/.ssh/config or a system-global one in /etc/ssh/ssh_config that stores the basic settings for each connection. Example: Host example_host User foo HostName example.com IdentityFile ~/.ssh/foo.key Port 23421 Having this in place, calling ssh example_host will open up a ...


0

There is ~/.ssh/config as pointed out in the manual pages for ssh. It is well described there and in man ssh_config and also many times answered on askubuntu. TL;DR: # to preserve connections: ControlMaster auto ControlPath ~/.ssh/controlmasters/%r@%h:%p ControlPersist 20m # to provide correct keys, users, IPs and use aliases Host yourHost Hostname ...


1

the simplest answer is this question : why to show the password ? if someone knows how many character your password has , he can make a dictionary with all possible combination of characters and numbers with the same length of your password. it would be cracked later.


6

It makes the password length harder to know. If your screen is being monitored, for example, using • placeholders would allow an attacker to dramatically reduce the number of passwords they'd need to try in order to crack your password. Good passwords are made up of a bank of about 40 characters. So compare the difference between If you have a 10 char ...


2

There is no need to show a * when inputting characters. Showing a * gives a hint to anyone watching you type: they then know the amount of characters you typed. And since is it better to type a wrong password than to have 1 person get to know something about your password (even if it is just the length) not showing a * is the better method. In case of ...


1

My reasoning behind this is following: number of "•" characters you enter is very big hint for someone that would like to know/break your password. If the bad guy don't see nothing, your password is more secure. Possibly there are other reasons but one above is enough for me.


0

I encountered this same problem today. Garbled console text in initramfs for dm-crypt luks encryption prompt. I am using Arch Linux, but the symptoms are the same as you're describing. I have full disk luks encryption enabled on my Thinkpad laptop. The prompts from dm-crypt in initramfs (and it would seem all console text from initramfs) are garbled, ...


0

I figured it out, I got it to ask for the password of a user I created called "admin" which is the system administrator. I have set the "user" account to be only a desktop user and not an administrator. 1) I changed the menu entry to say gksu -w -u admin /home/admin/bin/menu.sh (Where I put the script) 2) In the menu.sh script gksu -u user ...


4

Under Settings→Security & Privacy there is an option to disable requiring the password when the screen is awakened.


0

In Brightness & Lock in System Settings toggle the Lock switch to off.


0

You could do that with a simple bash script and Zenity. As stated, this shouldn't be used unless you don't care about security. #!/bin/sh #Create the Zenity Window and show it OUTPUT=$(zenity --password "Password") #Compare the user input with your hardcoded password if [ "$OUTPUT" = "abc1234" ] then #Command to launch the application from the CLI. ...


0

You may be able to recover it by decrypting the file /home/username/.ecryptfs/wrapped-passphrase using your login passphrase. ecryptfs-unwrap-passphrase /home/username/.ecryptfs/wrapped-passphrase Type your login passphrase to reveal the mount passphrase. If your login passphrase matches the passphrase used to encrypt the wrapped-passphrase file, your ...


0

This seems to be a question for wubi; I would report a bug to wubi as this is not an issue with standard installation of Ubuntu ; and can't be duplicated to troubleshoot.


0

To install Ubuntu the system requires you to set a root (administrator) password upon install. (See here). If you have forgotten the administrator password you can always reset it. This would be the 2nd best option first being reinstalling Ubuntu and remembering the root password.


-2

Go to System > Preferences > keyboard shortcuts run a terminal: Ctrl+Alt+t and type: passwd user .. enter new password for user If no luck You can refer the link From the official Ubuntu Lost Password documentation: Reboot your computer. Hold Shift during boot to start GRUB menu. Highlight your image and press E to edit. Find the line starting with ...


0

Welcome to Ubuntu World.How did you login to your system? If your User Account is previously set to login without password you may try this. Open up Terminal and type in passwd. Enter a new password (For a strong password make sure it has capitals, more than 8 characters and numbers) and press enter. Retype your new password and press enter.


1

Try to give permission to your script file: $ sudo chmod +x start-dfs.sh Then execute. $ sudo bash start-dfs.sh


1

This is common issue with encrypted home, and was answered many times, for example on Unix, but is covered even in official Ubuntu documentation. This is probably caused by the fact, that your home directory (and therefore the key) is not accessible during the login time. This can be caused by the fact, that your home is mounted from network drive (on ...


2

GNU Screen stores user's passwords in ~/.screenrcand authenticates using PAM in /etc/pam.d/screen. Deleting ~/.screenrc should solve the problem.


0

You probably don't need an anti-virus if it's your personal computer. GNU/ Linux has a different permissions model and there are way less threats for your client GNU/ Linux based computer. The extension .linux sounds funny to me. I would look for something which ends with .deb! In case you really want an anti-virus for Linux, I would go for Avast: ...


0

In your /etc/ssh/sshd_config file you should use the line: PasswordAuthentication no Reload the ssh configuration with: sudo service ssh reload It should now no longer be possible to log in using password based authentication, assuming you're using Ubuntu :)


-1

If certificate copied correctly, then it should work with the connection formated like this: ssh hostname\ip -l username Where username is the user, who have you certificate in .ssh/authorized_keys


0

I appeared that the account had slow keys active by default so that when I entered the password using onboard, everything worked. The guest account worked when pressed an extra Enter key.


5

Firstly, there should be zero reason to login as the tomcat7 user. There's no logical use case for this, so therefore I'm not sure why you'd try and use it. You state in your question you want to set up a virtual X server for a webapp - you don't need to login as tomcat7 to do this, though your question isn't "How can I launch a virtual X server for my ...


6

Some background info: User log-ins are handled by the PAM system (Pluggable Authentication Module) and in this particular case by the pam_tally subsystem (to tally the user accounts). As pam_tally itself will be deprecated, you should use pam_tally2, which comes in two parts: pam_tally2.so being the module that does the authentication itself and which ...


1

You can't do it from guest account. And next time be more careful while typing your password. Get an Ubuntu Live media (the same you used to install it) and boot your computer from it. In a terminal, run: sudo mount /dev/sdXY /mnt Replacing XY with the appropriate letter/number to your Ubuntu partition. sudo chroot /mnt sudo passwd username Replace ...


-1

here is a one liner to make @David Foerster answer more useful MYCWD=`pwd`; cd /etc/NetworkManager/system-connections/ ; sudo grep -e '^psk=' * | less ; cd $MYCWD


0

As it was a very fresh install and I had enough troubles with Ubuntu Desktop 14.0.4 LTS - I decided to uninstall it and then install Ubuntu Desktop 15.10. No login loop issue, no wifi driver related issue and grub2 is also working fine. Only one issue is remaining now that is nvidia graphics card driver which is making ubuntu freeze. That is the only one to ...


0

I was able to solve this issue with the following steps: From a command prompt, run gnome-disks Find which device is your swap drive. Mine was /dev/sda3 ll /dev/disk/by-id Find the ID that is symlinked to your swap partition sudo vim /etc/crypttab On the line beginning with cryptswap1, change the uuid=… portion to /dev/disk/by-id/ID-HERE. Save and ...


2

You can change the password via the GUI on XFCE by following these steps. First open the all settings from the menu, now choose users and groupsfrom the bottom and click change next to the password Now just enter your new password and click OK.


0

Open up a terminal, and type sudo passwd yourusername. Where ¨yourusername¨ has to be your user name, of course.


1

Before you treat it as a bad password, try CTRL-ALT-F1 and you should get a text-based login, verify your password is not working there. (one my box to get back to the graphical login I use CTRL-ALT-F7) Failing that, can you connect via ssh from another machine and test out that password? ssh username@hostname You say you are providing the right password ...



Top 50 recent answers are included