Tag Info

New answers tagged

0

Unable to correct problems, you have held broken packages. That line from the output you received (when trying to install libgtk2.0-dev) seems to indicate you need to fix broken and missing packages. Try this: sudo apt-get update && sudo apt-get upgrade --fix-missing --fix-broken Then, assuming that was successful, you should be able to run the ...


0

press CTRL+T This will open terminal. sudo apt-get update Enter your account password. apt-get upgrade This will install updates. apt-get install <the package you need to install> this will install your package


0

Method 1 Ubuntu uses 'apt' as a package management tool. To install any package, this is the syntax: sudo apt-get install <package-name> So all you need is the package name. To search among the PPAs on your system, you can use this: apt-cache search <keyword> So with this command you can search for packages. So when you search for chrome ...


0

I was running into the same situation and I found this post that gave the clues to solve my problem. In my case, what happened is that running the upgrade it tried to set the kernel 3.13.0-53-generic, and got the same issues. It wasn't a problem of downloading but configuring. My /boot partition had some space, but not big enough for the new kernel to get ...


2

Sometimes the package dependencies are related to packages out of x86_64 architecture. Try these following steps: sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install libgtk2.0-dev I hope to help you.


1

Boot from the live USB Find out where the existing disk is mounted - say it is mounted on /media/point Download http://ppa.launchpad.net/canonical-kernel-team/ppa/ubuntu/pool/main/l/linux/linux-image-3.19.0-18-generic_3.19.0-18.18_amd64.deb (for a 64 bit system) or ...


1

First you should know this is not a weired action, this is totally right and you some how asking for this action!! So why this happens? You want to install libgirepository-1.0-1:i386 , but you already have this libgirepository-1.0-1 64 bit version, so here the system is asking you to replace the 64bit with this 32bit. This replace has some consequences, ...


0

I experienced something similar and found in the end that installing the package would work just fine, even though apt-cache policy package said it was not available, and threw the error message you are reporting, however with N: instead of E:. (However, apt-cache search package returns empty output for me, rather than the error message.) Running strace on ...


1

Linux americostechadmin-phpserver 3.13.0-53-generic #89-Ubuntu SMP Wed May 20 10:34:28 UTC 2015 i686 i686 i686 GNU/Linux This shows that your system is 32 bit i686 instead you are installing 64bit package, so this raises that errors. To solve that run the command: sudo apt-get -f install press y , this would remove the package you are going to ...


0

Try this link: OpenCV installation for Ubuntu 12.04.


0

apport and apport-gtk are both marked as dependencies by ubuntu-mate-desktop. If you remove one of the former, the later will also be removed. ubuntu-mate-desktop is a meta-package, enclosing the set of packages that make up the Mate DE. apport and apport-gtk are part of this set, meaning they are deemed core components of this DE. If you remove one of then ...


2

Another method Download main package which depend on the other. Extract the package, remove the unwanted dependencies, repack it. Now open the new package with gdebi package installer. It will install new dependencies for you. List of depencies can be found at DEBIAN /control -> depends For help on repacing deb see my answer on how to create a PPA


0

mediascanner2.0 is a package used in Unity 8 to discover media and then play it. For example, the Core Music App on Unity 8 uses mediascanner to scan the music directory(or any directory for that matter) and then play back music. Since Ubuntu is moving towards Unity 8, it is included by default in the Ubuntu iso. mediascanner is scanning your whole hard ...


0

Test this: Download this files to 32 bits: http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/libgtk2.0-dev_2.24.10-0ubuntu6_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/g/gtk+2.0/gir1.2-gtk-2.0_2.24.10-0ubuntu6_i386.deb http://mirrors.kernel.org/ubuntu/pool/main/a/atk1.0/libatk1.0-dev_2.4.0-0ubuntu1_i386.deb ...


1

Try installing all of them at the same time, like this: sudo apt-get install libgtk2.0-dev libpango1-dev libcairo2-dev libfontconfig1-dev


0

Here is How do I restore the default repositories. After that do: sudo apt-get update And install Minicom by tuping: sudo apt-get install minicom


0

Like it was mentioned in the comments it is a configuration mistake. I changed the source to 'Main server' and the issue was resolved.


0

The easiest way is to move the modified source to your other system and compile it there. But you also can create a deb package too. Here is one of the guides. But it will need some effort to learn doing it right.


1

According to Ubuntu Community Help Wiki, try running: sudo apt-get -f install From the help page, This command does the same thing as Edit->Fix Broken Packages in Synaptic. Do this if you get complaints about packages with "unmet dependencies". Then if you still experience problems, run sudo apt-get check and report back.


2

If you use aptitude or a graphical package manager (Synaptic, etc.), then you can unselect which packages should be installed as long as it doesn't cause a dependency issue. In the case of aptitude, before installing a package (in the graphical view), it will show you why a dependent package is being installed. In my case, I use KDE, and so don't have any ...


0

Test this: Open a terminal. Run it: sudo -i update-rc.d -f slpd remove dpkg --configure -a apt-get -f install


0

A) try sudo update-grub then sudo apt-get upgrade if it does not help then try the rest of the steps. 1) goto ubuntu terminal, sudo synaptic 2) left hand pane, goto "Installed" 3) On the top you will see QUICK FILTER, type this "3.13.0" (without inverted commas), you will the linux images there, the issue that may have arise is because of the incomplete ...


4

You have two options Change the dependencies and use the latest libgcrypt libgcrypt20 does not exist without reason. Install libgcrypt11 and use an old version of libgcrypt Change the dependencies First, remove the previous installation of Springseed: sudo apt-get remove springseed Download the latest Springseed version here, eg: cd wget ...


3

The final release of Ubuntu 15.04 no longer keeps the package libgcrypt11, rather libgcrypt20 as you have come across by the Synaptic Package Manager. All you have to do is to download the package from here and then install it prior to Springseed. You may earn additional knowledge from this source pointing out similar problems with other apps besides ...


0

I am uncertain on the cause for the error, but if you select advanced options during your initial load you should be able to select a previous image to load. I encountered the same issue and was able to load without an error with the last kernel image. I posted this as a possible suggestion: http://stephenjkennedy.me/?p=68 Hope it helps.


1

Indeed there is no specific answer. The answer would bw related to each package unique. The master guidlune to your choice is what you care about. Installing from Ubuntu main repositories ensure you security, stability but with some versions, since to ensure the policies put by ubuntu packaging system would take some time. So as a guidline, don't add third ...


0

Installing from the website itself gives you the latest updates of that particular software. Software being in PPAs generally take time to be tested and modified. I generally download the .deb file from the website only.


0

For the half installed package error, --reinstall worked for me: sudo apt-get install --reinstall packagename


5

So, mate-core depends on mate-desktop-environment-core which in turn depends on mate-terminal. A depend cannot be broken easily. Nor apt-get nor aptitude supports a --without or --exclude option and "holding" the packages won't help: $ echo "mate-terminal hold" | sudo dpkg --set-selections $ sudo apt-get install mate-core [...] Some packages could not be ...


0

Open a python shell and type: import sys sys.path /usr/local should normally be first, so it will be searched first.


0

Found it: download the .deb file for libsdl-gfx1.2-4 from here. Afterwards, try to install the Bastion .deb file again. This should work.


0

Try installing synaptic from the command line, and see if you can't reinstall apt that way. From a terminal window, type in the following: wget http://mirrors.kernel.org/ubuntu/pool/universe/s/synaptic/synaptic_0.81.1_amd64.deb then install the downloaded package: sudo dpkg -i synaptic_0.81.1_amd64.deb then run the installed app: sudo synaptic In the ...


0

If you want to remove the ATLAS development packages, they are actually called libatlas-dev and libatlas-base-dev. However, there should be no need to uninstall these packages in order to use OpenBLAS: the update-alternatives mechanism will take care of things for you, automatically assigning higher priority to the OpenBLAS version of libblas when you ...


0

I'm not sure what happened with your apt-get, but if you're unable to use it, you might want to use apt from Ubuntu repositories (simply downloading and installing via sudo dpkg -i package_name) the functionality of apt is pretty much similar to what you get with apt-get.


0

Assuming that your apt-get seriously needs a reinstall, you can try following: Check your current apt-get version by apt-get --version. Search for the same version's .deb file on launchpad.net install it by dpkg -i filename.deb Of course, this unfortunately cannot work if you also removed the packeges on which apt depends, like libgcc1


0

Here is a link to a python program named UBPROXY . Given below are the steps to set proxy Authentication. http://code.google.com/p/ubproxy/downloads/detail?name=ubproxy command to use-> 1.download this program. 2.open your terminal 3."cd ~/Downloads" (Presuming that your download exist in this directory) 4."chmod +x ubproxy" 5."sudo ./ubproxy"


5

Quoted from https://wiki.ubuntu.com/LTS LTS is an abbreviation for “Long Term Support”. We produce a new Ubuntu Desktop and Ubuntu Server release every six months [diagram below]. That means you'll always have the latest and greatest applications that the open source world has to offer. Ubuntu is designed with security in mind. You get free ...


-2

Apt manual claims that you can specify "exact dependency" with (=xx.yy) as well as <=, >=, but it does not work as documented. The way things seem to actually work is that Depends: version info has no functional value and is completely ignored. Without the version dependency, you cannot have a repo with multiple supported versions of the same package - ...


1

For what it's worth, I fought this issue for a while before I landed on this as a solution: sudo apt-get install steam -y This took care of all of the nasty package issues. Steam started right up.


2

First you should know as the others are sudoers then you can't restrict their access, but there is a tricky simple way to do what you want. First of all you should specify all packages that you would to restrict. Open the sudoer config file: sudo visudo for example I'm gonna here prevent the user named user from installing youtube-dl. Add this line to ...


1

There is no such thing as tor 0.2.7.5. What you read about is Tor Launcher 0.2.7.5 which I suspect is a different thing that tor itself. You can have (in decreasing order of stability) the following build: the latest stable which 0.2.5.12.1 the latest experimental build which is 0.2.6.7.1 the latest dev build 0.2.7.1-alpha-dev-20150518T200057Z-1 none of ...


0

See this error: Unpacking libreoffice-common (1:4.4.2~rc2-0ubuntu1~trusty1) ... dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a4.4.2~rc2-0ubuntu1~trusty1_all.deb (--unpack): trying to overwrite '/usr/bin/soffice', which is also in package openoffice-debian-menus 4.1.1-9775 The only thing you have to do, this package should ...


0

Open Terminal and fire these commands... sudo apt-get remove --purge libreoffice-core libreoffice-common python3-uno libreoffice-* sudo apt-get update sudo apt-get upgrade sudo apt-get autoremove


0

i'd try cleaning the status of my installation before resorting to uninstalling whatever created the problem: apt-get autoclean apt-get update apt-get upgrade apt-get install -f much better way to solve this in most cases and in at least one instance had helped me when the other way wouldn't work (because huge dependencies on the package to be removed)


1

Can't comment on the previous answer (lack of rep), but to add on to Kam's answer above, you can download the notify-osd .deb file from here, for me I just installed the daily one. Run sudo dpkg -i filename.deb and you'll find that it'll immediately work with your existing NotifyOSDConfig installed. This will "downgrade" notify-osd (as shown in output), and ...


0

Try this, should solve your problem: sudo apt-get remove keyboard-configuration sudo apt-get install keyboard-configuration sudo apt-get update sudo apt-get upgrade


21

You could check which package brings ls binary using dpkg: $ dpkg -S /bin/ls coreutils: /bin/ls dpkg will show you that it is package coreutils. Now you only need to reinstall it: $ sudo apt-get install --reinstall coreutils


0

Look at this line: Depends: libdrm2 (= 2.4.52-1) but 2.4.56-1~ubuntu1 will be installed. It says the libdrm-dev to be installed is 2.4.52-1 and requires its dependencies all versioned in 2.4.52-1. But your apt-get only has 2.4.56-1~ubuntu1 available. Thus, you may try to 'upgrade' the version of libdrm-dev, that is version 2.4.56-1~ubuntu1, as same as ...


0

I'm using the 14.10 package, and it works out of the box, however, you have to use use the --force option to install it, and you must bloacklist notify-osd in synaptic (prevent future updates) or it's gonna reinstall the official package - untill the ppa is updated for vivid that is. Also, apt-get dist-upgrade does not upgrade the distribution. It's just ...


0

Test this: Open a terminal.Press Ctrl+Alt+T Run it: sudo -i apt-get clean apt-get autoremove UNUSCONF=$(dpkg -l|grep "^rc"|awk '{print $2}') apt-get remove --purge $UNUSCONF NEWKERNEL=$(uname -r|sed 's/-*[a-z]//g'|sed 's/-386//g') ADDKERNEL="linux-(image|headers|ubuntu-modules|restricted-modules)" ...



Top 50 recent answers are included