Tag Info

New answers tagged

-1

List of all Qt5 developement packages, available on Ubuntu.


0

With no other info (apt-get install -f and "synaptic" don't work?), right now I'd guess you have conflicting software sources. Resetting them to defaults might work.


1

Right now the options are very limited. The available apps can be found by running: snappy search '*'


1

In the debian/install file, add this line (or only use this line, if there aren't any others in there): moduleFileName /usr/local/lib/python2.7/site-packages/ You basically use the same line format for each file (or directory): filename /path/to/destination/


1

It is not really clear what you want - the location of the package or the location of the installed application... For an installed package dpkg -L packagename lists all the files.


1

Try to reinstall ceilometer: sudo apt-get purge ceilometer-api ceilometer-collector ceilometer-agent-central ceilometer-agent-notification ceilometer-alarm-evaluator ceilometer-alarm-notifier python-ceilometerclient sudo apt-get --purge autoremove sudo apt-get autoclean sudo rm -rf /var/lib/ceilometer/ /var/log/ceilometer sudo deluser ceilometer sudo ...


1

dpgk -c /var/cache/apt/archive/packagename.deb You can pick -c or --contents. Or if you use wajig, wajig contents /var/cache/apt/archive/packagename.deb does the same. If you just want the location of an executable file (and you know it's name) then which progname tells you; or you could use $(which progname) in your script...


0

Kiwix is the app for linux. I want to add a tip for anyone who wants to use it and is running 64 bit system and cannot start the app. You will know that you need to follow my instructions if the app does not start and you do not get any error messages. After you download the package from Here! Open the folder , go to linux folder and then make the file " ...


1

Assuming that you selected English when installing, these commands ought to add all the language and language support packages for both Czech and English: sudo mkdir /usr/share/locale-langpack/cs sudo apt-get install $(check-language-support)


3

[I'm the maintainer of said ppa]: When Launchpad builds a source package in a PPA, it creates binaries for i386 (x86) and amd64, but not for arm. (Source: help.launchpad.net/Packaging/PPA). But there is a possibility to request community arm builds (dev.launchpad.net/CommunityARMBuilds), which I just did: ...


0

Logs Ubuntu community: https://help.ubuntu.com/community/LinuxLogFiles The apt log: /var/log/apt/... The dpkg log: /var/log/dpkg.log... Keeping own logs - the logsave LOGSAVE(8) System Manager's Manual LOGSAVE(8) NAME logsave - save the output of a command in a logfile SYNOPSIS ...


1

If you have disabled all repositories then this is the problem for the application which you are trying to install is from one of those repositories. So you would either need to activate them all, or find the specific one which this software uses and activate that one.


1

That repo only has a pgl package. If you look at the package files you'll see it provides binaries for all those commands. That's all you need to install. sudo apt-get install pgl I should also add that this PPA only ships versions for lucid-trusty. If you're using something newer (eg 14.10), this won't work. Talk to its maintainer.


1

You could try and run sudo apt-get dist-upgrade which does update more packages as the normal "upgrade" package would do. Also a call to sudo apt-get check and sudo apt-get -f can't hurt.


0

I don't know exactly what you did, but I'd guess that you're correct that your "the disabled update sources" broke everything. (And your software sources should have nothing to do with suspend/sleep... even updating has to be manually initiated, so again once it's finished it shouldn't affect suspend/sleep). apt relies upon the software sources to know where ...


0

Please try running sudo apt-get -f and/or sudo apt-get update followed by sudo apt-get dist-upgrade and - if no errors occured - try installing wine again and inform us what happened. Greetings!


1

The package distribute 0.7.3 is a deprecated fork of Setuptools, install it only if you can't install Setuptools and need a compatibility layer. Before anything, execute in a terminal (xterm or Terminal are both fine) sudo apt-get install python-setuptools to install the distribution version of setuptools. If you really need to proceed, follow this ...


0

apt-get insists on fixing any broken packages before doing anything else. Use dpkg -r pkgname to remove the packages directly instead. After clearing those out, the run apt-get install -f to fix the broken packages.


0

So I ended up using Synaptic to correct the problem. No package were broken, but by navigating through all the packages involved, I selected & removed all those marked for audio files. That is because I tried to install Rythme Box and although I could open it, it was very buggy. I had previously used it and it was fine. That led me to think that there ...


0

sudo apt-get install -y build-essential kernel-package libncurses5-dev bzip2 bin86 qt4-dev-tools wget libncurses5 git-core nautilus-open-terminal because you're using newer linux > 13.10


0

Just found a solution in using sudo apt-get install dpkg --get-selections | awk '{print $1}' | egrep -v 'dpkg|apt|mysql|mythtv' (please note I think that it will hide the little marks at each end of the dpkg or something to show it as a code snippet. At the beginning of the dpkg part there is the character right below the tilde (~) character that looks like ...


0

Maybe it's only certain sources that include the ability to update. The linked you posted states that when you install with dpkg it bypasses apt and therefore won't get updated. As a test I searched what version of nodejs is available in Utopic (v0.10.25) and then installed nodejs (v0.10.20) using checkinstall I downloaded and extracted then ran: ...


1

The package manager doesn't care whether a package has been installed by dpkg or apt. If it finds a newer version of a package in the repositories that newer version gets installed. In your case that means your package gets updated if the package in the new Ubuntu version has a higher version number. See "How to prevent updating of a specific package?" if ...


0

Now the problem is moot, but for the future: Always use the same removal method as the installation method. Therefore, use the following priority in installing software Install/remove from the standard Ubuntu repositories using the GUI of the Ubuntu Software center. Use the TUI of aptitude apt-get install szPackageName to install and apt-get purge ...


0

By chance, have you done a recent update? Maybe try an update with Synaptic by reloading and apply any updates then try installing VLC through Synaptic after checking for broken packages. I had a weird instance installing VLC in Zorin OS 9 and if memory serves me correctly this is what worked. Worth a quick try, anyways.


0

Occasionally one might want to hold back all the packages currently installed. Here's how. First save the current state, so you can undo: dpkg --get-selections > current_selections.txt Then, to hold back all the packages: dpkg --get-selections | sed -r "s/\tinstall/hold/" |dpkg --set-selections Finally, when you want to revert back to the previous ...


0

You have Debian repository in your source list (ftp.us.debian.org...) which is causing this problem. The latest version of locales available in Ubuntu 14.04 Repository is already installed on your system. Also this package has no file which will replace /usr/sbin/validlocale So removing this Debian repository from /etc/apt/sources.list should solve your ...


1

The Ubuntu Software Centre also keeps a history around, for those that prefer a GUI.


1

I had the same error. You have to do a "sudo" and issue the command one by one : $ wget http://download.microsoft.com/download/ie6sp1/finrel/ $ cabextract -F 'tahoma*ttf' IELPKTH.CAB $ sudo mv -f tahoma*ttf /usr/share/fonts/truetype/msttcorefonts/ $ chmod 644 /usr/share/fonts/truetype/msttcorefonts/tahoma* $ fc-cache -v $ rm -f IELPKTH.CAB


0

Edit sources.list and comment out the duplicate entry. Edit sources.list: sudo nano /etc/apt/sources.list Place a # in front of the duplicate entry Save: CTRL + X, Y, ENTER Update: sudo apt-get update Now try again. Source


1

Enabling Recommended Updates and Unsupported Updates in 'Software & Updates' and then installing skype worked. It seems I didn't have the latest versions of some packages since I have disabled Recommended Updates and Unsupported Updates. I had only Security Updates enabled. I was thinking that I had the latest versions of packages but apparently I was ...


0

Seems that this article talks about that Try this sudo add-apt-repository ppa:gloobus-dev/gloobus-preview sudo apt-get update sudo apt-get install gloobus-preview gloobus-sushi


0

I had a hunch that the problem may have been caused by me using archive.ubuntu.com instead of us.archive.ubuntu.com. Sure enough, upon restoring the old sources.list file, the problem has been solved. Thanks for the help! EDIT Turns out it was not caused by using the wrong server for archive.ubuntu.com, but actually a problem with not having the update ...


1

Using information gathered from everybody here, as well as some more researching, I've created a PPA as an easier fix for this issue sudo apt-add-repository ppa:dwrj87/fglrxfix sudo apt-get update and then sudo apt-get install fglrx or sudo apt-get install fglrx-updates


1

Go to Ubuntu Software Center and search for the package software-properties-common, install that package if it is not installed. Open your dash by pressing the Super Key (Windows Key) and type software sources. Go into the application that appears and place a check mark on all the packages present there. After doing it, execute the following commands one ...


1

What you are looking for is the Ubuntu Packaging Guide: Welcome to the Ubuntu Packaging and Development Guide! This is the official place for learning all about Ubuntu Development and packaging. Section 6. Packaging New Software provides the details on building a package; Section 7. Security and Stable Release Updates dives into security issues; ...


2

In addition to Fabby's answer, there is one more point to consider: the architecture dependency of the package contents. For example, the blender program itself will obviously depend on the architecture of the OS - you can only run amd64 binaries on amd64 OSes. However, a lot of data is not so dependent - the icon files, translations, programs written in ...


0

Ok,you should read it firstly.https://www.debian.org/doc/manuals/maint-guide/. then you should try to create a simple debian package. you know ,dpkg is the main tool for creating package . so you can find information by using man command.


3

To answer your question here I'll use LibreOffice as an example (as nearly everyone has that installed). If you're on Lubuntu (which doesn't have LibreOffice as standard office productivity suite) and you install LibreOffice, it's a nearly empty package although it has package dependencies for Writer, Calc, Base, etc. A package dependency is just a ...


2

Dependencies (and configuration files if you ran the application) can be automatically removed by issuing the following commands: sudo apt-get remove maven sudo apt-get purge if you want to erase old downloaded archive files as well, do an: sudo apt-get autoclean after that you should be able to safely install maven2...


1

I encountered a similar problem, all you got to do it paste this in your bash-terminal : sudo apt-get install eclipse eclipse-jdt eclipse-pde eclipse-platform* libtomcat7-java


0

This problem has been solved by installing the conflicting package. Solution Download and extract the package manually apt-get download conflicting-pakage dpkg -x libc-bin*.deb unpackdir/ Copy the file to your system sudo cp unpackdir/sbin/ldconfig /sbin/ Make sure the package and package system is in a good state. sudo apt-get install --reinstall ...


0

This question interests me, and I'm trying to get another four reputation points, so I can upvote a useful answer I recently found here on ask Ubuntu... so I tried to find the answer: The ones who maintain "Universe" are the Masters of the Universe. On their mailing list there was a discussion on security updates for Drupal, in August 2014. One answer worth ...


1

For anyone who might me interested I am posting the solution here, giving credit tot the website of TeX Live and Debian/Ubuntu which I learned the solution from. Integrating vanilla TeX Live with Debian To install vanilla TeX Live so that it replaces the Debian packages, perform the following steps: Install vanilla TeX Live as root, system-wide. Ensure ...


0

The issue is that debootstrap doesn't use your local keyrings in /etc/apt/trusted.gpg or /etc/apt/trusted.gpg.d/, but only uses the keyrings under /usr/share/keyrings/. From Debian 8 Jessie onwards, you can simply install the (official Debian) package ubuntu-archive-keyring and it should fix your issue. On earlier Debian releases, you could make pbuilder ...


0

How would you go about undoing this fix? Don't have enough rep to comment, but I figured it might be good to remove the certs once you get the drivers, as it sounds like they'll fix the issue server-side eventually. I removed /usr/local/share/ca-certificates/download_01_org.crt and /etc/ssl/certs/download_01_org.pem for what it's worth.


2

I've sent a message on 01.org contact form concerning this certificate problem and linking to this thread. We'll see if it's a man in the middle attack, a server misconfiguration or a new parent certificate unknown on client side. update, I had a response from intel : Appreciate you letting us know. We are aware of the situation and we are ...


0

Checked today (07 Jan 2015). These settings work well for me: APT::Install-Recommends "false"; APT::Install-Suggests "false"; This solution does not work: APT::Get::Install-Recommends "false"; APT::Get::Install-Suggests "false";


0

I had the same problem. I couldn't get my drivers updated at ALL yesterday. Glad I found this so soon. I solved the problem by combining 2 of the given solutions. First I downloaded the cert with openssl echo -n | openssl s_client -connect download.01.org:443 | \ sed -ne '/-BEGIN CERTIFICATE-/,/-END CERTIFICATE-/p' | \ sudo tee ...


0

just update certificates sudo update-ca-certificates worksk like a charm



Top 50 recent answers are included