Tag Info

Hot answers tagged

81

In 12.04 LTS there's a slightly cleaner way to do it. Just run gsettings set org.gnome.desktop.interface ubuntu-overlay-scrollbars false in a terminal. Apps opened afterwards will have the non-ayatana scrollbar. To get the default behavior back, run gsettings reset org.gnome.desktop.interface ubuntu-overlay-scrollbars If you are using 12.10 or later, ...


59

You can disable the scrollbars either For your user: Add the line export LIBOVERLAY_SCROLLBAR=0 to the file ~/.xprofile (create one, if it doesn't exist). Or globally: Create a file /etc/X11/Xsession.d/99disable-overlay-scrollbars and add above line (requires root permissions, see this answer about how to create a file as root). Or per application: ...


30

I am going to answer my own question. Thanks to the user "SevenMachines" in ubuntuforums, I've found a way to disable overlay scrollbars for a specific application. I did a shell script with the following (for eclipse, for example): #!/bin/sh LIBOVERLAY_SCROLLBAR=0 eclipse Then, make it executable, and using the "Menu editor", changed eclipse to point to ...


25

You can remove the scrollbars completely by typing sudo apt-get remove overlay-scrollbar liboverlay-scrollbar


17

That is currently not possible, due to the libraries that Firefox's user interface is written using. There is a bug report that you can mark as affecting you: https://bugs.launchpad.net/firefox/+bug/767040


15

Alternatively, in your .bashrc add the following alias eclipse="LIBOVERLAY_SCROLLBAR=0 eclipse" In fact, you may also want to add UBUNTU_MENUPROXY=0 so unity menus work properly with eclipse, so that becomes: alias eclipse="UBUNTU_MENUPROXY=0 LIBOVERLAY_SCROLLBAR=0 eclipse" [Note: that this will only take effect once you restart your bash shell]


14

You could edit the .desktop File like this: cp /usr/share/applications/eclipse.desktop ~/.local/share/applications/ ...then put... env LIBOVERLAY_SCROLLBAR=0 to the Exec Field that the file looks afterwards like this: [Desktop Entry] Categories=Development;IDE;Java; Comment=Eclipse Integrated Development Environment Exec=env LIBOVERLAY_SCROLLBAR=0 ...


12

Just disabling or removing the overlay-scrollbars as described by the other answers will get you back the scroll bars, but they will be missing the stepper buttons at the end of the bars because they have been disabled in the Ambiance theme. To re-enable them, put the following in the ~/.gtkrc-2.0 file: style "default" { engine "murrine" { ...


10

/usr/bin/eclipse is a start script by itself. You can edit this in a text editor and add the following lines (the same as mentioned in other answers), below the line GDK_NATIVE_WINDOWS=true. export UBUNTU_MENUPROXY=0 export LIBOVERLAY_SCROLLBAR=0


6

There are currently no way to do it. Currently only native Gtk applications support the overlay-scrollbars, additional support will eventually come later on.


5

I'm not entirely certain, as I'm not very fluent in C, but it seems like the patched GTK that Ubuntu uses to load the scrollbars has been hardcoded to look in /usr/lib/ only. From the patch: + gchar *flag = (gchar*) g_getenv ("LIBOVERLAY_SCROLLBAR"); + + /* check if LIBOVERLAY_SCROLLBAR is set to 0 or an empty value + and disable the ...


4

Make sure you have the packages overlay-scrollbar and liboverlay-scrollbar-0.1-0 installed. (It's possible that you somehow lost the package ubuntu-desktop which usually is responsible for pulling in such new packages.) Overlay scrollbars only work in a handful of applications right now (easiest to test are probably Nautilus and gedit), so maybe you have ...


4

This was actually a bug which was reported on launchpad.net , it was confirmed by the Ubuntu Team and then subsequently fixed. You can see the history of this bug here: https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/843456


4

This is currently not available in 10.10. The offical packages in Launchpad.net are just for Natty and Oneiric: Packages in Distributions “overlay-scrollbar” source package in Oneiric Version 0.1.12-0ubuntu1 uploaded on 2011-04-27 “overlay-scrollbar” source package in Natty Version 0.1.12-0ubuntu1 uploaded on 2011-04-27 ...


4

A more generic alternative to the above answers would be this simple script that I called "regular-scrollbars": #!/bin/sh LIBOVERLAY_SCROLLBAR=0 "$1" Save that someplace on your path, and then you can use the menu editor to add "regular-scrollbars" before any command you want (as long as it only has one argument - try "@$" if you think you'll need more ...


3

You should use gtk_scrolled_window widget because is the only widget that support overlay scrollbars. Source https://wiki.ubuntu.com/Ayatana/ScrollBars If it doesn't work try with: sudo su echo "export LIBOVERLAY_SCROLLBAR=1" > /etc/X11/Xsession.d/80overlayscrollbars


3

Maybe you're talking about ayatana scrollbar! in the case that you want to have the old scrollbar style you only need to use the next command: sudo apt-get remove overlay-scrollbar liboverlay-scrollbar liboverlay-scrollbar3 See the image to notice the ayatana srollbar.


3

In Ubuntu 12.04 you can just install Ubuntu Tweak and the option to disable the vertical overlay scrollbar is in Tweaks -> Miscellaneous. You'll need to log-off or reboot for the changes to take effect. If you want the overlay scrollbar back at some point, you just go and enable it back again in the app. In addition you get a large number of tweaks at your ...


3

Simply use utility dconf-editor or gconf-editor. If it is not already present you can install this from Ubuntu Software Center. This utility is like Windows registry-editor where you can tweak system settings. From entry org > gnome > Desktop > Applications.you find an item named ubuntu-overlay-scrollbars. Toggle the item off, logout/login and ...


3

Overlay scrollbars haven't been ported to GTK3 yet so they won't work until this work is done. This porting will be done sometime during the 11.10 cycle.


3

I got it working: The only thing i did (if i remember correctly) is to install overlay-scrollbar package.


3

In Ubuntu 12.04 smooth scrolling is enabled system-wide and many GTK3 applications (most of the default ones) support it. However, the default PDF viewer, Evince, does not yet. The good news is that smooth scrolling in Evince might be coming as an update. See https://bugs.launchpad.net/ubuntu/+source/evince/+bug/981248. Also, if you disable overlay ...


3

Here I did this a while back. This it what I used sudo su echo "export LIBOVERLAY_SCROLLBAR=0" > /etc/X11/Xsession.d/80overlayscrollbars now logout & login


3

The solution is in /usr/share/themes/Ambiance/gtk-2.0/gtkrc – for example, for Ambiance theme. You can edit this file through Terminal (Ctrl+Alt+T): sudo gedit /usr/share/themes/Ambiance/gtk-2.0/gtkrc It contains anything about everything, so be careful. If you don’t mind about the procedure, you can download my file and replace the gtkrc with it, by the ...


2

You could try the methods outlined by Webupd8. My favorite is the uninstallation option: sudo apt-get remove overlay-scrollbar liboverlay-scrollbar-0.2-0 liboverlay-scrollbar3-0.2-0 Bear in mind that Webupd8 says that this may cause dependency issues with metapackages, although in practice I haven't had this issue with 12.04. If you do have dependency ...


2

The solution you are trying to do is suitable for Ubuntu versions 12.10 and not for 12.04 LTS. If you would like to have the old scroll bar in Ubuntu 12.04 then you can do it by installing Ubuntu tweak. Here is the way to do it. open your terminal with CTRL+ALT+T then type as wget ...


2

fossfreedom posted this as a comment, which essentially answers the question: doubtful it will land - according to this blueprint, no progress on this: blueprints.launchpad.net/ubuntu/+spec/… – fossfreedom♦ Mar 5 '12 at 10:50 On its whiteboard (main page), that blueprint currently says: From Etherpad: issues for current implementation ...


2

Yes it is possible... ... at least for GTK apps such as lxterminal, pcmanfm and abiword. Whether on Lubuntu, Xubuntu or Ubuntu, Chromium/Chrome, Firefox, Opera and Seamonkey are browsers that do not currently support overlay scrollbars. Midori and Web (Epiphany) do. LibreOffice, the office suite, also doesn't support them. how-to Just install the ...


2

It's a known bug/"feature" in Nux I believe this is what you mean (see circled cursor): This is a known bug/feature, with no estimated fix date (it's in the backlog). The situation and bug report are very complicated because the bug was originally filed in 2010 when Unity was still 2D; that was fixed, but it's still a problem in the new Unity 3D ...


2

I had a similar issue. I'm not sure if this'll work for you as well, but I was able to fix it, by adding a GtkScrolledWindow with a GtkViewport that has a GtkBox within it. Sorta like this: I hope that fixes the issue you are having.



Only top voted, non community-wiki answers of a minimum length are eligible