New answers tagged

1

Here is the workaround from gangstaluv: sudo apt install conjure-up conjure-up openstack Original Post


0

Try $ juju destroy-environment maas --force, then bootstrap again. If it doesn't help, share maas log file (/var/log/maas/maas.log)


0

tunnel network is for communication which is not important for controller or other nodes. For ex. if you have two compute node. both have VM with 10.10.10.5/16 and 10.10.1.27/16. if both want to communication, then router or switch for both is hosted on network node. so VM hosted under openstack cloud, they don't need to communicate with controller, so this ...


0

If you want to just access the dashboard from your laptop you can use sshuttle: sshuttle ubuntu@<server_ip> -r 10.0.6.0/24 That'll let you load up your dashboard with the container IP. If you want something more substantial then configuring iptables is probably the way to go.


0

You need to associate your ubuntu-net with your instances and associate a floating IP.


1

Your environments.yaml will need to define http-proxy, https-proxy, and no-proxy. See here for all configuration options https://jujucharms.com/docs/1.25/config-general


2

Not yet, you'll want to follow this bug for status of MAAS 2.0 and Juju 2.0 https://bugs.launchpad.net/juju-core/+bug/1564577 As for OpenStack on 16.04 you'll want to do: sudo apt install conjure-up conjure-up openstack


1

This isn't possible with the Autopilot directly. What you can do is change these settings after Autopilot deployed your cloud, but you will have to use juju. First, access the inner cloud environment as explained here: Landscape openstack juju management Then do a series of juju get commands against the services you want to change. In your case, it's going ...


-1

Solved it!!!! Seems like for JUJU bootstrap to work IP forwarding needs to be enabled on MAAS server. Refer: https://github.com/Ubuntu-Solutions-Engineering/openstack-installer/issues/901


0

I also had the same issue, but the following worked for me git clone https://github.com/openstack-dev/devstack.git or git clone git://git.openstack.org/openstack-dev/devstack


-1

You can work around this by changing the image-stream value in your ~/.juju/environments.yaml file from 'daily' to 'released'.


1

There isn’t a single guide to point you towards, mainly due to the size of the project and subsequent ways it can be tailored for an individual’s needs. The question itself spans four different software projects and multiple fields of technology including networking, virtualisation and storage configuration. The most basic of guides can be found on ...


0

You might probably be running into DNS issues. Refer the following link: https://github.com/puppetlabs/puppetlabs-openstack/issues/235 https://github.com/Ubuntu-Solutions-Engineering/openstack-installer/issues/883


0

You should be looking into IP forwarding on the MAAS server. The nodes being managed by MAAS server try to reach internet via MAAS server i.e; MAAS server acts as the default gateway. So even if you configure NAT on the 10.x.x.x switch, the nodes will try to contact the MAAS server to reach internet. Take a look at these issues: ...


0

It's a bit difficult to find a single place that provides all the details. However, I can help to some extent. sudo apt-get install software-properties-common python-software-properties sudo add-apt-repository ppa:juju/stable sudo add-apt-repository ppa:maas/stable sudo add-apt-repository ppa:cloud-installer/stable sudo apt-get update sudo apt-get install ...


0

The entire stack is offline. Will have to recommission and re-run openstack-install.


1

Those images are downloaded from the Internet to make Ubuntu available in the Horizon dashboard to launch cloud instances with. Autopilot is trying to put them in place before your first login. Can your newfangled OpenStack setup connect to the Internet?


0

Share the keystone logs which can help us to debug the issue. Restarting keystone service often helps in such situations if there is not any serious issue.


0

I had the same issue with Hyper-V and I had to patch my grubx64 file as described here: How to deploy MAAS If you plan on deploying MaaS on Hyper-V using Generation 2 images, you will need to disable secure boot in VMs and patch grubx64.efi located in: wget http://wiki.cloudbase.it/_media/grubnetx64.efi.gz gunzip grubnetx64.efi.gz cp grubnetx64.efi ...


1

If you're asking if the MAAS server counts as one of the 5 servers required to use Autopilot, you're correct. 1. You can't add maas as a node as far as I am aware. Autopilot is meant to build the stack in an automated way, if you're capable of adding maas, you'll be doing it against the will of autopilot. Additionally, your landscape server will not be ...


2

Apparently the issue was not enough time. Solved after adding bootstrap-timeout: 1800 to .juju/environments.yaml file.


0

I hit similar thing when login to UI by demo account. I also saw the quota for the project demo is fine. but when I change the volume quota from 10 to 9 and save, I could create the instance well.



Top 50 recent answers are included