New answers tagged

3

Don't mix and match nginx.org repos and the Ubuntu PPAs for NGINX. You are trying to use two separate PPAs - 1.11.3 from upstream Mainline repos, and 1.10.0 from my NGINX Stable PPA. This is something I touched upon in my blog post here, when an influx of bugs prompted the notice. (Content copied into below) Pick one repo, and drop the other in your /etc/...


0

I had the same problem. I DO NOT have Apache, and nothing else was blocking my port 80. I could NOT install nginx with sudo apt-get install nginx nor with sudo apt-get install nginx-common nginx-full After one week I stumbled over this little blog: https://etc.banana.fish/?p=75 In this blog, the solution is: Install nginx-common: sudo apt-get ...


0

First step would be to delete the middle virtualhost: server { listen 443; listen [::]:443; server_name subdomain.domain.pw; return 301 https://subdomain.domain.pw$request_uri; } The next step would be to alter your SSL VirtualHost so it uses CloudFlare's cipher suite, add this into the body of the last VirtualHost (replacing the existing ...


0

location ~ [^/]\.php(/|$) { include snippets/fastcgi-php.conf; fastcgi_pass unix:/run/php/php7.0-fpm.sock; } this will parse all all .php files in the URI, plus paths starting or ending with '/'.


-1

Symlink /etc/nginx/sites-available/phpmyadmin to /etc/nginx/sites-enabled/phpmyadmin & restart nginx This is because that is supposed to be done to make virtualhost works.


0

You have to edit the configurations for your nginx sites under /etc/nginx/sites-enabled and change the listen directives to a different port. Or remove the sites from the enabled list. Once done and you run sudo service nginx restart, then nginx should no longer bind to those ports. (The only other reason nginx might bind to ports and disobey the standard ...


1

Use dpkg-statoverride to change the user and group for /var/log/nginx as the change is most likely happen in postinst script on every package update.


0

To resolve this, I ended up removing Nginx all together. I only had two server blocks setup so it wasnt a big deal to restore everything. Once I installed Nginx and setup my server blocks, everything was working fine. apt-get purge nginx apt-get install nginx I can see how this might not be the best thing but it resolved my issue none the less. Also ...


0

check if there is not another process launching and changing the ulimit before like here with supervisor : https://underyx.me/2015/05/18/raising-the-maximum-number-of-file-descriptors


0

If you have Apache installed. Apply following commands. Stop apache2 service apache2 stop then install nginx sudo apt-get install nginx



Top 50 recent answers are included