Hot answers tagged

24

I got the same problem today. TLDR: downgrade libnl3 or upgrade network-manager. As per this answer, problem is that a fix in libnl3 caused a regression in network-manager. Then, it was only a bug for -proposed packages, but I guess bug was tested enough that it could be introduced into regular Ubuntu ;). Safest way is to take a step back and install ...


14

I had the same problem today. I had to setup the connection manually via command line to get to the internet and then I upgraded Ubuntu. After the upgrade it works fine. If you have DHCP on your router and using the cable, just type the following two commands: sudo ifconfig eth0 up sudo dhclient It helped me to connect to the inernet and to update Ubuntu. ...


8

This one is more simple as mentioned in comments @snark. So try this one first. DHCP required. Link1 If you have access to a differnt pc or OS with internet use the above ticked answer @tamkderplar Link2 Edit:This method is working if you are connected by Ethernet cable as mentioned below in comments section. No need to Downgrade Use Ubuntu's built in ...


5

As of 2016-05-13 this libnl bug is affecting also users without trusty-proposed, who will almost certainly be directed here by Google. Updated libnl and network-manager packages have already been released, so I recommend a forward upgrade. Enable Network Manually Assuming you are using a wired connection, eth0and a network with DHCP enabled, configure ...


3

You can do it this way to fix the problem: Download file: libnl-3-200_3.2.21-1_XXX.deb libnl-route-3-200_3.2.21-1_XXX.deb libnl-genl-3-200_3.2.21-1_XXX.deb OS 32bit: XXX = i386 || OS 64bit: XXX = amd64 Link: http://archive.ubuntu.com/ubuntu/pool/main/libn/libnl3/ To them into one folder and install them with the command: sudo dpkg -i lib*.deb ...


2

I've got this device too. We need both of these files for WiFi to work: /lib/firmware/brcm/brcmfmac43340-sdio.bin /lib/firmware/brcm/brcmfmac43340-sdio.txt Step 1 Using Android firmware was the standard fix for our card (and still works), but now you can get the binary from the Linux firmware repository (and it's already in the installation with 16.04, so ...


2

You need to specify this proxies and apply them system wide. Just collect the IP and Ports for your HTTP and HTTPS proxies and do this with the system proxy setting GUI. Search for Network Proxy in dash. Try user_name:password@Proxy_IP for the authentication. This seems to be the way to configure it in the configuration file. source Ubuntu Main Mate ...


2

I would not recommend downgrading packages or installing new ones by hand - this will inevitably lead to version issues later on. The best fix to this issue is simply to upgrade the network-manager package. The first thing to do is to connect manually to the internet; while the network-manager is dead this does not mean you can not connect. 1. Open a ...


2

You could use nmcli to temporarily change your mac address: nmcli connection modify --temporary <connection_name> 802-11-wireless.cloned-mac-address 00:60:1B:EB:F8:73 nmcli connection up <connection_name>


2

First, I used these commands (thanks, Beleriand): sudo ifconfig eth0 up sudo dhclient eth0 Then I solved it by upgrading the network manager: 14.04 - Network manager stopped working Thank you!


1

This answer summarizes the chat: You can either: let NetworkManager take care of network connections; make sure that managed=true in /etc/NetworkManager/NetworkManager.conf. Restart the Network Manager after changes: sudo systemctl restart NetworkManager. Obsolete entries in /etc/NetworkManager/system-connections can be deleted; if necessary, they will be ...


1

You can write-update a password to a seperate file. This works for me: echo "vpn.secrets.password:MY_PASSWORD" > /my/vpn/password nmcli con up uuid MY_UUID passwd-file /my/vpn/password If you can't do that, you can also "simulate" keyboard, run sudo apt-get install xautomation and try this script (works for me at 16.04 as well): #!/bin/bash nmcli con ...


1

VPN Autoconnect states that "It seems that NetworkManager fails to obtain the user's VPN password from gnome-keyring-daemon." it also states a possible workaround.


1

I had a similar problem once and by changing nm-applet to launch with dbus-launch nm-applet solved my problem. To see if this will work for you, run in terminal dbus-launch nm-applet and see if network menu shows up. If menu shows than to make the fix permanent, edit /etc/xdg/autostart/nm-applet.desktop and change Exec=nm-applet to ...


1

The solution proposed by 'nobody' hasn't worked for me as my computer was unable to connect via ethernet and "sudo dhclient" didn't give any output. This worked for me: Solution if you're unable to connect via ethernet. The step 2 proposed by 'r2rien' worked as a charm and it is really simple, just download the three files (libnl, libnl-genl, libnl-route) ...


1

I faced the same problem before Network manager takes about 8 second theirs two ways to solve this problem: disable connecting automatically of your connection to do this go to edit connection -> select your connection -> edit and disable connecting automatically 2. you can simply disable Enable networking from network indicator.


1

I just switched to Ubuntu so I can't double-check, but was use KDE before. I'm think the package you're looking to install is network-manager-l2tp and then use the network manager GUI to create a new VPN connection. At least that's what I remember doing.


1

This bug has been reported to KDE and they have provided a patch to the networkmanager-qt package. I am looking for people to test it. If you can install one of the following packages (one is for amd64 and the second is i386) https://launchpad.net/~clivejo/+archive/ubuntu/xenial/+files/libkf5networkmanagerqt6_5.18.0-0ubuntu2~ubuntu16.04~ppa1_amd64.deb ...


1

You'll need to add a route to 10.0.0.0/8: route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.73.9.1 dev em2 (untested) To make it permanent add it to your interfaces config in the em2 section: up route add -net 10.0.0.0 netmask 255.0.0.0 gw 10.73.9.1 dev em2 Just for understanding: Your computer knows where to send packets in your local net. For everything ...


1

Finally I was able to fix the issues after trying out numbers of different methods. Get details of your PCI wireless card by running sudo lshw -class network Get your card model info according to the product line. For instance, as you can see in the question description it says product: RTL8723BE PCIe Wireless Network Adapter so the model of my card is ...


1

The problem was my ethernet adapter was not being driven at all. I found that the realtek site only offered drivers for linux kernels 3.x or older so I installed 14.04 and installed the driver and its online now.


1

I have been having the same issue, While not a fix, I found that restarting the network manager works. I have included the instructions to do this below. From the command line Stopping Network Manager sudo /etc/init.d/network-manager stop Starting Network Manager sudo /etc/init.d/network-manager start


1

Another tool that you might want to employ is iperf. You can use this to determine if the local networking is killing your throughput. A reference is located at: https://iperf.fr/. You can simply generate high bandwidth loads and then check what that actual reported throughput is. If you have two nodes you can do the following check. First run sudo lshw -c ...



Only top voted, non community-wiki answers of a minimum length are eligible