Tag Info

Hot answers tagged

9

Preliminaries This following worked for me for Ubuntu 12.04. You should disable your computer's firewall as you test this so it won't interfere. The /etc/default/qemu-kvm file should be as originally installed. You will need to have bridge-utils qemu-kvm and libvirt-bin installed. Any users using virtual machines should be added to the libvirtd group. ...


8

The NAT connection needed to be selected with the hardware being: AMD PCNet FAST III (Am79C973, the default) This works with almost any OS (as mentioned on the Virtualbox help page). The Intel setting for some reason did not work.


6

So you want something like this? +------------+ +---------------+ +--------+ Rest | DVD player |<-- wired -->| Ubuntu Bridge |<-- wifi -->| Router |<--> of the +------------+ +---------------+ +--------+ network You can do this easily with Firestarter. On your Ubuntu machine, install ...


5

Your ip should be on the br0, eth0 won't have an ip. Something like this : # This file describes the network interfaces available on your system # and how to activate them. For more information, see interfaces(5). # The loopback network interface auto lo iface lo inet loopback # The primary network interface auto eth0 iface eth0 inet manual auto br0 ...


5

The following answer repeats much of the information in the Links below                                                          LXC Containers are a lightweight virtualization technology. They are more akin to an enhanced chroot than to full virtualization like Qemu or VMware, both because they do not emulate hardware and because containers share the same ...


5

I've been working on this issue for a while now. I am running 12.04 LXC 0.7.5 on the host and a mixture of 12.04 and 11.04 in the containers. I had zero success with editing: /run/networking/ifstate as it seems to not persist after a container is restarted. I solved the problem by commenting out the following line of the containers config file: ...


4

I think that daemonlogger will do want you want. It is capable of operating in two modes: sniffing packets and logging them directly to disk (files are automatically rolled over after 1GB of data), or in a "soft-tap" mode where it mirrors packets on another interface. It is is the repository, so sudo apt-get install daemonlogger will ...


3

Yes, that is what you need to do. Sharing an internet connection using Network Manager will setup the sharer as a DHCP server, etc, which is not what you want. You can read how to do it here: http://manpages.ubuntu.com/manpages/lucid/en/man5/bridge-utils-interfaces.5.html


3

Unfortunately, I keep answering my own questions aparently. But just to share with others.. Bridge + openvpn works BUT internal network only. AND has an odd bug that openvpn re-connects it self making multiple TAP devices (I use tap method). In the end i solved my problem this way: go back to the normal Network management - default system stuff. Add an ...


3

First, forget virbr0 -- that's added by libvirt and is irrelevant. For an "all-in-one" Openstack server with one NIC, there should be no need for another aliased virtual interface. As discussed in the Openstack guide, you should bridge br100 to your public IP address (eth0), and let Nova create instances and bridge them to br100. e.g. add the below to ...


3

Okay, this is how I got around the problem: 1. Remove Network Manager sudo apt-get remove network-manager note: read the end of this post for a disclaimer 2. Set up pptp on the command line We'll use a handy tool called pptpsetup that sets up all the needed config files for us. Run: sudo pptpsetup --create $your-connection --server se.rv.er.ip ...


2

If you want to bridge connections you need bridge-utils. Create a virtual bridge: root@bridge:~> brctl addbr br0 Add interfaces: root@bridge:~> brctl addif br0 eth0 root@bridge:~> brctl addif br0 eth1 Bounce them: root@bridge:~> ifconfig eth0 down root@bridge:~> ifconfig eth1 down root@bridge:~> ifconfig eth0 up root@bridge:~> ...


2

NetworkManager tries to manage eth0 because eth0 is not configured in /etc/network/interfaces. To cause NetworkManager not to touch eth0, add the following stanza to /etc/network/interfaces. iface eth0 inet manual If you aren't using NetworkManager then you can safely remove network-manager. By the way, there's an easier way to configure bridges in ...


2

These are the two scripts I use to create a bridge for qemu-kvm. First, let the host become a IP router. Script ip-router.sh: #!/bin/bash internetinterface="eth0" username=`whoami` if [ "x$username" != "xroot" ] ; then echo echo "You must be root in order to run this script..." echo exit fi if [ "x$1" != "x" ] ; then ...


2

I've had the same problem. Also the vnc packages is also never installed. It seems to me that the charms is not fully functioning, or i may be missing something... However i made it work by setting up the networking my self. Created a bridge 'br100' and made sure the interface linked to the bridge was set for promiscuous mode. This has to be done on ...


2

You are right something is trying to point lxcbr0. Use lxcbr0 in these files /etc/default/lxc /etc/lxc/default.conf /etc/network/interfaces I tried br0 it give me the same error. After changing existing bridge to lxcbr0 that I worked fine.


2

In the end I ended up just creating an interface and forwarding packets over it with some iptables rules, which seems to be working for me. This does NOT use the 'bridge' option that all the tutorials seem to suggest so I don't know if there is a fatal flaw? auto lo iface lo inet loopback auto xenbr0 iface xenbr0 inet static bridge_ports none ...


2

The guest-Ubuntu configuration shouldn't need to change. At all. A guest OS is given a virtual network connection based on what the host machine makes available. The only changes that need to happen are to the VM settings so it knows to bridge to your wireless connection instead of the previously wired connection. Shut down the guest Load the Virtualbox ...


2

Most trouble occurs because of the Broadcom drivers in HP Laptops at least. If you have a broadcom network controller Check if your card is compatible with b43(link 1). If it is, awesome, keep reading. The default Broadcom sta driver (wl) will not support access point mode. So install b43 taking precautionary measure to be online by any means necessary. Turn ...


2

When you are logged in: Go to Network menu in the panel. Navigate to "Edit connections". When that window opens, select "Auto eth0", and press "Edit" (This assumes that you are connected to the Internet on some other port, for example wlan0 using wireless). A new window will open. Navigate to the tab titled "IPv4 Settings", and change the Method to "Shared ...


2

Lubuntu comes with Network-manager, which makes this very easy. Click on the network icon in your panel, and select Edit connections. In the dialog that appears, select the wired interface and click Edit. In the IPv4-settings pane in the new dialog, you can select Method: "Shared with other computers". Any internet connection will now be shared on your ...


1

If you're using Ubuntu Desktop, then it's really simple. Click the network icon at the to right of your screen. Select "Create new wireless network". Give the network a name, choose an encryption type (wep, wpa, etc) and make a password. Click "create" and that should be it. You can now connect to the wireless network from other computers and the wired ...


1

No, this is not possible. You can connect to both ISPs at once, but each will give you a different IP address. When you say, run a web browser and try to download something, it has to pick one IP address to use, and then its traffic will all be routed through that ISP. You could run one program on one address and one on the other, but you can't get one ...


1

I do not believe this is possible with a Linux-based software bridge (at least, not in its current version). If it were, it should be an option in the brctl utility. Yes, many physical Ethernet switches have some kind of a mirroring/monitoring capability, which would allow you to designate an interface within the bridge to send all traffic to. It sounds ...


1

check the auto connect settings under the ipv4/6 settings under your ethernet connection in network manager, if its set to "connect automatically" it will just keep connecting and disconnecting. your other issue after you change that will be that your ethernet connection may say "connected" and then "disconnected" but not go back to connected. to fix this ...


1

What is wrong with /etc/network/interface ? \ Anyway, I had the same problem, however on 12.04. I tried edm's fix but it didn't help. Then I tried changing the method to "only local" for eth0 and then changing the method for wlan0 to "shared to other computers". Then by using "ifconfig" in terminal I found that eth0 had changed IP to 10.42.0.1, so I used ...


1

If you are using network-manger in Ubuntu, it's an Ad hoc wifi network and android don't recognize them. Therefore you have to create a true Access Point wifi network, with hostap for example. However, custom android ROMs such as CyanogenMod can connect to Ad Hoc wifi networks. If you are already trying to set up a true Ad Hoc wifi network, then the problem ...


1

You need something to tell the outside world to route A.B/16 to your bridge, this involves some kind of router and possibly some kind of virtual router. I'm not sure if learning this kind of routing is your goal or if simply getting VMs bridged is your goal. If you just want your VMs bridged, then bridge them onto the same network as your host. e.g. $ ...


1

You can do the same thing by forwarding packets from ethernet card to wireless card. In order to do that, [wlan0 - wireless card; eth0 - ethernet card]. Do this on your ubuntu machine. ifconfig eth0 192.168.1.1 (or whatever you want) Enable ip_forward by echo 1 > /proc/sys/net/ipv4/ip_forward Enable forwarding in IPTABLES by iptables -A FORWARD ...



Only top voted, non community-wiki answers of a minimum length are eligible