Tag Info

New answers tagged

-1

Here is how I handled it, after reading this thread; I tried first to check the file permissions, through the graphical interface, by opening 'home', 'download', i.e. the location where I put netbeans-8.0.2-linux.sh; seeing the button for changing the file to executable was unchecked, I checked it; I opened a terminal, changed to the directory where ...


1

First an explanation, thank you @kos By using an Exec= line such as Exec=/usr/local/netbeans-8.0/bin/netbeans netbeans is executed in sh already, because the Exec= lines in desktop files are executed as commands in sh, not in bash or else. So Exec=/bin/sh -c "/usr/local/netbeans-8.0/bin/netbeans" spawns an excessive sh instance. Just ...


1

I figured out the issue by looking through syslog. I probably should have done that to begin with, but I'm still a Linux noob. Sorry if I wasted anyone's time! Apparently, Netbeans was failing to pick up a tool agent. Specifically, the instrumentation tool Jayatanaag.jar. For some reason, this didn't cause a fail state when starting directly from a ...


1

try without /bin/sh Exec=/usr/local/netbeans-8.0/bin/netbeans


0

If you want to keep using gtk+ theme, there is a solution that is already implemented by default on ubuntu 15.04 which fixes the menu on java swing applications. sudo add-apt-repository ppa:danjaredg/jayatana sudo apt-get update sudo apt-get install jayatana


1

sudo apt-get install links elinks


0

It is a little bit old but there is this guide from the netbeans.org: https://netbeans.org/kb/72/cnd/qt-applications.html What I did was install the qt4 tools. sudo apt-get install qt4-dev-tools qt4-designer qt4-default qt4-qmake Then within Netbeans install the C++ support with Tools->Plugins->Available Plugins , select C++ and install. From there ...


0

Don't know if this might help but what works for me is assuming you are the the current home directory of your user ./netbeans-8.0.2/bin/netbeans I installed netbeans by downloading the sh installer from their website. Just curious on how to run netbeans via terminal and this worked for me.


2

You have to use terminal. Change directory to the directory where you have downloaded the netbeans6.9-ml-java-linux.sh file. cd /home/username/Downloads/ Then run this. sudo chmod a+x netbeans6.9-ml-java-linux.sh It will enable execution access to the file. After that you should do this to install. sudo bash netbeans6.9-ml-java-linux.sh


1

Try typing in the terminal bash ./netbeans6.9-ml-java-linux.sh



Top 50 recent answers are included