New answers tagged

1

That error number suggests that you have something in your 'mysql' database (the one it uses for settings) that is incompatible with this version of mysql. The plugin could not be loaded to handle that bit of data and that is preventing mysql from loading. I'm guessing its a maria db thing that is not supported in mysql. One way round this would be to ...


0

Remove MySql completely: 1.Stop the MySql Database Server sudo service mysql stop OR sudo service mysqld stop 2.Kill all the MySql related processes sudo killall -9 mysql sudo killall -9 mysqld 3.Remove the MySql files and related dependencies sudo apt-get remove --purge mysql-server mysql-client mysql-common sudo apt-get autoremove sudo apt-get ...


1

Open a terminal and type: sudo apt-get remove --purge phpmyadmin or as Rinzwind noted sudo apt-get purge phpmyadmin this should (1) remove phpmyadmin and (2) remove its settings files and so on too.


1

Edit: upon re-reading your question I surmise that your server is behind a firewall that you do not control? If so, please disregard the iptables part of the answer and skip to the SSH config part... Is it a matter of wanting the transport to be encrypted, or is it simply a matter of getting through the firewall? Getting through the firewall could be as ...


0

Here are the general instructions for how to forward ports via ssh. https://help.ubuntu.com/community/SSH/OpenSSH/PortForwarding Please ensure you have permission from your network admins to subvert their security in this manner, please also take precautions to secure this tunnel.


0

Those lines belonged to an older version of SonarQube. If you are using SonarQube 5.x, there is no need to set those lines. Check the updated post on http://mamikon.net/blog/installing-sonarqube-ubuntu/


1

You are entirely able to kill the process, but it seems to be starting itself again. If you notice, the PID is changing each time that you kill it. Something on your system is automatically starting it on your behalf. You have a couple of options: Seek and destroy whatever is starting it (usually some sort of web control panel like XAMPP, probably in this ...


1

Moving a MySQL database involves "exporting" it and then "importing" it, not copying it. You have identified that you have "phpmyadmin" installed. On your Windows computer use it to export your database. Copy the resulting file to your Ubuntu computer and use "phpmyadmin" on your Ubuntu computer, in this case, to import it. Alternatively use: mysqldump


0

You have changed or removed debian users used to maintain MySQL. 'debian-sys-maint'@'localhost' http://www.electrictoolbox.com/restore-debian-sys-maint-mysql-user/


1

You do not need to change the root user. For purpose of data operations we usually create a new mysql user and grant certain privileges to this user (generally limited to a database). This can be done in following ways: From terminal mysql -u root -p and enter the root password. Then, in the terminal you will see as mysql> indicating you are ...


2

This is pretty normal for applications like Xampp, MySQL, etc. Unless you install it in the home directory, it is usually installed in places like /opt/, which usually needs sudo access to run (unless you forceably disable that with the chmod command) to run as user http://dev.mysql.com/doc/refman/5.7/en/changing-mysql-user.html


2

Do the following to clean out the broken packages: sudo apt-get clean sudo apt-get update sudo dpkg -r mysql-client-5.7 sudo dpkg -r mysql-server-5.7 sudo dpkg -r libmysqlclient20:i386 sudo dpkg -r libmysqlclient20:amd64 sudo dpkg -r libmysqlclient18:amd64 sudo dpkg -r mysql-common sudo dpkg -r mysql After that reinstall it with: sudo apt-get install ...


2

Thanks to @Videonauth sudo dpkg -r mysql-client-5.7 sudo dpkg -r mysql-server-5.7 sudo dpkg -r libmysqlclient20:i386 sudo dpkg -r libmysqlclient20:amd64 sudo dpkg -r libmysqlclient18:amd64 sudo dpkg -r mysql-common Then running: sudo apt-get purge mysql-workbench mysql-server mysql-common mysql-client If anything fails, just run sudo dpkg -r ...


0

Current most compatible solution in my case is to enter the root password in /etc/mysql/debian.cnf In addition, I've submitted a bug report. https://bugs.launchpad.net/ubuntu/+source/mariadb-10.0/+bug/1582209


1

Here is what we have so far. First, edit your /etc/apt/sources.list file and remove mariadb by executing the following commands: sudo sed -i 's/^.*mariadb.*$//g' /etc/apt/sources.list sudo apt-get update Now, let's fix that broken package: sudo apt-get install libmysqlclient18=5.5.49-0ubuntu0.14.04.1 libmysqlclient-dev Please post any more errors, ...


0

try adding that text to your my.cnf and replace --defaults-file=/etc/mysql/debian.cnf with --defaults-file=~/.my.cnf include your password. your request got denied because debian.cnf overrides [client]. if .my.cnf looks like: [client] user=mysqluser password=mysqlpass


0

If you have a working IMAP server authentication setup, you can easily change postfix/saslauthd to use it instead of PAM: "/etc/default/saslauthd": MECHANISMS="rimap" MECH_OPTIONS="127.0.0.1"


0

First of all run these two commands sudo service mysql stop sudo /opt/lampp/lampp restart If that doesn't solve your problem than run following command in terminal one at a time sudo chmod -R 777 /opt/lampp sudo chown -hR nobody /opt/lampp sudo chmod -R 755 /opt/lampp Than start server and you will be good to go


0

Just ran into the same error. You'll need to manually enable the mysqli php module and then restart apache: $ sudo phpenmod mysqli $ sudo service apache2 restart After that, it all worked (for me).


0

You should try this command: GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,DROP,INDEX,ALTER,CREATE TEMPORARY TABLES,LOCK TABLES ON drupal.* TO 'drupaluser'@'localhost'; For more info, refer this. Link: http://dev.mysql.com/doc/refman/5.7/en/grant.html


1

libmysqlclient_r.so is not part of the libmysqlclient in ubuntu 16.04. You can create a symlink to the compatible libmysqlclient.so before you run your command using: sudo ln -s /usr/lib/x86_64-linux-gnu/libmysqlclient.so /usr/lib/x86_64-linux-gnu/libmysqlclient_r.so


0

/etc/init.d/mysql stop service mysql stop killall -KILL mysql mysqld_safe mysqld When you see the following information, you success mysql: no process found mysqld_safe: no process found mysqld: no process found I use this to solve the installation problem of MySQL 5.6 in Ubuntu 15.10 using this link. During this installation, I encounter the problem ...


0

From what I understand pam_mysql is no longer being developed and that particular feature in it was deprecated years ago, the new update finally "broke" it. I have found no solution as of yet, other then migrating your authentication away from mysql, which for me isn't an option really, so still looking for a solution. update: I just found this page, ...


0

This is a known issue with MySql 5.7. A workaround is mentioned here[1] Workaound: set GLOBAL sql_mode="ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION"; ​ [1] https://wso2.org/jira/browse/APIMANAGER-4645


0

Please check that apache and php packages exist or not in your machine. Please follow this steps to completely remove mysql Now open the terminal ctrl + t sudo apt-get purge mysql-server mysql-client mysql-common mysql-server-core-5.5 mysql-client-core-5.5 sudo rm -rf /etc/mysql /var/lib/mysql sudo apt-get autoremove sudo apt-get autoclean Install ...


0

Here are the commands to run to install MariaDB on your Ubuntu system: sudo apt-get install software-properties-common sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8 sudo add-apt-repository 'deb [arch=amd64,i386] http://mirrors.hustunique.com/mariadb/repo/10.1/ubuntu xenial main' Once the key is imported and the ...


1

The following commands worked for me to uninstall and reinstall MySQL (in this order, although I don't know if some of these commands are surplus): sudo apt-get install mysql-client sudo apt-get install mysql-server sudo apt-get purge dbconfig-mysql sudo apt-get purge mysql-common sudo apt-get install mysql-server sudo apt-get install mysql-client


0

To expand on what @Zarco said, you can use sudo mysql to operate as root temporarily if you have sudo access on the machine. It looks like the standard is to use the plugin field now to do unix_socket authentication on MySQL.


0

I have wasted now 2 days on this. Finaly I got the solution, remove xampp and install mysql, phpmyadmin, php5, apache2 manually. sudo apt-get install apache2 mysql-server mysql-client php5 libapache2-mod-php5 apt-cache search php5 Then pick the ones you need and install them like this: apt-get install php5-mysql php5-curl php5-gd php5-intl php-pear ...


0

I had the same problem, it was caused by a "plugin" value in "mysql.user" table. Have you tried with this answer: http://askubuntu.com/a/636579/299538 Here is an explanation for that: http://superuser.com/a/1071043/592085


0

As you enclosed, it is from the log: Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Invalid default value for 'REG_CREATED_TIME' According to this there is no problem with Ubuntu or linux. It's a Java problem and the log is a Java stacktrace. Update: OK, I did some investigation and I tried out you want to install an ...


0

I encountered this problem too and pkill is a little bit brutal I think Since I'm not using any akonadi dependent applications I make a akonadictl stop when mysqld get too much weighted. It will not restart until I launch something like Kmail, Kontact, what means never ! Unfortunately it will resume on reboot. I didn't found any solution to fix that ...


0

in my case it was password mismatch for maintenance user debian-sys-maint between one in /etc/mysql/debian.cnf and one in MySQL database. This user is used for MySQL shutdown and other functions. After MySQL update it might happened that there is a pass mismatch between file and database. This could also happen if you move your database from one MySQL to ...


0

Yes. It helped to escape special chars: MPASS=$(printf "%q\n" "$DB_PASS") But there was still a problem with mysqldump. I finally found out, that mysqldump only worked for me with passwords with special characters when I don't tell mysqldump the host (-h hostname). This seems to be a bug. Or isn't it? Unfortunately I also have sites where the mysql ...


1

The answer is in the comments, but I think It is worth to post it there. I downloaded mysql-apt-config_0.7.2-1_all.deb (MySQL APT repository - dev.mysql.com/downloads/repo/apt) from dev.mysql.com and during config I have chosen Ubuntu Wily since 16.04 was not on the list. And that was the problem, Xenial already has MySQL 5.7 in its official repositories. ...


2

Can you paste all output from an apt-get update? Maybe if you try this: sudo rm -f /var/cache/apt/archives/mysql* sudo apt-get autoclean Then: sudo apt-get update


0

Check your db as it looks like you already have the key 'REG_PATH_IND_BY_PATH_VALUE' defined and are trying to create it again when you do the create index 'REG_PATH_IND_BY_PATH_VALUE'. This could be that when you first tried to run the query, that part succeeded and then it failed on something else and now is failing because the create worked first time. ...


0

I highly recommend you to trying LAMP Stack from Bitnami. Bitnami LAMP Stack Manager It's completely self contained and will not interfere with other software on your system. If you unsatisfied with this, just delete the folder. Or execute uninstall script inside the folder for clean removal.


0

for ubuntu 14.04 or higher: sudo apt-get install php5-xdebug Make sure that the installation of the xdebug lib is in the correct folder: cd /usr find . -name 'xdebug.so' 2> /dev/null That should output something like this: ./lib/php5/20121212/xdebug.so Append both the /etc/php5/apache2/php.ini and /etc/php5/cgi/php.ini files with the ...


2

I have encounter the same problem. Though i had the big enough memory 12Gb given to my VM, but still things were failing as in question. After spending some time found that default apt get was missing some of the configuration translation and tool translation packages. The MySQL apt repository provides a simple and convenient way to install and update MySQL ...


0

I confirm that L5 works fine with PHP7 on Ubuntu 16. Actually, i'm using it right now. Installation from composer.


1

you shouldn't need the []'s try mysqldump -u root -p guru99 > guru99.sql and guru99 should be your database name


0

As you are new to Linux. Try reading these articles (this and this one too) related to MySQL installation. This will help you understand meaning and reason behind each command which you are using.


0

This is the kind of problem I love... afterwards. It may be a bit long and tedious, but let's work through it. I would begin by clearing out your /var/cache/apt/archives folder: cd /var/cache/apt/archives sudo rm *.deb Then run : sudo apt-get update sudo apt-get upgrade I suspect you'll run into an error somewhere in the apt-get update or upgrade, ...


0

Your password needs to have the special characters escaped. So if your original password is xgT{uic[Is?uJ+it will have to become xgT\{uic\[Is\?uJ\+ (A slash before the special characters). You might also want to look at something already written to do this such as AutoMySQLBackup, but I'm not sure if you need daily, weekly or monthly backup rotations. ...


0

If you installed phpymadmin from the archives, php-gettext is a dependency and would be automatically installed.


0

From here: phpmyadmin not working due to missing mbstring extention sudo apt-get install php-mbstring php7.0-mbstring php-gettext sudo service apache2 restart


0

Did you set up a password for the root user? I got the same problem. A possible workaround could be to set up your configuration (rest of users you will use, create new DBs, etc...) using sudo to operate with the root user. For standard operations with non-root users I am not experiencing any problem. Hope this help.


0

I have set password in this way: After completion of mysql installation, run command: sudo mysql_secure_installation It will show: NOTE: RUNNING ALL PARTS OF THIS SCRIPT IS RECOMMENDED FOR ALL MariaDB SERVERS IN PRODUCTION USE! PLEASE READ EACH STEP CAREFULLY! In order to log into MariaDB to secure it, we'll need the current password ...


0

You stated that you "just copied my old set of databases" The word "copying" in this situation could imply an incorrect approach. Of course your "copying" may have involved other undisclosed steps. MySQL seems to be structured to export your databases and to then import them into the "new" database. Not actual copying. Do you still have your original MySQL ...



Top 50 recent answers are included