Hot answers tagged

4

Those commands go into ~/.mysql_history.


2

Did the (truncated) line "Found option without preced" originally read something like Found option without preceding group in config file: /etc/mysql/my.cnf at line: 123 If that's the case, there's probably a option in your my.cnf file that's not assigned to a group. The my.cnf file is divided into several groups, one with options for the MySQL server, ...


2

we were also facing same issue after Upgarde from 14.04 to 16.04 Solved the problem by removing myisam-recover = BACKUP and key_buffer = 16M from my.cnf Then use "sudo service mysql start" to start the MySQL daemon again and "sudo apt-get -f install" to recover your system packaging state. here I found it https://bugs.launchpad.net/ubuntu/+source/mysql-5....


2

I have found a solution with help from "steeldriver" Problem: My problem was that i run forever start myscript.js with user root, forever save all logs in folder of the user that run the script, that is why i have no space in /dev/md1 Solution: move all files that was in /root/.forever to my new user, /home/user/.forever and run forever start myscript.js ...


2

Dynamic link libraries (DLLs) are a Windows-specific technology and don't work on Ubuntu. Because PHP can be run on different operating systems, its configuration files contain examples for how to configure it on different operating systems: ;;;;;;;;;;;;;;;;;;;;;; ; Dynamic Extensions ; ;;;;;;;;;;;;;;;;;;;;;; ; If you wish to have an extension loaded ...


2

I would suggest you change your vhost to name based: Replace the IP address with *:443 and add ssl certificates set the server name to your alias minus the www. add a second vhost for http which only redirects to https This should allow you to use vtiger from the local network and from the outside world and has added security through https. Now let's ...


2

There is not really a need for a bash script. First, work out what backup command would work for you. In principle, you could do something as easy as: mysqldump > /path/to/mysqldump.sql 2>/path/to/mysqldump.err This will write the contents of all the data bases to a file called mysqldump.sql. The form of this is such that, if you need to restore the ...


1

The easiest way to delete a database from within a script is: echo "drop database dbname" | mysql -u username -ppassword This will start up the mysql command line client and execute the SQL statement that was piped into it by the echo command. In your script, you can either delete the database as soon as it has been backed up: echo "drop database $db" | ...


1

Finally, it works! :) After install php, i typed in terminal: gksu gedit /etc/apache2/apache2.conf Then add the following line to the end of the file. Include /etc/phpmyadmin/apache.conf Then restart apache /etc/init.d/apache2 restart Thanks for help @Hellas and i hope this command helps somebody!


1

It happened to me as well and I fixed it by: uninstalling the package $ whereis apache2 manually remove anything related to it fresh package reinstall


1

Try the following code in your terminal sudo service mysqld restart I think thats what your looking for


1

We found that a 3rd party web app was managing it's own session files and failing garbage collection. Once we deleted some very old folders of them, the issues disappeared.


1

Connection string depends of software you use, but yes, if you are on same machine with webserver and database, you refer to it as localhost or 127.0.0.1 or by hostname too, if you wish.


1

After I founded the error message in /var/log/mysql/error.log 2016-07-06 07:15:03 58630 [ERROR] /usr/sbin/mysqld: unknown variable 'audit-log=ON' Then I opened the config file /etc/mysql/my.cnf and founded a row with the statement audit-log=ON I deleted that row and tested to start the server again with sudo /etc/init.d/mysql start the first time it did't ...


1

I found a solution at: http://stackoverflow.com/questions/25244606/completely-remove-mysql-ubuntu-14-04-lts/28113482#28113482 sudo rm -rf /var/lib/mysql/mysql sudo apt-get remove --purge mysql-server mysql-client mysql-common sudo apt-get autoremove sudo apt-get autoclean sudo apt-get install mysql-server During the reinstallation I was prompted for a (...


1

Try this: mysql --host *HOST_IP* --user *USER* --password=*PASSWORD* -D *DATABASE_NAME* -e "DELETE FROM `wp_posts` WHERE `post_type` = "attachment" ;


1

The mysqld.conf file had collation-set-server = utf8 when it should have been character-set-server = utf8


1

You're on the right track, but not really there yet. The file you read about is the /etc/passwd file, not the /etc/passwd.lock file. /etc/passwd defines which user accounts are available on you machine, which group(s) they belong to and other things. Many, many years ago /etc/passwd also contained the account's passwords. But for security reasons those were ...


1

Use this: sudo update-rc.d mysql defaults Good luck


1

After changing the data directory you need to change the Apparmor settings to solve the permission issue Open /etc/apparmor.d/usr.sbin.mysqld Comment out /var/lib/mysql/ r, /var/lib/mysql/** rwk, Then /mnt/01D0900CA5E8F760/ProgramData/MySQL/MySQLServer5.6/ r, /mnt/01D0900CA5E8F760/ProgramData/MySQL/MySQLServer5.6/** rwk, Also see to it ...



Only top voted, non community-wiki answers of a minimum length are eligible