Tag Info

New answers tagged

0

Thanks. Jacob's solution is just what I was looking for. <screen> is meant to replace the specific input that you need to provide to xrandr. To find out what that name of the input is, look at the first acronym that appears just before the list of numbers when you run xandr. In my case these were LVDS1 and VGA1 (the first is my laptop, the second ...


0

https://apps.ubuntu.com/cat/applications/precise/arandr/ ARandR is a visual front end for XRandR 1.2/1.3 (per display options), which provides full controll over positioning, saving and loading to/from shell scripts and easy integration with other applications. This is a program that allows you to save scripts. In turn, this eliminates having to set ...


0

Looks like you need a custom modeline for your display (Basically a custom "output"). Either that or your drivers aren't working properly... I had this issue with an old monitor and a custom modeline sorted it right away :P You can add the native resolution modeline (1920x1080_60.00?) and then you should be able to switch to it, any other resolutions will ...


0

Did you install Unity with the CompizConfig Settings Manager? You can download it with sudo apt-get install compizconfig-settings-manager. Then launch with ccsm. Click the desktop section on the left then Unity plugin, use the filter to find "Edge Stop Velocity" and set it to 0.


0

I had this working on a Dell E6520 with the eport+ docking station on Ubuntu 14.04.1. The drivers that I had working correctly were the following packages. Once I got them working I then pinned them through synaptic. libcuda1-331_331.38-0ubuntu7.1_amd64.deb nvidia-331_331.38-0ubuntu7.1_amd64.deb nvidia-331-uvm_331.38-0ubuntu7.1_amd64.deb ...


0

The solution below works as follows: Press a key combination The first application that starts within 15 seconds will start on screen 1 or: Press a(nother) key combination The first application that starts within 15 seconds will start on screen 2 In other words: you'll need two key combinations to make sure a new application window appears on either ...


1

Here's an idea for a startup script or at least a script that can be bound to a shortcut to launch windows for the first time: Step 1 Find out your root window width and height. This can be done with xwininfo -root | awk '/Width/,/Height/ {print}' or xprop -root | awk '$1~/NET_DESKTOP_GEOMETRY/ {print } Sample outputs are bellow $ xwininfo -root | ...


2

It will take a background script to keep track of whether the second monitor is connected or not. The script below checks every five seconds if that is the case, and sets the wallpaper accordingly. The script also remembers the set wallpaper for the two states (connected/disconnected) in a hidden file. The file is automatically updated if you change the ...


1

You need to look at xrandr command May be something like: xrandr --output SCREEN1 --output SCREEN2 --output SCREEN3 --same-as SCREEN2 where SCREEN3 mirrors SCREEN2. Replace SCREEN1, SCREEN2, SCREEN3 with the appropriate name that you get with the xrandr command (without any option). For example, LDVS1, HDMI1, VGA1, etc ...


0

i fix my problem with this xrandr --output DFP3 --mode 1440x900 --rate 59.9 and monitor turn on. After this i see In system-> display and monitors checkbox for enable monitor, but before i not see his. checkbox is hidden on window. Last version of kodi is very buggy - this problem with Blank other displays option - not return monitor to on, after close ...


1

I made my self a little script to switch screens (I've two identical LCD in splitscreen vs one Beamer so I changed the script to match your case) #!/bin/bash if [[ $(xrandr | grep "DFP3 connected") ]]; then xrandr --output DFP2 --mode 1920x1080 --output DFP3 --off else xrandr --output DFP3 --mode 1440x900 --output DFP2 --off fi Just save this as ...


1

Welcome to Ubuntu with systemd rather than with upstart. This is systemd bug #76267. Lennart Poettering's initial explanation was:The [nvidia] binary driver does not implement the DRM interfaces in /sys. This means we cannot detect how many displays are connected and then we decide not to handle the lid switch since we cannot be sure about whether the ...


0

This is a simple solution that works for me as I work remotely with multiple monitors as well as across platforms.(Windows, Mac, and Linux) I use a program called Teamviewer, that can be located at Teamviewer.com I am currently running it through wine but have run the linux version successfully as well. It will allow you to quickly switch between monitors ...


1

For anyone still wondering on this topic: the xrandr and x11vnc clip does work; to enable the mouse to get over there you need to use the panning argument to set the mouse tracking area: xrandr --fb 2560x1024 --output LVDS1 --panning 1280x1024+0+0/2560x1024+0+0 Then when running xvnc use: x11vnc -clip 1280x1024+1281+0 -nocursorshape -nocursorpos That ...


4

First Solution: x2go is an Open Source remote desktop application for GNU/Linux that uses NX technology protocol. Install X2Go Server On Ubuntu 14.04: Run the following commands to add X2Go repository and install it in Ubuntu 14.04 or higher versions. sudo apt-get install software-properties-common sudo add-apt-repository ppa:x2go/stable sudo apt-get ...


1

I used NoMachine NX for a long time which worked well for me. The server run on a Ubuntu Server and I was able to connect from both Windows and Linux. According to this article, the previous version 3.5 (current is 4.x) already supported multiple monitors what is said to be improved in 4.x. If this is what you are looking for, you could give it a try as ...


0

Try this: xrandr --output "nameYourVGA" --mode "yourResolution" For example: xrandr --output VGA1 --mode 1366x768 See if that works.


0

Found a reasonable hackaround. The following script does what I want, albeit in a kinda ugly way alias xcmd='xrandr cmd to turn on monitors, turn off laptop' alias xcmd_inv='xrandr cmd to turn off monitors, turn on laptop' $xcmd sleep 1 $xcmd_inv sleep 1 $xcmd sleep 1 $xcmd_inv sleep 1 $xcmd That's not the real script, but hopefully clear enough to anyone ...


2

I posted the bug to gdm developers and got the tip to use static conf. /etc/X11/xorg.conf.d/21-intel.conf Contents: Section "Device" Identifier "Intel Graphics" Driver "intel" Option "monitor-eDP1" "eDP1" EndSection Section "Monitor" Identifier "eDP1" Modeline "1920x1080" 172.80 1920 2040 2248 2576 1080 ...


0

It could have something to do with your drivers. Open the dash and search for Proprietary Driver and see if you have to update your drivers for the Intel Graphics card


0

Hmm... here's screenshot of XFCE's display properties from my home system with two equal monitors. When I had Benq 24" and LG 19", there also weren't any problem for using two monitors with different resolutions. Left (primary) connected with HDMI, and secondary connected with DVI. XFCE: 4.12, Ubuntu: 14.04.2 (originally in Russian, I added English ...


1

Post installation and removal nvidia, I noticed a strange(and a good one at that) behaviour. And that its that the GUI response in second monitor has become much improved. And I also noticed that the xorg.conf has a different setting, pasting it for your reference, jpvel@jpvel-M11xR3:~/Downloads$ sudo cat /etc/X11/xorg.conf.04192015 Section ...


0

You're not the only one to experience this and unfortunately there is no fix. Users have reported this behaviour since 2010 and it has been an open bug since 2011. Having explored the various suggestions in those links, until this bug is fixed, I think the only way is to adjust the speed manually each time


0

old but busted: http://www.webupd8.org/2012/10/ubuntu-multi-monitor-tweaks-full-screen.html Maybe people like me still searching for solutions...


0

Even though this is a few years old, I see there is no accepted answer. I have a Sapphire Radeon HD 5450 card that drives three monitors. My monitors are VGA 1440x900, HDMI 1680x1050, and VGA 1440x900. The ports are VGA, HDMI, and DVI. Therefore, for the DVI port I use an adapter. You would need to use the open source xorg drivers for best results. No ...


1

What you usually need to do in these situations is adding a small break in the command after login. Add this to your Startup Applications: /bin/bash -c "sleep 15&&xrandr --output DFP10 --rotate left && xrandr --output DFP11 --right-of DFP10" (If that is the normally working command) The reason is that most likely the command is performed ...


0

It is not clear whether you want to activate three monitors on the NVidia or do you want to use one monitor connected to the onboard graphics adapter. I have three monitors on GeForce 210. Two are connected to the NVidia and the third to onboard adapter. I was not able to set it up with NVidia drivers, but I did not spend to much time trying. I tried it ...


1

As I suspected, this was no fluke: Your monitors.xml contained an erroneous configuration without HDMI. Here is the corrected version that only contains one single configuration (the original that worked without any problems) Now, replace your existing version with my corrected one keep a back-up of the corrected just in case this ever happens again... ...


1

RandR is an extension to the X11 server that is used to communicate the configuration of outputs between the server's clients (= applications) and the graphics driver. Most applications don't actually speak the protocol themselves, but instead use a library called libXrandR. FakeXRandR replaces this library with one that still asks the graphics driver for ...


1

Solved! I thought that by adding a wallpaper (3840x2160) that wasn't the exact same size as my dual monitor set-up (3840x1080), Ubuntu would have adjusted it, but it didn't. So I search for 3840x1080 wallpapers, spanned it in the Tweak Tool panel and now it works. But still it confuses me that when I was in Activities or Show Application the wallpaper was ...


0

A recent update solved the problem


0

I had the same problem when I connected my second display to the VGA port. Problem solved when I changed to DVI. I found other issue using Display Port with a VGA adapter. The system goes crazy and becomes unable to detect the resolution properly. Quite a mess.


2

Some system updates came out today, and I applied those using Synaptic Package Manager. After the update and another reboot, the dual-monitor system is working again. I don't see anything in the updates that appear to have anything to do with display, but my guess is that maybe running the updates flushed out whatever the disconnect was that was keeping the ...


0

So after some experiments and with small luck i found out that i had to regenerate my xorg.conf file using command: sudo nvidia-xconfig. after that restart lightdm and thats it ;) additionally in display settings(not nvidia-settings) you probably will have to choose that all is align by laptop screen


0

I had the same problem, found a workaround here: http://ubuntuforums.org/showthread.php?t=2149791. xrandr --output LVDS1 --auto --left-of HDMI1 --output HDMI1 --auto --scale 1.0001x1.0001 (Adjust outputs accordingly) The important thing is to change the scale of your output. Beats me why this works, I hope they'll come up with a proper fix.


0

By sheer coincidence I had a similar problem right here with this computer only yesterday. Believing in trying the simplest solution first I applied a thin layer of CAIG DeOxit D100L to both ends and that fixed it. I recommend it to all my friends. I gave a vial of this to my girlfriend two years ago, and of all the gifts I've given her for birthdays, ...


0

I've had this problem since Ubuntu 14.10, with similar setup. I just gave up on Unity and run the Metacity flashback session instead. I like Unity, but I can't stand the cursor playing hide-and-seek.



Top 50 recent answers are included