New answers tagged

0

Just for reference: This is considered a mysql bug and tracked in https://bugs.launchpad.net/bugs/1576930 So far the answer from Firouziam is the correct workaround for those that do not use kdepim.


0

Your memory is probably being used as a RAM disk (https://en.wikipedia.org/wiki/RAM_drive). Type df -h. Do you see a "tmpfs" that is mounted on either /dev/shm or /run/shm? If so, that is your memory being used for that file system. In the past, I have stored frequently accessed files there (Note: the files are deleted when you reboot). I don't remember ...


1

There is no need to drop caches; Linux will cache data as much as it is allowed to, when memory pressure gets too high it will start to discard pages that are no longer useful and write back dirty pages to free up spare memory. The Linux philosophy is to keep data cached just in case it needs to be accessed again later, and if memory is required it will ...


0

A good way is to check the processes with the largest RSS ps aux --sort -rss | head ..or use tools such as slabtop to see where memory is being used on the Linux slab allocator: sudo slabtop


1

Install htop via sudo apt install htop start htop by typing htop Press F6 to trigger the sort-function and select MEM% on the left side via arrow keys As a result you get a dynamic list of all processes sorted by mem-usage


2

To list the processes sorted by the memory usage ps --sort -rss -eo pid,pmem,rss,vsz,comm More information here : how-to-detect-a-memory-leak The server is killing processes to free memory, this is what happens when all the virtual pages are allocated (swap+ram). If possible the best would be to restart the server to have all the stopped services ...


3

Please consider the sample output I got from the free command in my Ubuntu 12.04: total used free shared buffers cached Mem: 8074640 6187480 1887160 377056 365128 2113156 -/+ buffers/cache: 3709196 4365444 Swap: 15998972 82120 15916852 The Mem used(kb_main_used) field value is now ...


0

Your issue is that your computer files are currently mounted on /sda1 which is only 100GB, whereas SDA2 seems to be an empty junk drive at the moment. To fix this, do the following, but read every step before trying anything. The format for fstab, which is the partitioning and mounting file is as follows: UUID=???????? /home ext3 defaults ...


0

I encountered this problem too and pkill is a little bit brutal I think Since I'm not using any akonadi dependent applications I make a akonadictl stop when mysqld get too much weighted. It will not restart until I launch something like Kmail, Kontact, what means never ! Unfortunately it will resume on reboot. I didn't found any solution to fix that ...


0

For ubuntu 15.04, this has changed. The correct way to set the oom setting for a pid is echo 42 > /proc/666/oom_score_adj instead of /proc/666/oom_adj



Top 50 recent answers are included