Tag Info

New answers tagged

0

A simple solution is to unset the environment variable causing the problem before running Matlab. Seems to work so far without side effects: $ unset JAVA_TOOL_OPTIONS $ matlab


0

According to the first line it would like to write on your storage, and it didn't have permission. Likely it writes in the /etc directory and it has root owner that's why you need to run it with sudo.


2

you don't have to make an alias. Easily just add the matlab bin directory to your PATH. PATH=$PATH:/home/user/matlab/bin add this line also to .bashrc and then source .bashrc if you want to make it permanent. NOw you can run the command matlab with no need to create an alias. But to know your error above, you probably have understand syntax of alias in ...


2

Mount the iso by command line: sudo mount -o loop myIsoFile.iso /media/iso then you will know were you mounted it.


0

Go to Preferences-->Keyboard-->Shortcuts In the Active settings dropdown choose Windows Default Set.


6

According to the following line from your message, you have the jayatana package installed: Picked up JAVA_TOOL_OPTIONS: -javaagent:/usr/share/java/jayatanaag.jar This package is responsible for application menu support for Java swing applications, and seems to be the cause for the segfault. Removing it worked for me: sudo apt-get remove jayatana Don't ...


0

One stackoverflow thread showed that segmentation violation error can be solved by changing the default renderer to zbuffer. Add this line to the startup.m file: set(0, 'DefaultFigureRenderer', 'zbuffer');


0

This is a very good guide page for me and if you follow it you will get Matlab installed. They are discussing the Java problem there too. My understanding is that the Matlab version you are using is old and that you have installed java but not the java development kit (jdk). Probably you will need to either install a newer Matlab version or install an older ...


3

Possible solution: Link libgfortran.so.3 to libgfortran.so ln -s libgfortran.so.3 libgfortran.so Rebuild ld cache sudo ldconfig Reinstall the lib Check out http://stackoverflow.com/questions/16710047/usr-bin-ld-cannot-find-lnameofthelibrary for more info.



Top 50 recent answers are included