Tag Info

Hot answers tagged

7

In a Terminal, type these commands: sudo apt-get install blueman sudo reboot Then will works fine. Seems it's a bug in new Bluetooth manager.


4

Find the device ID of your magic mouse by doing: xinput list Then set the inverse scrolling by doing: xinput set-button-map ID 1 2 3 5 4 (replacing ID with the ID of your device)


4

Please see this to get help with MultiTouch in Ubuntu: https://wiki.ubuntu.com/Multitouch#Community%20Help There is a section dedicated to the Apple Magic Mouse, I also have that device and am interested in documenting any multitouch information there. The above page also includes information on testing and using demos for multitouch. If you want to see ...


3

OK folks, I went through a lot of pain to get both my Apple Keyboard and Apple Magic Trackpad working on Ubuntu 10.10. I tried several solutions, including the ones mentioned here and others that required editing files that don't exist (e.g. /etc/default/bluetooth), and while some seemed to work at first, none were stable over time. After much trial and ...


3

This works for me in 12.10 for speeding up the scrolling. sudo rmmod hid_magicmouse modprobe hid_magicmouse scroll-speed=55 scroll-acceleration=1 You can play around with the speed. The min is 0 and the max is 63 (default is 32 I believe). Anything over 50 feels 'natural' to me. I used scroll-acceleration of 1; which feels like enough (when you move fast, ...


2

This mouse has the following buttons in this order: Button Left, Button Middle, Button Right, Button Wheel Up, Button Wheel Down, Button Horiz Wheel Left, Button Horiz Wheel Right. They can be manipulated with xmodmap. See "man xmodmap" for details. To disable the middle click, create a ~/.Xmodmap file with this line: pointer = 1 0 3 4 5 6 7 0 0 0 0 0 0 ...


2

At the moment only way is setup it directly in hid_magicmouse driver. For testing run: sudo rmmod hid_magicmouse # scroll-speed value from 0 (slow) to 63 (fast): sudo modprobe hid_magicmouse scroll-speed=45 scroll-acceleration=1 For permanent settings put to the /etc/modprobe.d/magicmouse.conf this: options hid_magicmouse scroll-speed=45 ...


2

I believe I did something like this to fix a similar problem http://numberformatdata.wordpress.com/2011/05/08/apple-magic-mouse-works-with-ubuntu/ More detailed explanation: http://patrickmylund.com/blog/lowering-gaming-mouse-sensitivity-in-ubuntu-9-10/ I think these directions will still work on 12.10


2

Ubuntu supports using it as a standard mouse (move the cursor and left/right clicks). As far as I know, all bluetooth adapters work out of the box. The driver updates in the next version (Maverick, 10.10) are expected to support scrolling and might support multitouch. According to this forum post someone has backported the scrolling support to Lucid, but ...


1

There is a multitouch driver developed by Chase Douglas on his ppa, take a look at this. It was developed for 10.4 though, don't know if you can use it on 10.10 but it's worth a look.


1

An user said to me before that He connects automatically his magic mouse with Blueman application.You can install it from Software Center.


1

Installed blueman and opened it. Right click on listed device and select input device. Enter pass phrase as 0000. Now it works fine.


1

Ubuntu does not have a driver or any compatibility written in yet. That is the most basic answer there is. Someone might have written a driver for the magic mouse, but I haven't seen any drivers yet. 12.04 will probably have support for it since it is a LTS, so there is hope. Also the reason it only supports basic functions is because that is all that is ...


1

The Magic Mouse works out of the box in 12.04, with right-click, middle-click, left-click, vertical scroll and horizontal scroll. As far as I can tell, more advanced functions (two-finger swipe, three-finger swipe, pinch, and zoom) don't work yet.


1

I am using one right now. I just connected it via USB bluetooth dongley thingy. (technical term) The only issue right now is that I cannot invert scrolling and scrolling is not that smooth. I am still trying to figure that out. It does work though.


1

The directions linked by Will Huang worked for me on 12.10. I just setup the following aliases in ~/.bash_aliases alias mouse-list='xinput --list-props "bluetooth mouse"' alias mouse-slow='xinput --set-prop "bluetooth mouse" "Device Accel Constant Deceleration" 1.5' http://numberformatdata.wordpress.com/2011/05/08/apple-magic-mouse-works-with-ubuntu/



Only top voted, non community-wiki answers of a minimum length are eligible