New answers tagged

0

I had this issue and it came down to my firewall. I was not letting the NTP through my firewall. I had to allow UDP/123 through the firewall so the node could sync its time.


0

You may be running into bug #1517632 where having an outdated distro-info can result in a "no matching tools" error (see comment #15 for more info). Try updating the distro-info-data package and see if you can bootstrap.


1

juju bootstrap --upload-tools This will upload a set of the right tools into your bootstrap node.


3

By default the user created when Openstack is deployed doesn't have administrative privileges. There is however an admin account created that can be used. You can access the admin credentials from within Landscape -> Openstack. You can click the 'Download OpenStack RC file for admin' to get what you need. Also, that file can be used to administer ...


0

if you install Ubuntu Server 16.04 LTS you will see the Network tab. I ran in to same issue but when I install 16.04 then I lost Cluster tab, still trying to figure it out..


0

Still have the same problem after removing: apt update Hit:1 //ppa.launchpad.net/cloud-installer/stable/ubuntu xenial InRelease Get:2 //security.ubuntu.com/ubuntu xenial-security InRelease [93.3 kB] Hit:3 //ppa.launchpad.net/juju/stable/ubuntu xenial InRelease Ign:4 //ppa.launchpad.net/maas-maintainers/stable/ubuntu xenial InRelease Err:5 ...


1

I suggest you dump it if its still running and use LXD. You should have no issues deploying this without MaaS and just running Juju with local control of your local LXD as described here. Your machine should be able to run it without sweating too much. If you require MaaS to demonstrate it (It really is pretty awesome. You should try to check out the ...


0

Since MAAS 1.7 (released in November 2014) it supports more operating systems than just Ubuntu. From the release blog post: Specifically, MAAS can now provision Windows Server 2012 RT/Hyper-V, CentOS, RHEL, SLES, and OpenSUSE. The installation is done using the same single-pass mechanism used to deploy Ubuntu, typically providing the user with a running ...


0

I had to turn on IPMI in the Network settings on the iDRAC for this to work: iDRAC -> iDRAC Settings -> Network/Security -> Network -> IPMI Settings [x]Enable IPMI Over LAN


0

In the meanwhile, if you are doing test-and-dev, would love your feedback on the Juju 2.0 beta. The latest version (b7) seems to work well with LXD and I think the public clouds, too. In 2.0 the GUI is part of the base controller, so all you have to do is: $ juju autoload-credentials $ juju bootstrap aws $ juju gui See if that works well for you.


0

The bug was confirmed and reopened. [Bug 1534643] Re: cookies file locked for too long


1

Check for DHCP lease exhaustion, in /var/log/syslog on the MAAS server.


0

Check power settings in MAAS UI for that node. In power settings, "Power ID" should be the hostname of that node. Recommission if all settings are correct/updated. Check for maas logs as well in /var/log/maas/ and post here if you still not able to figure out the issue.


0

Download the 1.9 tar.gz Uncompress it using tar -xvf FILENAME.tar.gz Move the extracted file to /usr/local/share/MAAS-1.9 by doing sudo mv /path/to/unzipped/folder /usr/local/share/MAAS-1.9 Link any executables that you need to run MAAS by doing sudo ln -s /usr/local/share/MAAS-1.9/path/to/executable /usr/local/bin/executable There maybe be dependencies ...


1

With some help, I was able to find this bug, which was what was causing the health_warn in ceph. I haven't resolved the error yet with a work around, but I'll update this answer when I do. https://bugs.launchpad.net/charms/+source/glance/+bug/1492742 Adding OSDs will resolve the warning. The nice part is, juju handles it all for you. Once the drive is ...


2

Juju does not support MAAS2 until 2.0.0 beta 7.


0

on MAAS server i had to IP forward and Masquerade and resolved the issue iptables -L -n /sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE /sbin/iptables -A FORWARD -i eth0 -o eth1 -m state --state RELATED,ESTABLISHED -j ACCEPT /sbin/iptables -A FORWARD -i eth1 -o eth0 -j ACCEPT sudo iptables-save ...Also make sure (both upper case and lower ...


2

Well, I don't think you gonna like the answer. According to https://maas.ubuntu.com/docs/changelog.html cluster controllers have been deprecated and replaced by rack controllers. Cluster tab was removed and at least at this moment configuration can only be seen/modified by using CLI: maas your-maas-profile rack-controllers read Some of configuration ...


0

Login to your MAAS server via SSH. Get API key from your administrator account (take a look to the top right corner in the web GUI) and run the following command: maas login my-mass http://localhost/MAAS Set NTP server value: maas my-maas maas set-config name=ntp_server value=your-preferred-ntp-server Get NTP server value: maas my-maas maas ...


0

You need the following firewall ports open: MAAS, its nodes and the Autopilot will need to be able to reach the internet, or at least these sites (http and https): maas.ubuntu.com cloud-images.ubuntu.com streams.canonical.com an Ubuntu archive (archive.ubuntu.com or a mirror) api.jujucharms.com manage.jujucharms.com jujucharms.com store.juju.ubuntu.com ...


2

If upload-tools works and it doesn't without, chances are you need the following firewall ports open: MAAS, its nodes and the Autopilot will need to be able to reach the internet, or at least these sites (http and https): maas.ubuntu.com cloud-images.ubuntu.com streams.canonical.com an Ubuntu archive (archive.ubuntu.com or a mirror) api.jujucharms.com ...


0

Basically you should follow http://maas.ubuntu.com/docs/install.html#maas-packages-and-repositories with a slight change: # add developement branch instead of stable sudo add-apt-repository ppa:maas/next sudo apt-get update sudo apt-get dist-upgrade If you'll be able to drop PPA source any time later with: sudo add-apt-repository -r ppa:maas/next


0

Usually when you deploy a service and don't specify a machine, juju deploys that service to a new machine enlisted in MAAS. This message appears when juju is grabbing a new node to deploy that service on. See juju deploy in commands list


0

DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS" Installed: 2.0.0~beta3 1) First problem (Node must be connected to a network): Visit the node details page for the node that is reporting "Node must be connected to a network". On that page select the subnet you want the interface to DHCP from and then select "DHCP" in the IP assignment section. 2) I am also facing ...


1

Here is the workaround from gangstaluv: sudo apt install conjure-up conjure-up openstack Original Post


0

Try $ juju destroy-environment maas --force, then bootstrap again. If it doesn't help, share maas log file (/var/log/maas/maas.log)


1

Juju's support for MAAS 2.0 (which is what you'll get in Xenial) is still in development. The bug you're seeing appears to be fixed for Juju 2.0-beta7: https://bugs.launchpad.net/juju-core/+bug/1576368


1

Turns out there isn't a stable release of MAAS for Xenial which means I need to be on the ppa:maas/next repository instead of ppa:maas/stable. The issue was brought about after stepping through the MAAS getting started guide which wanted asked me to ad the ppa:maas/stable repository. After removing it with sudo add-apt-repository --remove ppa:maas/stable ...


2

Your environments.yaml will need to define http-proxy, https-proxy, and no-proxy. See here for all configuration options https://jujucharms.com/docs/1.25/config-general


2

Not yet, you'll want to follow this bug for status of MAAS 2.0 and Juju 2.0 https://bugs.launchpad.net/juju-core/+bug/1564577 As for OpenStack on 16.04 you'll want to do: sudo apt install conjure-up conjure-up openstack


0

I presume, you're using IPMI 2.0 power type. Go to MAAS > Nodes, click on node. Scroll down to Power, click Edit button, copy IP address, user and password. Then run the following command on your MAAS server: ipmitool -I lanplus -H <ip address> -U <user> power status and debug your way from there. It might be that you are actually missing IPMI ...


0

Try powering down ALL hardware, and retrying. If it still fails, try reloading MAAS on both sides.


0

PXE images are loaded from your MAAS server, but when booted, they are using an Ubuntu archive mirror to download/update some packages. You can set up local Ubuntu archive mirror and then change MAAS > Settings > Ubuntu accordingly.


0

You can achieve that using MAAS CLI. Login to your MAAS server via SSH. Get API key from your administrator account (take a look to the top right corner in the web GUI) and run the following command: maas login my-mass http://localhost/MAAS Find ID of a subnet you need to change: maas my-mass subnets read Change it: maas my-maas subnet update ...


0

Technically all MAAS configuration is in PostgreSQL database named maasdb. You should change it via API, CLI or GUI. I wouldn't recommend to mess up with database directly.


0

IIRC on Ubuntu virbr0 with 192.168.122.1/24 is automatically created when you install qemu packages. Run: dpkg -l | grep -i qemu to see is that the case.


0

In the maas GUI..go the settings>deploy options and change the Default Ubuntu release used for commissioning and save your selection.


1

In the maas ui..go the settings>deploy options and change the Default Ubuntu release used for commissioning.



Top 50 recent answers are included