Hot answers tagged

2

By default MAAS GUI (well, Apache actually) is listening on all available interfaces (take a look at /etc/apache2/conf-enabled/maas-http.conf), so unless you have tweaked your Apache configuration otherwise in /etc/apache2/ports.conf, GUI will be accessible from your private network too. I guess that you do not actually mean GUI – you mean access of your ...


2

Not yet, you'll want to follow this bug for status of MAAS 2.0 and Juju 2.0 https://bugs.launchpad.net/juju-core/+bug/1564577 As for OpenStack on 16.04 you'll want to do: sudo apt install conjure-up conjure-up openstack


2

Well, I don't think you gonna like the answer. According to https://maas.ubuntu.com/docs/changelog.html cluster controllers have been deprecated and replaced by rack controllers. Cluster tab was removed and at least at this moment configuration can only be seen/modified by using CLI: maas your-maas-profile rack-controllers read Some of configuration ...


2

Juju does not support MAAS2 until 2.0.0 beta 7.


2

By default the user created when Openstack is deployed doesn't have administrative privileges. There is however an admin account created that can be used. You can access the admin credentials from within Landscape -> Openstack. You can click the 'Download OpenStack RC file for admin' to get what you need. Also, that file can be used to administer ...


1

Check for DHCP lease exhaustion, in /var/log/syslog on the MAAS server.


1

If upload-tools works and it doesn't without, chances are you need the following firewall ports open: MAAS, its nodes and the Autopilot will need to be able to reach the internet, or at least these sites (http and https): maas.ubuntu.com cloud-images.ubuntu.com streams.canonical.com an Ubuntu archive (archive.ubuntu.com or a mirror) api.jujucharms.com ...


1

Here is the workaround from gangstaluv: sudo apt install conjure-up conjure-up openstack Original Post


1

With some help, I was able to find this bug, which was what was causing the health_warn in ceph. I haven't resolved the error yet with a work around, but I'll update this answer when I do. https://bugs.launchpad.net/charms/+source/glance/+bug/1492742


1

Turns out there isn't a stable release of MAAS for Xenial which means I need to be on the ppa:maas/next repository instead of ppa:maas/stable. The issue was brought about after stepping through the MAAS getting started guide which wanted asked me to ad the ppa:maas/stable repository. After removing it with sudo add-apt-repository --remove ppa:maas/stable ...


1

Juju's support for MAAS 2.0 (which is what you'll get in Xenial) is still in development. The bug you're seeing appears to be fixed for Juju 2.0-beta7: https://bugs.launchpad.net/juju-core/+bug/1576368


1

Your environments.yaml will need to define http-proxy, https-proxy, and no-proxy. See here for all configuration options https://jujucharms.com/docs/1.25/config-general


1

In the maas ui..go the settings>deploy options and change the Default Ubuntu release used for commissioning.


1

I had the same issue this morning. Check under settings "Default Ubuntu release used for commissioning" I wasn't able to use 14.04 anymore. After adding Image 16.04 commissioning is working again. With best regards, Jockel


1

I suggest you dump it if its still running and use LXD. You should have no issues deploying this without MaaS and just running Juju with local control of your local LXD as described here. Your machine should be able to run it without sweating too much. If you require MaaS to demonstrate it (It really is pretty awesome. You should try to check out the ...



Only top voted, non community-wiki answers of a minimum length are eligible