Tag Info

New answers tagged

0

It sounds like you have the LANGUAGE variable set to ru:en or something in /etc/default/locale, so try to change it there to just en. The answer, which Alexej Magura wrote, also mentions ~/.pam_environment. Possibly, since you have Kubuntu, other files may be involved instead (or also).


0

Taken from help.ubuntu.com The LANGUAGE priority list The "LANGUAGE" environment variable, which is set by the GUIs more often than not on Ubuntu desktops, controls language for message and menu display for GNU compatible applications. For such applications it overrides whatever locale names are set in "LANG" and "LC_MESSAGES". Unlike "LANG" and ...


1

1) You may need to run sudo "dpkg-reconfigure" also for the application you have installed while "locale" settings have been invalid / not matching. While system locale was incorrectly setup I installed "vim". Later when system locale was fixed I saw a situation that vim was showing utf-8 characters incorretly as strange symbols while "nano" and "less" ...


2

I do have, same as you little boxes in place where symbols or letters should be,, when viewing with font viewer (ver: 3.8.0 on my xubuntu): here but I tried to give a fontmatrix a try and voila, it shows all chars from Wingdings,, So, I would say that it is only issue in programs that we use to view some fonts... I tried also to install fontforge, and ...


0

The link Rohit provides has the answer, and it's a good one (I used it myself, and I would upvote it if I had enough rep). However, in the spirit of this, and particularly in case Rohit's link goes away, I'm going to write out the answer in full. Note: this should still be considered Rohit's answer; I'm just transferring it here for posterity. One way to ...


0

Just to add that an easy way to see your files containing Greek and were saved by your friends in their Windows machines is to convert them to UTF-8 with the command: iconv -f Windows-1253 -t utf-8 input.txt > output.txt This will read input.txt as Windows-1253 and will write it into output.txt as UTF-8. output.txt will contain the correct UTF-8 ...


1

As said here in the Debian Wiki, you can edit /etc/locales.gen and add all locales (or uncomment them, I had a list of all locales but all except the one I used as comments) you wish to have support for on your system. Then, execute sudo dpkg-reconfigure locales to update the locales on your system. Now, all of the locales you added/uncommented in ...


0

I think it's the unicode-data package that matters, and it looks like Ubuntu 14.04 has version 6.3. Utopic and Vivid have version 7.0, so you may want to try to install the Utopic or Vivid version of unicode-data. Haven't tested, though. Edit: Have you tried the package fonts-opensymbol? $ dpkg -p fonts-opensymbol Package: fonts-opensymbol Priority: ...


-1

I did things in a similar way to apply the locale system wide without rebooting or having to log out. First, download the language pack: sudo apt-get install language-pack-ru-base Next, check which versions are supported: less /usr/share/i18n/SUPPORTED | grep ru_RU Now, apply the result (almost always use the UTF-8 version for just about any ...


1

Based on this page, the settings should go in .pam_environment or .profile https://help.ubuntu.com/community/EnvironmentVariables#A.2BAH4ALw.pam_environment My default .profile is sourcing .bashrc so I added these lines to my .bashrc since I already have it under source control. #Change first day of week to Monday export LC_TIME=en_GB.UTF-8 #Change to ...


0

I just found a solution for this problem! Here it is.. 1- Stop and drop your current cluster: $ sudo pg_dropcluster --stop 9.3 main 2- Create a new cluster with the correct locale: $ sudo pg_createcluster --locale pt_BR.UTF8 9.3 main 3- Confirm it worked as expected: $ sudo -u postgres psql (9.3) => show LC_COLLATE;


0

Simply install it using below commands : sudo apt-get update sudo apt-get install postgresql postgresql-contrib and then change the datastorage location : /etc/postgresql/<VERSION>/main/postgresql.conf eg : vi /etc/postgresql/8.4/main/postgresql.conf Search for "data_directory" and provide your new datapath, now save the file and restart the ...



Top 50 recent answers are included