Tag Info

Hot answers tagged

90

First run locale to list what locales you are supposed to have: $ locale LANG=C LANGUAGE= LC_CTYPE=fi_FI.UTF-8 LC_NUMERIC="C" LC_TIME="C" LC_COLLATE=fi_FI.UTF-8 LC_MONETARY="C" LC_MESSAGES=fi_FI.UTF-8 LC_PAPER="C" LC_NAME="C" LC_ADDRESS="C" LC_TELEPHONE="C" LC_MEASUREMENT="C" LC_IDENTIFICATION="C" LC_ALL= The generate the missing locale and reconfigure ...


42

Nothing suggested above worked in my case (Ubuntu Server 12.04LTS). What finally helped was putting to the file /etc/environment: LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 For some reason it was missing. The outputs for locale and other commands appeared like the variables were properly defined. In other words don't take for granted all the basic stuff is ...


42

They should disappear after issuing: sudo locale-gen en_US en_US.UTF-8 dpkg-reconfigure locales dpkg-reconfigure reconfigures packages after they have already been installed. Pass it the names of a package or packages to reconfigure. It will ask configuration questions, much like when the package was first installed.


33

I had the same problem, but found the following solution over at ubuntuforums: export LANGUAGE=en_US.UTF-8 export LANG=en_US.UTF-8 export LC_ALL=en_US.UTF-8 locale-gen en_US.UTF-8 sudo dpkg-reconfigure locales


29

Here's another solution, also from Ubuntu Forums. I think this is somewhat cleaner and more robust: it doesn't involve customising Ubuntu's locale files (only settings that you're supposed to edit). Gnome calendar applet adheres to your locale settings. In Ubuntu, you can assign locale components by editing the file /etc/default/locale. Here is ...


19

Usually this error means that you could have been changing between different languages (locales) and something has caused this to error erroneously. You could try regenerating your list of locales with sudo dpkg-reconfigure locales For me the result was: Generating locales... en_AG.UTF-8... done en_AU.UTF-8... done en_BW.UTF-8... done ...


14

What is an Ubuntu localized image? Due to space restrictions, the official Ubuntu installation CDs (also known as ISO images) that can be downloaded from ubuntu.com contain only a handful of the many languages in which Ubuntu is available. Any additional languages can then be downloaded during or after the installation. Localized images are customized ...


14

Run the command locale - it should show your current locale. Generate the locales for french: sudo locale-gen fr_FR sudo locale-gen fr_FR.UTF-8 Also, try regenerating the supported locale list by running: sudo dpkg-reconfigure locales And update/change the current default locale: sudo update-locale LANG=fr_FR.UTF-8 Update Extra steps to try: ...


13

I've managed to get things running "normally" again. After trying lots of package re-installs etc, including fully removing IBus (all to no effect), I started to think that it may be caused by a config setting which re-installing doesn't modify. I had noticed that the output from locale was rather bereft, of UTF-8 assignments, so I checked this in a ...


12

The only way to do this, would be to patch (or in some cases, un-patch) all of the code which displays sizes to the user, and recompile your own fork of Ubuntu which has all of the sizes displayed using base 8 math (which is what you are asking for, and not base 2). It is a very invasive change to make, and is not an Ubuntu specific thing, as upstream ...


12

You can set locale manually using update-locale: sudo update-locale LANG=de_DE.UTF-8 LC_MESSAGES=POSIX Read the man page for more information. Alternatively, you can manually change your system's locale entries by modifying the file /etc/default/locale. For example on a German system, to prevent system messages from being translated, you may use: ...


12

This can happen sometimes on fresh minimal/alternate installs or in other situations. The fix is pretty simple. Try these, in the following order, testing after each to see if the situation is fixed: 1. Reconfigure locales sudo dpkg-reconfigure locales if that doesn't work, 2. Reinstall locale language-pack sudo apt-get --reinstall install ...


11

The full list of key combinations is available on the local filesystem here: /usr/share/X11/locale/$LANG/Compose Everything that starts with <Multi_key> is a Compose key combination. You'll find a lot of multi-number combinations producing stuff like: 34 as ¾ (10) as ⑩ And there are some fun (nearly easter egg) things in there too, including: ...


11

You can list locales with localedef --list-archive or with locale -a Corresponding file size is given by ls -lh /usr/lib/locale/locale-archive To remove unused locales you can do sudo locale-gen --purge it_IT.UTF-8 en_US.UTF-8 && echo "Success!" where it_IT.UTF-8 and en_US.UTF-8 are the only two locales I want. The && echo ...


10

If you run the env command, you will be given the environment variables for language. LANGUAGE= LANG=en_CA.UTF-8 If you set those variables to English settings, with the export command, any command called after this will be in "English mode". export LANG=en_US.UTF-8 You can also put this also in the .bashrc or .profile file in your home directory, this ...


10

This answer will demonstrate how to fully customize a locale, optionally using an existing locale as a base. The type of locale that will be used in this answer is the i18n type; such type of locale will be implied in every mention of the word "locale" in the body of the answer. Find a guide The first thing you need to customize a locale, is get to know ...


9

bash function for terminal Here is my bash function to switch between DE and EN locales. You may extend this code with your preferred languages. To use this, put it in your ~/.bashrc (or ~/.bash_profile)- Call it with _configure_locale EN to switch to English. function _configure_locale() { # [profile] local profile=${1:-EN} case ${profile} in ...


8

I also met this problem ,as you see, your LC_ALL is empty. I did as follows and it helps: $ sudo vim /etc/environment and set the LC_ALL to something like en_US.UTF-8,mine is: LANG="en_US.UTF-8" LC_MESSAGES="C" LC_ALL="en_US.UTF-8" then reboot,and run locale ,and it should be something like: LANG=zh_CN.utf8 LC_CTYPE="en_US.UTF-8" ...


8

check which locales are supported : less /usr/share/i18n/SUPPORTED Add locale to list of generated echo ru_RU.UTF8 >> /var/lib/locales/supported.d/local Regenerate list (it will invoke locale-gen...) sudo dpkg-reconfigure locales


7

The best solution for me is to do this on a per-user basis in my own home directory. That way I don't have to edit a system-wide file. (Of course if you want this setting for all of the users on your system you are obviously forced to edit system files.) What I do is edit the file ~/.xsessionrc to contain the line "export LC_TIME=en_GB.utf8". That's it.


7

There are several environment variables available for changing language setting. You can view your current locale settings by executing the locale command. To change all locale settings, use LANG=C. The locale as used in C is English and always available without installing additional language packs. Examples: Executing a command with the default language ...


7

Should be fine. Might cause the install to take a little longer, but probably nothing serious, especially if it's just random browsing and not, for example, playing big heavy Flash games at a site like Kongregate (assuming you even have Flash available in the installer environment, which I don't know the answer to off the top of my head).


7

It is possible for KDE apps. Just change it in your system settings. First, install systemsettings clicking this then, run it Then, choose Locale ▸ Other ▸ Byte Size Units select the one you want.


7

You probably need to install unzip sudo apt-get install zip unzip as far as your error message, yes you should probably file a bug report on that one. "How do I report a bug?"


6

You probably want to check the value of the LANG environment variable: user@host:~$ echo $LANG en_GB.UTF-8 You can then write a short script which picks an appropriate file based on the value of this: #!/bin/bash SHORTLANG=${LANG:0:2} zenity --text-info --filename greeting_${SHORTLANG}.txt Which takes the first two characters of $LANG and displays the ...


6

I've found locale-gen to be your friend. as in (adding hebrew utf8 for example): root@world:~# locale-gen he_IL.UTF-8 you can even rehash it like so: root@world:~# dpkg-reconfigure locales and check that you did good: root@world:~# locale -a I found this solution way simpler than adding stuff to text files, even though it is what it does.


5

You need to add the Persian Keyboard layout. Click the + sign to add Choose the correct layout that suites you, and then click on Add Click on Options to choose the key combination that you want, in your case Alt+Shift


5

Winecfg does not have any option to change the language. The normal way is the method you posted. You will need to change the executable that you start and add the locale in front of it just like you do from command line. Besides that ... it is old but winelocale might still work. WineLocale clones the functionality of Microsoft AppLocale in Wine. ...


4

Open a terminal Ctrl+Alt+T and type: LANG=en_US.UTF-8 bash or: LC_ALL=C bash Now the terminal output is in english language. You can check it with locale. It is possible to make a command to do that with a permanent alias. Open the .bashrc file with your preferred editor and put the following code in there: alias basheng='LANG=en_US.UTF-8 bash' or: ...



Only top voted, non community-wiki answers of a minimum length are eligible