Hot answers tagged

23

This works for me on 13.04, both mute and unmute: amixer -D pulse set Master 1+ toggle It specifies pulse audio to ensure unmute, unmutes everything.


13

Install the xdotool package, and try issuing xdotool key XF86AudioLowerVolume and xdotool key XF86AudioRaiseVolume.


12

I'm using this script as a workaround: #!/bin/bash CURRENT_STATE=`amixer get Master | egrep 'Playback.*?\[o' | egrep -o '\[o.+\]'` if [[ $CURRENT_STATE == '[on]' ]]; then amixer set Master mute else amixer set Master unmute amixer set Front unmute amixer set Headphone unmute fi I did a diff of amixer scontents before calling amixer set ...


5

I just now solved it. lircd -n --device=name='IR*' -H devinput. That's it. Works.


5

I couldn't get sound muting to toggle correctly. Whether I used CLI and type in Amixer sset Master toggle or hit the HP pavillion media toggle key, I get the same result: If sound is on and working, it will automatically turn off Master channel AND PCM channel. Then when I hit the toggle again (cli or key) it ALWAYS turns on Master, but leaves PCM muted. For ...


5

It seems it is a problem of mapping, or something. Just run sudo dpkg-reconfigure lirc, and in the first screen (Remote control configuration:), select Windows Media Center Transceivers/Remotes (all). In the second screen (IR transmitter, if present:), you can select None. Now, irw can output text: $ sudo irw 000000037ff07be1 00 KEY_UP mceusb ...


4

You could bind a shortcut to this script I've found in the Arch forums (needs the package 'libnotify-bin'): #!/bin/sh usage="usage: $0 -c {up|down|mute} [-i increment] [-m mixer]" command= increment=5% mixer=Master while getopts i:m:h o do case "$o" in i) increment=$OPTARG;; m) mixer=$OPTARG;; h) echo "$usage"; exit 0;; ?) echo "$usage"; ...


4

Here's what worked on my HP-2140us: Install the "Infrared Remote Control" app from the software center If you haven't installed lirc before, you'll get a config screen; if the install completes without one, open a terminal and type sudo dpkg-reconfigure lirc Select ENE KB3926 as your receiver and None as your transmitter. Open Preferences > Infrafed Remote ...


3

Some of the shell code from that source doesn't do what it claims to do; mainly the type that goes: if [ -n $(pgrep -f vlc) ]; then (vlc &); fi This runs vlc & in two cases. If there are no processes matching "vlc", and if there are exactly one process matching "vlc". If there are more than one process matching "vlc", vlc & will not be run. So ...


3

Quite likely your remote is used as a keyboard. I don't know any real useful docs for how to configure it but /lib/udev/rules.d/95-keymap.rules and the files in /lib/udev/keymaps/ may give you some idea about how to do it.


3

OK, for me I found that editing the .mythtv/lircrc file was the answer. I had to append a "key_" in front of all the button = keyname lines. e.g button = Up becomes button = key_Up hope that helps.


2

The program you need is called lirc supports the remote control, looking into it it seems the driver is certainly supported but your dell model doesn't yet have a configuration file to map the buttons to actions. In order to get this working we need a sys-admin or programmer to take a look at your computer while your pressing the keys to figure it out and ...


2

OK so your lirc configuration basically claims the mouse as a remote control input which means xinput can't then use it as a normal mouse. Without lirc claiming the hardware xinput would pick up the mouse and you'd see it when running xinput list from the command line under Virtual core pointer So since your configuration binds it up what you need to do is ...


2

You can create /etc/serial.conf and put lines like /dev/ttyS0 uart none into it. /etc/init.d/etc-setserial reads this file. The setserial binary is part of the setserial package, which is a dependency of the lirc package, so it should be automatically installed.


2

Per this thread: http://ubuntuforums.org/showthread.php?p=10709651 You need to add this line to /etc/rc.local: echo lirc > /sys/class/rc/rc0/protocols You also might need to add sleep 10 right above that line. Try it without it first and then add it if you need it. I needed it but others didn't.


2

As the root user, you could define something like this in the ~/.lircrc file (with "POWER" replaced with whatever is correct for your remote): begin prog = rawcontrol button = POWER config = power end Then add something like this to /etc/rc.local or another init script: ircat rawcontrol | (while read line do if [ "x$line" = "xpower" ]; then ...


2

Try this script fragment...it works https://wiki.archlinux.org/index.php/PulseAudio#volume_control


2

If I'm not mistaken, it's a bug that causes other mixer channels to mute and unmute. To mute, try amixer set Master 0; To unmute try amixer set Master 1%+; amixer set Master 7dB+;


2

The RC6 remotes all use Infrared (ir), not Bluetooth. The only reliable source (i.e. won't disappear or be out of stock all of a sudden) to buy those receivers that I know of is Ebay. Ironically, it's almost cheaper to buy a remote + receiver bundle than to buy the receiver alone. The receiver alone (with a Lenovo branding) currently costs $14-$20, a ...


2

As I workaround I installed xautomation and modified ~/.lircrc to use xte instead of irxevent wherever it referred to CurrentWindow. The mentioned passage now looks like this: begin prog = irexec button = KEY_OK config = xte 'key Return' end Now everything's working fine again.


2

This is the correct version of the Option line: Option "Ignore" "True"


2

Like Florian said, Ubuntu is seeing the remote as a keyboard. You can add the below to /etc/X11/xorg.conf to stop X from picking it up: Section "InputClass" Identifier "Remote" MatchProduct "<your transceiver input name>" Options "Ignored" "True" EndSection (If there is no xorg.conf, just create it (sudo gedit /etc/X11/xorg.conf)) To get ...


2

Remote's Play button is consumed by media-keys plugin for gnome-settings-daemon. To disable it and allow MythTV receiving the event, do: $ gsettings set org.gnome.settings-daemon.plugins.media-keys active false Also you will want to disable/uninstall xfce4-volumed to prevent it from trapping XF86AudioLowerVolume, XF86AudioRaiseVolume and XF86AudioMute. ...


2

I have the same remote. Here is how I got mine to work, at least for testing purposes: ir-keytable -c ir-keytable -w /lib/udev/rc_keymaps/imon_mce ir-keytable -t Still need to get it to start automatically at boot, but getting closer...


2

Turns out I had a conflicting program: inputlirc After removing it, reconfiguring lirc, rebooting, reconfiguring ir-keytables, everything seemed to be working. $ sudo apt-get purge inputlirc $ sudo dpkg-reconfigure lirc $ sudo reboot now $ sudo ir-keytables -c -w /etc/rc_keymaps/rc6_mce irw shows no problems. $ sudo irw 000000008001006c 00 KEY_DOWN ...


1

I've just been down a similar path of discovering the new in-kernel lirc, for me the ah ha moment was when I realized an ir remote is now just another keyboard. As an alternative to showkey/evtest you can run sudo ir-keytable -t to detect remote button presses. Though I don't think it offers too much new information. To adjust the mapping of remote ...


1

Personally, with my Nova-T usb tv stick and remote I install lirc, sudo apt-get install lirc and choose my usb tv stick and when choosing the remote it doesn't really show me it listed, so I just choose anything. I stop the lirc service, sudo service lirc stop and run cat /proc/bus/input/devices which gives me I: Bus=0003 Vendor=2040 Product=7070 ...


1

Tnx for reply. I loaded the module with modprobe dvb_usb_rtl2832u rc_mode=2 I have IR-receiver on input4. Started lircd with lircd -n --device=name='IR*' -H devinput but no luck with the remote. I also followed instructions on http://www.pclinuxos.com/forum/index.php?topic=89669.5;wap2 cat /proc/bus/input/devices | grep -n10 c803 gives IR-receiver on ...


1

I had a similar problem with a windows media center remote. X was picking up the remote as well as mythtv. If you are having the same problem, you have two choices: 1) Tell X to ignore your remote control. 2) Remove the arrow keys from the lirc mapping for mythtv so that X controls the arrow keys and lirc controls the rest. Unfortunately, I've forgotten ...


1

If you want to replace amixer in .lircrc for your remotecontrol working with lirc, you can try following lines. Be sure to have xmacro installed. Volume-control now works again. begin prog = irexec button = KEY_VOLUMEUP repeat = 1 delay = 2 config = echo KeyStrPress XF86AudioRaiseVolume KeyStrRelease ...



Only top voted, non community-wiki answers of a minimum length are eligible