Tag Info

New answers tagged

1

Today after next set of kernel updates the issue has gone. Now Ubuntu 15.04 boots normally. sserg@SSERG-U38DT:~$ inxi -F System: Host: SSERG-U38DT Kernel: 3.19.0-18-generic x86_64 (64 bit) Desktop: Unity 7.3.2 Distro: Ubuntu 15.04 vivid


1

Turns out that this was a simple matter of giving the wrong permissions to my icon set. There was nothing wrong with my theme, it just couldn't be read. Odds are, if you're modifying an existing icon theme, it has all the required icons. Permissions just need to be set as 755 for directories, and 644 for files. Lesson from this: Always check permissions!!


-1

There are many issues with both NVIDIA and ATI/AMD proprietary drivers for kernel versions 3.19 and 4.0. There are known fixes for NVIDIA drivers, but fixing these issues only allows you to compile the drivers and still introduces issues with GDM and Gnome. For me, I had to use lightDM and LXDE to use my NVIDIA drivers. I could have opted into using the ...


0

There was the same error for me on Ubuntu 14.04.02 LTS. I have opened log file /var/log/lightdm/lightdm.log and see message like ...not enough disk space for .Xauthroity.... Then I have found that there is really zero space on disk. So I have removed some files and bug disappeared.


1

This could also be because of a special combination of settings: Encrypted /home/$USER $USER in nopasswdlogin group lightdm will try to log you in, but can't access any files so you get the described symptoms. To fix this, remove $USER from the group: sudo gpasswd -d $USER nopasswdlogin


0

Open up lightdm.conf: gksudo gedit /etc/lightdm/lightdm.conf You must have the following settings under [SeatDefaults]: user-session=ubuntu greeter-session=unity-greeter Save and reboot. UPDATE Open your Terminal, Enter below command sudo apt-get purge lightdm-gtk-greeter* sudo apt-get purge lightdm sudo add-apt-repository --remove ...


0

Through extensive trial and error, it appears that the culprit was auth required pam_tally.so onerr=fail deny=3 unlock_time=3600 magic_root Removing deny=3 unlock_time=3600 and instead doing sudo faillog -l 3600 -m 3 appears to have done the trick. I would still like to understand why, if anyone can offer an explanation. I chose those options ...


0

Thanks to A.B. I found that the CSS settings are imported into gtk.css in the GTK theme you use. The CSS file itself is named lightdm-gtk-greeter.css and should be in /usr/share/themes/(theme)/apps/


0

After updating 14.04 to 14.10 and then 15.04 I got caught in the login loop. After much poking around at problems with nVidia drivers, they were not much help. I have an HP Pavillion with AMD CPU & Drivers. Here were the simple steps that worked: ctrl-alt-F1 ; <-- to get a console prompt (non-gui) dkms status ; <-- ...


2

First run this command for a graphical environment sudo systemctl set-default graphical.target Because you have used sudo systemctl set-default multi-user.target before. Then repair the entries in /etc/default/grub This statement is completely wrong: GRUB_DEFAULT="quiet splash" Open the configuration: sudo nano /etc/default/grub and replace the ...


0

Once you're sucessfully logged on to Ubuntu. Open a Terminal (Ctrl+Alt+T) followed by:- sudo gedit /boot/grub/grub.cfg Edit the line that looks like linux /boot/vmlinuz-x.x.x-xx-generic root=xxx\xyz ro xxx-options to linux /boot/vmlinuz-x.x.x-xx-generic root=xxx\xyz rw xxx-options This file is generated from the files present in /etc/grub.d and ...


3

It is not a good idea to install Nvidia drivers from .run files, downloaded from Nvidia site. This way they will not be registered properly by dkms and you will get black screen after first kernel update. Good way to install the driver is to run: sudo apt-get install nvidia-current Or go to System Settings -> Software & Updates -> Additional Drivers ...


0

Sorry for the short answer… Login into your terminal and install lightdm again: sudo apt-get install lightdm or maybe with --reinstall sudo apt-get install --reinstall lightdm For the completeness sudo dpkg-reconfigure lightdm and check the entry in /etc/X11/default-display-manager, it should be /usr/sbin/lightdm Restart or start lightdm with ...


0

You can create new user as suggested by ColonelTrogdor or there are other ways to solve this problem. First login into tty by pressing CTRL+ALT+1 Note: Press ALT+7 to came out from tty Solution 1: Reset the Unity and Compiz Download Unity Reset tool from here. Note: It should work with Ubuntu 14.04, 13.10 and 13.04. Reset Unity using the following ...


-1

to avoid the login loop you can install and use different login manager or use new clean user account in your old login manager,if you want create new clean user account,install another login manager first (example:gdm) via command line if you dont have any,then change your login manager type "sudo dpkg-reconfigure lightdm" then change the login manager to ...


0

Easily you can change the User ID of the user you want to hide. The system tray only shows system users which are having USer ID =>1000 So to hide a user just give him a UID < 1000 You can change the UID using the command sudo usermod -u UID username Be carfull the numbers from 0 to 99 is reserved for system accounts, so don't use them. Moreover ...


1

To hide/invisible an administrator account in login page: Note: replace AdminAccount with the actual administrator account e.g. admin01 (Ctrl + Alt + T) login in sudoer/admin account to used this command. sudo usermod -u 999 AdminAccount


1

cat /etc/lightdm/lightdm.conf.d/30-seats.conf [LightDM]<br> seats=Seat:0, Seat:1 [Seat:0] user-session=ubuntu autologin-user= [Seat:1] user-session=ubuntu autologin-user=


0

I had the same problem on Ubuntu 14. I used Ctrl+Alt+f2, then logged in. When I inspected the file "/etc/profile", I found that I had inserted an illegal character while setting up the path. After correcting that, I logged off and restarted and my GDM was working perfectly. I would advise you to inspect the file for illegal characters.


0

I'm not sure exactly what I did to get lightdm to successfully start a session for me except maybe allowing anyone (not just consoles) to connect to the xserver. The gnome-shell desktop still doesn't appear when I login through lightdm while it does when using startx.


0

turns out the permissions fault came from my ~/.config/ folder, the location of my monitors.xml file. By default it was 700, once I changed it to 755, the symbolic link (and my correct login screen rotation) worked.


1

This is a bug in Unity. Please mark yourself as affected here: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1451613


1

Install Ubuntu Tweak. It still works although it hasn't been updated for a while. You can download the deb package from here: https://launchpad.net/ubuntu-tweak Start Ubuntu Tweak, go to Tweaks > Startup > Login Settings. There you should be able to "Unlock" Root privileges and select some LDM Preferences like "Draw Grid".


0

According to the (German) Wiki of ubuntuusers.de, starting from Ubuntu 12.04 you need to use the dconf-editor GUI tool. You start it just as you did with gsettings set before: Giv the 'lightdm' user account access to your GUI (xhost), switch to that user account (su) and start dconf-editor xhost +SI:localuser:lightdm sudo su lightdm -s /bin/bash ...


0

Once I did some tweaking, I got it to work. Tweaks included: editing /etc/issue to include line breaks adding /usr/share/lightdm/lightdm.conf.d/50-show-dialog.conf with contents [SeatDefaults] session-setup-script=/usr/bin/mysess.sh editing my shell script to: #!/bin/bash if /usr/bin/zenity --question --text="`cat ...


0

Reading the unity-gtk-module.log I have seen that there was a problem with initctl. Due to a "recover" manual I had it renamed, and it couldn't find it. Renamed again and now it is working again :)


-1

I'd liked to help ya, but I would also like to know a few things about your set up. Are you running Ubuntu solo, dual boot, or through VMWare of sometype (VirtualBox)? I say this because it could be beyond the app software and the kernel depending on your model l-top and host OS. Also with that update and upgrade, run a dist-upgrade to upgrade the kernel. ...


1

Now i think there was problem in compiz after looking way around i found crash report of compiz in /var/crash just after crashing and the crash report was as in the screenshot and i found that it wasn't send because there was UnreportableReason: You have some obsolete package versions installed. Please upgrade the following packages and check if the ...


1

Based on the bug report, reported March 21, 2015 Ubuntu 15.04 Xserver does not start or freezes with systemd + lightdm. More detail regarding the impact of this change and how to switch from systemd to upstart and back again is available on this page. To check to see if your system is using systemd vs. upstart you can test by issuing the command sudo ...


0

I had similar issues after trying to add some startup scripts (black screen with cursor and a half-active search box). In my case deleting .cache directory from home dir unlocked my system. At this point I think that my problems originate from sudo not respecting -S switch when used in script. No idea why, as in Konsole it works OK...


0

tl;dr: My specific problem was that at one point I had put exec /bin/zsh in ~/.bashrc (no memory of why I did this). strace was not able to track this down but fatrace was since it could trace accesses for the whole system, not just a process subtree. Probably boring details: I was pretty sure that my issue had to do with something in my primary users home ...


0

try the following command: sudo dpkg-reconfigure lighdm a screen will appear asking you to choose between display managers (if you have more than one).


0

Why are you using xorg.conf to set the resolution and not Settings -> Display? To get it working again press ctrl+alt+F1 to open a tty, then login. Remove the xorg.conf file you created and reboot. If the resolution you want is missing use: cvt 1920 1080 60 to create a new modeline. xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 ...


1

Read Only is the state that recovery mode boots into intentionally. What you need to do is remount the root partition with read-write privileges. This will remount the drive as readable and writable. Execute this in the recovery console: mount -rw -o remount /


0

My ordeal has been with adding or removing *.desktop files on my machine, and getting a black screen with only a cursor and the "search bar" from alt-F2. The first time, I tried to manually add a *.desktop file to /.local/share/application for Sublime Text, and that messed up my machine. The second time I added a launcher for Android Studio using the ...


0

I had this problems after upgrading from 14.04. I restarted the system and went in to a terminal and tested the login at the terminal and determined my logins worked. I logged in as root and did apt-get update and saw an error that stated that I needed to run dpkg --configure -a. I ran the command and let it reconfigure the system. After it was finished( ...


0

In my case the problem was caused by wrong permissions on my home directory. 1: Boot from a live media (or different linux distro installed on the same system) and open a terminal with Ctrl-Alt-T 2: Make a temporary mount point and Mount the partition that contains your /home (in my case it was /dev/sda6) sudo mkdir /mnt/sda6 sudo mount /dev/sda6 ...


-1

Press CTRL+ALT+F1 and log in there and run: sudo chown -R $USER:$USER $HOME $USER is your username Ex - sudo chown -R singh:singh /home/ Then press CTRL+ALT+F7 and try to log in


1

I am also having problems with lightdm refusing to show up. In my case, I have both "plain" ubuntu and kubuntu-desktop, so I chose sddm as login screen (sudo dpkg-reconfigure lightdm allowed me to select which login manager I wanted). Maybe installing sddm (if you don't want all of Kubuntu desktop) might be a workaround (I don't know detailed steps on how to ...


1

This is a known bug with lightdm. There are ways to possibly fix it, along with ways of working around the problem. Make sure your computer is connected to the internet and enter a TTY by pressing Ctrl + ALT + F2. Log in here, then try the following: Purge and reinstall lightdm: Run sudo apt-get remove --purge lightdm. Once that's done, run sudo apt-get ...


1

I had a very similar issue where I could log in on the terminal but not on the desktop, my wallpaper from the profile was loaded during login, but after a few seconds it jumped back to the login screen. I checked all file permissions as suggested, they were fine. I tried without a separate home partition and was able to log in to the desktop. After that I ...


0

I switched from fglrx-updates to xserver-xorg-video-ati and it solved both the unlockable lock screen problem and the blank consoles problem.


1

With Xorg 1.17 and later, -nolisten tcp is the default, and you need to explicitly state -listen tcp to enable tcp connections.


1

You may want to cleanup your ecryptfs setup and startover. You can do this by removing the /home/.ecryptfs/username folder.


-1

You can log to the machine using another machine, for example like this: ssh login@machine download drivers from here: wget http://us.download.nvidia.com/XFree86/Linux-x86_64/346.59/NVIDIA-Linux-x86_64-346.59.run install them and configure system to use them.



Top 50 recent answers are included