Hot answers tagged

4

I got a hint here: http://askubuntu.com/a/518825/34298 The script you want to call when the lid opens or closes has to be stored in /etc/acpi/lid.sh. Then there has to be created the correct file /etc/acpi/events/lm_lid with the content as follows: event=button/lid.* action=/etc/acpi/lid.sh Reboot your system to let this take effect. Or maybe it is ...


3

To know if the button is indeed working, go to a terminal and type while [ 1 ]; do cat /proc/acpi/button/lid/LID/state; sleep 1; done you should get one state: open every second. Now close the lid and wait a bit. Open it again. Some lines should now be state: closed with that, you can tell that the hardware is working, and the signal is ...


3

You're on the right track with logind.conf, but you only need to change this line from the default configuration: HandleLidSwitch=ignore (i.e. you don't need LidSwitchIgnoreInhibited=no). In addition, you need to configure xfce4-power-manager to handle the lid switch. I found that the reliable way was to Quit it from the power manager icon menu before ...


2

For my script (lid.sh) to be called in /etc/acpi/, I had to create the correct file in /etc/acpi/events/. The file has to be called lm_lid and the content is as follows: event=button/lid.* action=/etc/acpi/lid.sh Reboot your system to let this take effect. Note: I moved back to Linux Mint (now 17) before I figured this all out, and this, with the ...


2

you must install Catalyst drivers from AMD. Follow this guide: What is the correct way to install ATI Catalyst Video Drivers (fglrx)? I have installed Catalyst 12.10 Drivers and finally, after 6 month about non return from sleep when suspend, now my Samsung 305u can wake up. Good luck.


2

This exact same thing is happening to me on Ubuntu 12.10, every time I close my laptop. One work around is to apt-get install compizconfig-settings-manager, run ccsm from the command line, enable Window Management -> Put and configure a keyboard shortcut for put_next_output_key. That way as soon as you open your laptop you can move the window back to ...


2

SOLUTION It seems that the info on the ubuntu community is not complete. You need to make one more step in order to work. According to this, you additionally need to create /etc/acpi/events/lm_lid and put: event=button/lid.* action=/etc/acpi/lid.sh Now it works fine for me. I have updated the Ubuntu guide so you can safely follow the guide here


2

Go to the system settings and then click on Power. On that menu, you can configure the closed lid behavior.


1

You need to install Nvidia proprietary drivers. Run in terminal: sudo apt-get install nvidia-352 nvidia-prime and reboot after the driver is installed.


1

I had a similar problem in Linux Mint 17.3. It went away when I installed the nvidia video driver in the place of the default open source one. (Administration->Driver Manager->Select nvidia recommended driver)


1

Go to System Setting -> Brightness and Lock and turn Lock off, turn the time delay of lock to Never just to be sure.


1

This is a known issue in 11.10. I have resolved it by upgrading kernel to 3.2, but I would not recommend it since the upgrade might cause all sorts of problems. https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/766490


1

I have a doubt: if you explicitly click in the 'suspend' option in the system button, the laptop suspends correctly? If the laptop suspends correctly, then this is just a configuration problem... In this case, you can install the Gnome Tweak Tool: sudo apt-get install gnome-tweak-tool After running the tweak tool, you should select the "Shell" option and ...


1

It turned out to be VirtualBox. I uninstalled VirtualBox & it started suspending correctly again. Anyway, thanks!



Only top voted, non community-wiki answers of a minimum length are eligible