Tag Info

New answers tagged

0

Install libpcl1, it's in the Ubuntu repositories: sudo apt-get install libpcl1 Or as @Fabby said, compile your own version: sudo apt-get install git cd git clone git@github.com:PointCloudLibrary/pcl.git cd pcl mkdir build cd build cmake .. Note the missing development libraries, eg: -- checking for module 'eigen3' -- package 'eigen3' not found -- ...


0

Because for your version of Ubuntu this library does not exist in this PPA. To solve this, you need to build from source instead.


0

verify your architecture if it's 64 bits, you don't install all dependence. and too verify PPAs install on your Ubuntu. How to do OK: sudo aptitude install libgl1-mesa-glx:i386


1

The error you see indicates that one of the programs "shared libraries" (which provide functions that your program needs) is not available. In this case, the actual shared library that is missing is called libboost_system.so. If we search the apt repositories for something with a similar name, we get the following packages: $ apt-cache search libboost ...


2

first of all ,I don't know if this question should be asked here as it is a c language related question but since it is under ubuntu I will respond : the GCC compiler will look for headers depending on how you declare the header so there is two possibilities first : Declaring the header using angled brackets <> exemple : #include <math.h> in ...


0

As per the updated answer on Dependency is not satisfiable: libtiff4 when trying to install Lightworks on Ubuntu 14.04 - you can install libtiff4 by hand, and then libpoppler-dev simply installs with apt-get. Hopefully libtiff5 still works as mentioned there...


0

Create a symbolic link If you have the file /usr/lib/x86_64-linux-gnu/libboost_system.so.1.55.0 64-bit sudo ln -s /usr/lib/x86_64-linux-gnu/libboost_system.so.1.55.0 /usr/lib/x86_64-linux-gnu/libboost_system.so.1.46.1 32-bit sudo ln -s /usr/lib/i386-linux-gnu/libboost_system.so.1.55.0 /usr/lib/i386-linux-gnu/libboost_system.so.1.46.1 If you have the ...


0

Ocelot is looking for an older version of boost. You'll either have to create a ton of symlinks to get Ocelot to think it's the right version or downgrade boost. Here's a link to getting a specific version of boost .


0

Try: sudo apt-get install libgl1-mesa-glx-lts-utopic:i386


1

I had the same issue, every time I tried to run steam it would tell me the libgl.so.1 error. All I did was type this into terminal and open steam back up and it worked. sudo apt-get install libgl1-mesa-glx-lts-utopic:i386 If this works for you, please upvote. Also, if you experience more issues, let me know in the replies. I will be happy to help


0

To Nathan's option, I would add patchelf which allows to change the RPATH of an executable. I personally prefer patching RPATH over defining LD_LIBRARY_PATH and the like, since Ubuntu has issue defining these in profile and also as if not defining this in profile, this save the need of a wrapper script. To define an executable RPATH which is relative to the ...


0

One can preload libraries using the "LD_PRELOAD" environment variable. Simply specify the full path of the so files like this: export LD_PRELOAD = "/path/to/so1.so /path/to/so2.so"


0

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia Your solution is in the webpage above. Uninstall all current nvidia drivers you have and install those ones.


0

Anyway let me sum up the story.. $ ls /usr/lib/x86_64-linux-gnu | grep -i libegl libEGL.so libEGL.so.1 libEGL.so.346.59 ls -l /usr/lib/x86_64-linux-gnu/libEGL.so lrwxrwxrwx 1 root root 18 mar 30 17:10 /usr/lib/x86_64-linux-gnu/libEGL.so -> mesa-egl/libEGL.so and lrwxrwxrwx 1 root root 15 mar 30 17:10 /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so ...



Top 50 recent answers are included