Tag Info

New answers tagged

0

I am posting an answer, because I have a work-around, or I hit upon the answer. I would venture to say that the creation of the .desktop files and the modification to the gsettings com.Canonical.Unity.Launcher favorites value had to be separated by some fixed interval of time. In my case, for my installation I needed to run npm rebuild for my delivered ...


1

I think that running xprop and selecting this blank window will help you to know which process creates it.


0

Is the path correct when you scroll over the library on the right side from nautilus? fix those by dragging the correct library to the right hand pane and then remove the incorrect one from there.


0

This is so simple... Go to Android Studio=>Tools=>Create desktop Entry.. it will work


0

menulibre doesn't supports *.desktop files. Therefore nothing is displayed in Unity. Try arronax sudo apt-add-ppa ppa:diesch/testing sudo apt-get update sudo apt-get install arronax


1

First an explanation, thank you @kos By using an Exec= line such as Exec=/usr/local/netbeans-8.0/bin/netbeans netbeans is executed in sh already, because the Exec= lines in desktop files are executed as commands in sh, not in bash or else. So Exec=/bin/sh -c "/usr/local/netbeans-8.0/bin/netbeans" spawns an excessive sh instance. Just ...


1

I figured out the issue by looking through syslog. I probably should have done that to begin with, but I'm still a Linux noob. Sorry if I wasted anyone's time! Apparently, Netbeans was failing to pick up a tool agent. Specifically, the instrumentation tool Jayatanaag.jar. For some reason, this didn't cause a fail state when starting directly from a ...


1

try without /bin/sh Exec=/usr/local/netbeans-8.0/bin/netbeans


0

Maybe too late... Since GNOME 3.8 there is an explicit option to disable animations, you can change with gconf editor, or simply issue this from terminal: gsettings set org.gnome.desktop.interface enable-animations false Also if this is not enough for you or you PC, you can enhace the responsiveness of UI by reducing the animation time: sudo nano ...


0

You can do that really simply over the GUI with a program called alacratz. Here's a pretty simple how-to. Bottom chapter is what your looking for http://develop.alpdesigns.ch/pages/linux/add_exe_program_to_linux.html


0

You can do that really easily with the third-party program alacarte. I wrote a noobs guide on how to do it here: http://develop.alpdesigns.ch/pages/linux/add_exe_program_to_linux.html


0

I have no idea what you've done or how you have installed firefox as there is no standard desktop file. Maybe you have removed Firefox earlier. Therefore re-install firefox sudo apt-get install --reinstall firefox Then, if still not the correct icon appears, remove the starter and add the starter again.


1

Install Unity Tweak Tool to customize the behavior of Unity Launcher. Open a terminal and execute : sudo apt-get install unity-tweak-tool Open the tool, click on Launcher Tab under category Unity and tweak.


0

I have the same problem. It seems to be a known Unity bug related to 'Window Spread' setting: https://bugs.launchpad.net/unity/+bug/1462841?comments=all The workaround is to disable 'Windows Spread' (thus losing that feature until the bug is fixed). Lame, but at the moment I'm not aware of anything better.


4

Complete Solution: The following steps will help you achieve the desired output: Create a new script file (replace create_dir.sh with your desired script name): vim ~/create_dir.sh The script will be created in the user’s home directory Add some commands that only a root or sudo user can execute like creating a folder at the root directory level: mkdir ...


0

In the ~/.local/share/applications/google-chrome-stable.desktop, I replaced its Exec= line with that of the /usr/share/applications/google-chrome.desktop. I had this line: Exec=opt/google/chrome and I replaced it with: Exec=/usr/bin/google-chrome-stable %U


0

Confirmed workaround is: Put the VB Guest in either windowed or full screen mode Lock the Ubuntu screen - VB Host - via the menu Unlock Put the VB Guest in full screen mode or go to windowed mode then back to full screen mode. The launcher and top menu row then disappeared / behaved as wanted and expected.


0

The best way I know of doing this is, open Android Studio then under Tools click on "Create Desktop Entry". This will list android studio in all programs list, from there you can add the application to quick launch.


0

found same problem after update to virtualbox 5.0.2 in same situation above except for the guest os that is ubuntu 14.04 too. My temporary workaround is to work in gnome-flashback session with metacity , while using gnome-flashback with compiz gives the problem exactly like when i am in unity.


1

Answer taken from comments Chaos I would write KeeperDesktop.jar in an absolute path: /path/to/KeeperDesktop.jar DaveyT SOLVED - chaos- your suggestion was correct, I changed the path to an absolute one and it works …


1

I had exactly the same problem with sublimeT3. First on a terminal I ran the next command: $echo $LOCAL And the output was an empty line. Next I ran: $locale An this was the output: LANG= LANGUAGE=en_US LC_CTYPE=POSIX LC_NUMERIC=POSIX LC_TIME=POSIX LC_COLLATE=POSIX LC_MONETARY=POSIX LC_MESSAGES=POSIX LC_PAPER=POSIX LC_NAME=POSIX LC_ADDRESS=POSIX ...


1

Nautilus is represented by multiple .desktop files in /usr/share/applications. Most likely, your current "new" icon is the nautilus-folder-handler.desktop -file. The one you need is nautilus.desktop. What to do Just navigate to the directory /usr/share/applications Look for the file nautilus.desktop Drag the file to the launcher Log out and back in No ...


0

alright, I sorted it out. for correct opening MS Word docs including files with spaces in name, we need to do 2 things: create a sh wrapper that will start WINWORD app with correct parameters: #!/bin/sh vmrun -T player -gu alx -gp 123 runProgramInGuest ./vmware/office/windows-7.vmx -activeWindow -interactive "c:\Program Files (x86)\Microsoft ...


0

I cannot vouch for the safety (in terms of Tor's purposes and goals) of the next solution, but this is what I did in my own case. I suppose that you already have tor browser registered as an app in your system, but if you don't than run this command from the directory containing the unpacked stuff, it must be something like: ~/tor-browser_en-US And run ...


0

Maybe, if you just change the sensitivity, the dock could show up more easily. The higher the sensitivity the politer the touch to left side of the screen is required.


0

No, The position of the launcher is fixed (left) but and I wished to change the position too, so rather than changing I set it to auto-hide which is effectively good option (without using any external apps). The launcher when hovered overlaps the opened application rather than shrinking the size. So thats equally good. :)


1

I have the same problem. And, finally, I found this https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-346/+bug/1440012 So, I think maybe you have installed the nvidia-346 driver? If you did install nvidia-346 driver, you can downgrade to nvidia-331 or upgrade to nvidia349 to avoid this issue. fearlessly install driver 349 : sudo ...


0

The easiest way to manage profiles in firefox is installing the multifox addon. URL: https://addons.mozilla.org/en-US/firefox/addon/multifox/ It works like profiles in Chrome but more smooth and better. You can open up different tabs of the same site with different logged in users. See attached:


7

How to set up different Firefox profiles for the same Ubuntu user and the same Firefox installation Excerpt of the command-line options from man firefox: -ProfileManager Start the profilemanager. Use this to choose the profile you would like to run firefox with. You will need to also use -no-remote if there is already a running firefox instance. ...


1

I will add this in case you want 2 firefoxes. The end result will be a normal firefox and one installed in /opt/. Both can be started at the same time and are totally separated from each other. Download the source file for a version of firefox. Possibly from here. Go to a terminal and execute (I assume you have 1(!) downloaded tar file; change the "*" to ...


0

You can open a new private window in Firefox (much like Chrome's incognito window) and use it simultaneously with normal browser with different accounts.


0

Same as above, and if interested in learning why one should/could have several profiles, the following link has some additional information: Multiple Firefox Profiles Starting Profile Manager in Linux If Firefox is already included in your Linux distribution or if you have installed Firefox with the package manager of your Linux distribution: "At the ...


0

In a terminal type firefox -no-remote -ProfileManager and create a new profile. Then start the desire profile with firefox -P profilename


1

Run firefox -P or firefox -ProfileManager. You may then create, select, and manage your profile(s). See also How to create a new Firefox profile on Windows? (kb.mozillazine.org). I could not find a similar page for Linux, but the options and screens are nearly the same. To create an icon, create a desktop file as described in How to get my custom ...


0

Follow this : Ctrl+Alt+F1 login there by user name and password Just try this : sudo service lightdm restart If lightdm fails to get back at normal,then Type: sudo apt-get update sudo apt-get install --reinstall ubuntu-desktop sudo apt-get install unity Note : IT Will Terminate Your ACTIVE SESSION


2

You would need to compile Unity yourself (with dependencies) if there is no PPA for this (I dont think there is). For a simple bug like this, I don't think that this is worth the hassle. If you are curious about how to compile it yourself, please refer to this Ask Ubuntu Question.



Top 50 recent answers are included