Tag Info

New answers tagged

1

As I take from our conversation in the comments, you have no software sources configured. This can be due to the following reasons: No sources were configured on installation. (is this even possible?) The software sources were removed accidentally or maliciously deliberately. They were lost due to another reason, which would most likely indicate a system ...


0

You should run sudo apt-get remove php5, then for 5.5 specifically, which was not used in 15.04, you will need to add a source from utopic by opening /etc/apt/sources.list in your favorite text editor and adding the following lines deb http://us.archive.ubuntu.com/ubuntu utopic main and deb-src http://us.archive.ubuntu.com/ubuntu utopic main. Next, to ...


0

You could be running two different instances of Apache. One serving files from var/www/html and the XAMPP/LAMPP instance serving from opt/lampp/htdocs/ (That's the default LAMPP directory) If you have that directory you could copy your project to it. Then start apache inside of LAMPP and see if it works as expected. Note: For LLAMP your site might be ...


0

you do not have to run the apache2 service manually. LAMP is all you need as we all know LAMP = Linux, Apache, Mysql and Php


0

Open a terminal (CTRL+ALT+T) type sudo dpkg --configure -a Done! You can now run sudo apt-get install lamp-server! Remember to mark this as an answer if I helped! It only takes a few seconds of your time and helps other users who have the same problem solve their issues. Thanks!


1

Certainly possible. I actually created a small script which sets up a virtual environment like you describe (although I use it purely as a server, I develop on my local machine). I put it on Github if you're interested: https://github.com/Bartwillemsen/virtual-devbox Basically what you need to do on your Ubuntu guest settings is create a second Network ...


0

It probably gives an error because htdocs is changeable only by root and you are trying to save a file. There are two options, either you save and edit your files as a superuser from the command line or change the permissions for htdocs folder. I prefer the second one, you can google ways to change permissions on a file and find the most suitable one for ...


0

You were close: the directory /var/www/ should be owned by www-data (as a user) and www-data as a group. So the proper command, if things get messed up, is: sudo chown -R www-data:www-data /var/www


1

Another possible solution to use: create a new partition to /var create a new partition to hold /var. you can use Gparted to do that. Create the filesystems for this partitions (can be done with Gparted too) or use mkfs.ext4 /dev/sdaX replace X with your own partition number for the newly created Mount the new filesystem under /mnt mkdir /mnt/var ...


2

Before you reinstall your system, move the mySQL databases to /home and then forget about any complicated stuff from now on! sudo service mysql stop sudo cp --recursive --preserve=all /var/lib/mysql/ /home/ Then: sudo nano /etc/mysql/my.cnf and set datadir to /home/mysql sudo nano /etc/apparmor.d/usr.sbin.mysqld add: /home/mysql/ r, /home/mysql/** ...


0

Your /var will be deleted, if you install Ubuntu again, because /var is not on a separate partition and probably it's a good idea to create a separate partition for /var. Make a backup of /var and move your databases back after the re-installation of Ubuntu. From the comments, an important point: Make sure that the MySQL server is stopped before ...


0

You have to run the install in this sequence: sudo apt-get update sudo apt-get install tasksel sudo tasksel install lamp-server


0

Can't you just become root? sudo -i By switching the current user of your shell to root you can edit your files as the owner, which has the w flag set, without having any need to set any permission. Once done, just run exit to switch back to the previous user


-2

This is possible. Currently root owns the files - you can see that by the root root section. We need you to own the files, and be able to write to them Also, we want everyone else to be able to read them (otherwise that would be a boring website) but not to be able to edit (or that could be a greif website). How do we do this? There are 2 ways, the GUI ...


3

files should be "644", directories should be "755". What you want is not permissions but you want to set the files and directories to a user and group that is allowed to write files into /var/www/html/. sudo chown -R $USER:$USER /var/www/html/* would set all to your current user or if you need something like "www-data" (the default apache user) change it ...


0

I can think of 3 possibilities: You don't have PHP installed. In that case run: sudo apt-get install php You have PHP installed but not enabled. You can try running: sudo a2enmod php5 sudo service apache2 restart You have PHP installed and enabled but you haven't restarted apache. sudo service apache2 restart



Top 50 recent answers are included