Tag Info

New answers tagged

0

I have been looking into this for like one hour, because it has been nuisance for me as well. EASY SOLUTION The simplest solution I found, but I am not too sure if this is working all the time but it's worth the try as the first solution is when you login in, at the right top corner, you will be able to choose your keyboard, Choose the one you want from ...


2

Installation Open Terminal and enter the following commands one by one. Add ibus-avro repository sudo add-apt-repository "deb http://download.opensuse.org/repositories/home:/sarimkhan/xUbuntu_14.04/ ./" Add key wget -q http://download.opensuse.org/repositories/home:/sarimkhan/xUbuntu_14.04/Release.key -O- | sudo apt-key add - Update package list sudo ...


1

You can set the shortcut in your System Settings panel at Text Entry by entering your new accelerator keys (Alt+Shift) in the text field(s) "Switch to next/previous source using:" Does that work for you or do you insist in a terminal command?


1

You want to make Caps Lock work like Shift, so you can set the behavior to the third one.


-1

I found that it was possible to toggle it using the key next to 1 (`) and alt. It should toggle it and take you through a couple of examples. Just type something in Microsoft Word (or whatever program you are using) each time you toggle it, and you should be able to find it. Hope this helped! :)


0

Go to the gears icon in the top right corner of the screen and: click System Settings keyboard layout options...(lower right hand corner) caps lock key behaviour (4th down) Scroll down and choose "Swap ESC and Caps Lock". Done!


1

I'm very sorry to say but you want Ubuntu to be Windows, which is not going to happen tomorrow... :-( Ubuntu is based on Linux, and although it has "windows" than can be dragged around a "desktop" and that it adheres to the CUA like Windows, it's just not the same thing! Asking for something and ruling out all possible answers is just going to leave you ...


0

Shift+f10 maps to a context menu on my Dell Latitude E4200, Ubuntu 14.04. Worth the try before changing the use of another key on your keyboard.


0

Workaround by user wof in Ubuntu bug tracker, for Ubuntu 14.10 using gxkb: https://bugs.launchpad.net/gnome-settings-daemon/+bug/1244090/comments/39 this workaround worked for ubuntu 14.10: in Settings->Text entry remove all input sources, leave only english install gxkb (layout switcher): sudo apt-get install gxkb add gxkb to startup ...


0

Changing Fn may not possible only if the its manufacturer added such option to BIOS. Why? Short answer: Pressing Fn alone does not send a scancode. Long answer: See How do Fn keys work? Stiky key for Caps lock alone (not full accessibility sticky modifiers) Change Caps lock key interpretation sudo nano /usr/share/X11/xkb/compat/caps Change LockMods ...


-1

just like any laptop there is usually a key that makes the keyboard characters change or makes new characters appeared I were you I would go through your keys and see if anything works if not see if Ubuntu already has answered another question like this or look it up online.


1

(I do not know Brazilian portuguese.) The name of the feature you are trying to use is "dead keys". A dead key is chosen so that it has a label which is similar to an accent and when it pressed it does not create a new letter, you have to press a second key too. Some combination results in the accented version of the second letter. There are more than one ...


1

You could add global shortcuts to write special chars. I use this often for my German keyboard layout with Ubuntu (on Windows this work out of the box). I added the following shortcuts: Shift+Enter+7 to write the letter { Shift+Enter+0 to write the letter } Shift+Enter+8 to write the letter [ Shift+Enter+9 to write the letter ] To add these shortcuts ...


0

hy Aabir, I was also searching for the same this resource helped me and I could remap my key on my linux mint netbook. remap keys in linux


1

If you only have 2 keyboard layouts, do the following: You need to install xdotool with sudo apt-get install xdotool for this. Modify your scripts to the following. #!/bin/bash xrandr --auto && xrandr --output eDP1 --off; xdotool keydown Super key space keyup Super and #!/bin/bash xrandr --auto && xrandr --output HDMI1 --off; ...


0

I would make use of the cross platform .NET rewrite of the popular Windows AutoHotkey scripting language, called IronAHK. I save time every day on my Windows system with AHK, cutting keystrokes and saving mouse clicks here and there. You can check it out here: ⠀http://www.ironahk.net/ And you should check out the original AHK as IronAHK doesn't market ...


0

Set US layout: setxkbmap us Set GB layout: setxkbmap gb


2

You can use ComposeKey sequences to easily write ligatures. This link should provide all the information you need: http://fsymbols.com/keyboard/linux/compose/


0

You wanted a man page? man xterm eightBitInput (class EightBitInput) If “true”, Meta characters (a single-byte character combined with the Meta modifier key) input from the keyboard are pre‐ sented as a single character, modified according to the eight‐ BitMeta resource. If “false”, Meta characters ...


1

I suggest you go through the settings menu, and do couple of things. First, open the language support menu and it should let you know whether or not the language support is installed completely. Second, open Region and Language, and under System tab, there should be an option to copy your settings to the system settings.Try doing that


1

to prevent gnome resetting keyboard setting in X i use this command: gsettings set org.gnome.settings-daemon.plugins.keyboard active false works for me


2

Typical, found a fix as soon as I posted this Q - so far it seems to work: 1: go to dconfeditor, org->compiz->onboard 2: set keylabel-overrides and layout to defaults ([] and NULL (ie enter nothing) respectively)


0

Install the ibus-m17n package and relogin. Then you will find a few additional Tamil input sources in Text Entry. Hopefully one of those, e.g. "Tamil (typewriter (m17n))", is what you are looking for.


0

It is some component of the Unity Destop Environment. I installed gnome-shell, and logged into gnome-session, ran the script in the question and the diff was empty, hence that session did not override any settings. And indeed both keyboard layouts where available in the panel. I filed a bugreport: https://bugs.launchpad.net/unity/+bug/1418939


0

My plain vanilla Ubuntu system contains a keyboard version of Bulgarian phonetic. I've posted it here. Download this file to ~/downloads/bg.txt and compare it to your current keyboard lay-out file in /usr/share/X11/xkb/symbols/bg by using the following command: diff ~/downloads/bg.txt /usr/share/X11/xkb/symbols/bg If they are identical (which they ...


1

For a german keyboard layout, two are typically on the key to the left of backspace key, the circumflex accent is typically on the key to the right (or on some keyboards below) of escape key. Now keep in mind that for them to actually work, you need a keyboard layout that has dead keys active (most germans for example use the 'nodeadkeys' layout as default, ...


0

Open System Settings -> Text Entry. The input source at the top of the list is default, and the one used at reboot or relogin. To change the default, move some otner source to the top of the list.



Top 50 recent answers are included