Tag Info

Hot answers tagged

4

In Ubuntu 14.04, keyboard layouts are kept in /usr/share/X11/xkb/symbols/ Each of the files in this directory contains a series of entries of the following type: key <AC01> {[a, A, aacute, Aacute]}; This entry maps a key on the keyboard to a number of specific characters using the following conventions: <A C01> The first letter A ...


2

You need to remap the key to Grave. This is taken from this answer. xev will output some information about the pressed key. The third line is important. It should look similar to: state 0x10, keycode 49 (keysym 0xff55, Escape), same_screen YES, in this example Escape is the name of the behaviour the key is assigned to at the moment, the number keycode ...


2

The OP found that the the problem is caused by a bug in Virtualbox: The issue is related to the VirtualBox "Guest additions" software. This post confirms there is a bug in version 4.3.14: http://forums.virtualbox.org/viewtopic.php?f=6&t=62687 VirtualBox 4.3.14 is the latest version, which I am using. As a work around I will downgrade to an ...


2

updated rm -f executed.log echo ".profile starting" >> executed.log if [ $(whoami) != "root" ] then echo "$(setxkbmap -v)">> executed.log echo "$(setxkbmap -layout "us" -variant "altgr-intl" -option "ctrl:nocaps")" echo "setxkbmap executed" >> executed.log echo "$(setxkbmap -v)">> executed.log fi check for small ...


1

You can change the layout with console-data. If not installed use sudo apt-get install console-data to install it. Then use sudo dpkg-reconfigure console-data to change the layout.


1

After days I finally resolved my problem. It was solved for me by disabling auto capture keyboard in VirtualBox. In VirtualBox: File -> Preferences -> Input -> Disable auto capture keyboard


1

Open System Settings, and click keyboard: Click input sources: Click +: Find German (I had to search you probably will just have to scroll), select it and click Add. Chose that as your default.


1

I can now select German (qwerty) in the Unity desktop in 14.04: This gives me exactly what I want. It is also possible to switch to this particular layout in the terminal: setxkbmap -layout de -variant qwerty There is absolutely no need to mess with the system's keyboard layout files!


1

The keyboard options in Ubuntu and GNOME are nothing but a frontend to the X keyboard extension (XKB). If you are fine with configuring things manually you can easily reenable all of the now-missing options with a setxkbmap command line. For instance, to set a non-modal switch between Russian and English keyboard layouts you can use the following command: ...


1


1

each symbol file should have a default layout. default partial alphanumeric_keys xkb_symbols "basic" hope this help


1

According to the bug-reporting mechanism here https://bugs.freedesktop.org/show_bug.cgi?id=81571 this has now been fixed.


1

Press CTRL+SHIFT while keeping them pressed, press and release U then type in 00BF, release CTRL+SHIFT, then you will have your ¿. Source:W3



Only top voted, non community-wiki answers of a minimum length are eligible