Hot answers tagged

49

Like Ubuntu, the Linux kernel also has long-term support versions. So, for an Ubuntu LTS release (like 16.04), picking the latest long-term kernel version makes sense. This way, unlike with a normal stable release, Canonical can rely on the kernel maintainers to backport fixes for a long time. 4.4 will be supported till February 2018. Canonical did pick a ...


5

Since Ubuntu kernel 4.4.0-20 the EFI_SECURE_BOOT_SIG_ENFORCE kernel config has been enabled. That prevents from loading unsigned third party modules if UEFI Secure Boot is enabled. Since Ubuntu kernel build 4.4.0-21.37 this can be fixed by running sudo apt install mokutil sudo mokutil --disable-validation


2

hidepid procfs on Linux now supports the hidepid option. From man 5 proc: hidepid=n (since Linux 3.3) This option controls who can access the information in /proc/[pid] directories. The argument, n, is one of the following values: 0 Everybody may access all /proc/[pid] directories. This is the ...


2

Here is a brief answer. Mainline kernels are just vanilla kernels from kernel.org packed as deb. Ubuntu kernels are specially maintained by Canonical Kernel Team. The team backports bug fixes and support of some new hardware from the latest mainline kernels, and also does other improvements. Canonical and the community supports only the Ubuntu kernels. ...


2

I have a Lenovo T440p and my wireless works perfectly. lspci -nnk | grep 0280 -A2 03:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b2] (rev 6b) Subsystem: Intel Corporation Wireless-N 7260 [8086:c262] Kernel driver in use: iwlwifi


2

Still tracking this issue? It seems like you have a bad memory module, the machine pauses just waiting for the hardware to correct this error by itself. You may need to try to remove or replace the memory at your first CPU, second channel and first slot. Please refer: http://serverfault.com/questions/569289/server-freezes-completely-in-unknown-condition ...


2

It seems I have solved it. 16.04 was installed over a disk containing an earlier version and for some reason it a) did not remove earlier kernels, and b) did not install the 16.04 4.4 kernel. solution - I deleted all earlier kernels from /boot and all directories referring to modules for earlier kernels, and reinstalled. That got rid of the problem.


1

I found that, when the target is another xubuntu, also following works to obtain the text addresses: (gdb) monitor lsmod Module Size modstruct Used by iptable_mangle 16384 0xffffffffc0f57040 1 (Live) 0xffffffffc0f55000 [ ] ... then you can use the elsewhere documented commands to tell gdb the offset (gdb) ...


1

I had the same problem as you, I also thought I had completely removed the kernel by deleting all its entries in /boot and directory in /lib/modules & updating GRUB, but i found the one directory that is used by update-initramfs to keep track of the kernels: /var/lib/initramfs-tools


1

Alright so after a bit of testing I'm pretty sure this is a secure boot issue. As in if it's enabled then this is thrown: WARNING: The vboxdrv kernel module is not loaded. Either there is no module available for the current kernel (4.4.0-21-generic) or it failed to load. Please recompile the kernel module and install it by sudo ...


1

Update: Note that while some indicate that VMWare version 12.1.1-3770994 fixes the issue - excellent for you! - unfortunately, this is not the case for me. I am running 12.1.1-3770994 and still having the problem as per my answer. I suspect this is a Secure Boot issue. 16.04 now enforces module signatures and the the VMWare modules built by the ...


1

I haven't had any issues with WiFi on a T530 and a new T560 (16.04) in the past. Be sure to get the Intel WiFi option, the modules should be the same in the 14 inch models. From the T560: 04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)


1

Im not familiar with that program but if I want my computer to boot to a different kernel I just manually edit the grub file located at: /etc/default/grub Look for GRUB_DEFAULT=0 (or whatever your default is set too) Change that line to the kernel you want loaded ... looking at your list there it looks like 0 would be the standard 4.4.8 and 3 would be ...


1

Ok .. Decided to give it Grub Customizer a try on a VM box so I didn't screw anything up. I was able to change the default kernel without any issues. Here is how I did it. In the General settings tab I clicked the pulldown for predefined. It listed all the kernels available. I chose the 3.19.0-58-generic and clicked save ... I rebooted into that kernel. ...


1

Restart your computer, when your BIOS is through quickly press shift (might need a few tries to get the timing right) to open the GRUB menu. There choose other options for ubuntu and select to boot with the older kernel, then you safely can uninstall everything what belongs to the newer kernel and be done with it: sudo apt-get remove linux-headers-4.4.8* ...



Only top voted, non community-wiki answers of a minimum length are eligible