New answers tagged

1

look here http://stackoverflow.com/questions/6477415/how-to-set-oracles-java-as-the-default-java-in-ubuntu not the accepted answer but Barracuda's, which I reproduce below: to set Oracle's Java SE Development Kit as the system default Java just download the latest Java SE Development Kit from [here][1] then create a directory somewhere you like in ...


1

Oracle JDK is a proprietary JAVA software by Oracle. Open JDK is an open-source JAVA software. There is no "recommended" JDK. You can use either one.


2

Open a terminal (ctrl+alt+t): sudo apt-get install openjdk-8* This will install the folowing packages: openjdk-8-jre-dcevm - Alternative VM for OpenJDK 8 with enhanced class redefinition openjdk-8-jre-zero - Alternative JVM for OpenJDK, using Zero/Shark openjdk-8-dbg - Java runtime based on OpenJDK (debugging symbols) openjdk-8-demo - Java runtime based ...


1

The one I did on 16.04 was: For OpenJDK 8.X sudo apt install openjdk-8-jre For OpenJDK 9.X sudo apt install openjdk-9-jre Note: There was no openjdk-6-jre nor openjdk-7-jre for me on Ubuntu 16.04. Also there is NO need to install Oracle JDK (Actually OpenJDK is much better than Oracle one for me).


1

had the same problem too.. but i solved it with these commands: sudo add-apt-repository ppa:openjdk-r/ppa sudo apt-get update sudo apt-get install openjdk-7-jre


0

Try the following: Install ppa-purge with sudo apt-get install ppa-purge Then bash sudo ppa-purge ppa:webupd8team/java Try to open your filemanager with gksu and delete the Java folders. Next step is to install the ppa again WITHOUT the -y option. You should be able to eccept the terms of service and install java. If you are done check with java ...


1

I had the exact same problem as you experienced. Turns out a RAM memory module in my machine was broken. After removing the broken memory module everything went back to normal.


-1

You can try to install the Java Runtime Environment (jre) first. Simply run the following in terminal: sudo apt-get install openjdk-7-jre OR: sudo apt-get install default-jre


0

Been a while that this issue is open. As I run into something like this just today I wanted to add my solution to that. (Would have commented on the answer above...but reputation..) I run into a similar issue and got it solved by sudo dpkg --add-architecture i386 sudo apt-get update sudo apt-get install libc6-i386 If apt-get was not able to locate the ...


2

Example for Java 8: sudo apt-get install openjdk-8-source apt-get puts it under the relevant JDK location as src.zip: /usr/lib/jvm/java-8-openjdk-amd64/src.zip Intellij IDEA recognized it automatically and started showing me the source code.


0

error was in the configuration file in program itself so it could't read right version i want


0

You currently have JRE installed, not JDK. NetBeans needs JDK to work properly. Install it by running: sudo apt-get install openjdk-7-jdk


0

You don't have JDK installed; you have JRE (although I suspect you already know that). To get that application to work, you need to install OpenJDK: sudo apt-get install openjdk-7-jdk That should set itself to the default Java version, but if it doesn't, you can run the command you have in your question to make it the default.


0

After a few OS installs, I also tried installing 740 again and here is what worked for me: Downloaded Java version 8u45. Install manually using these instructions. Run Java installer BD_NW_7.0_Presentation_7.40_Comp.2


0

It's 2016. You should have an internet connection. If you don't have an internet connection, you can still use packages. Download the package here. This is Java 7. There is no official Java 8 package for Ubuntu 14.04, so you'd need the get it from a thirdparty website if you really want Java 8. You need the one for i386 because you're running a 32 bit ...



Top 50 recent answers are included