New answers tagged

0

I fixed this problem. I use AS 2.1 and JDK1.7 while it required me to update JDK1.8 for some functions. I download the java setup file. Maybe I only installed jre but not jdk. so AS always warn me that "Please choose a valid JDK directory". So I guess the asker's problem same as me that you should install a JDK but not jre.


0

On Linux Mint 18 of the Ubuntu family with openjdk version "1.8.0_91" installed, I installed SAP GUI for Java 7.40 rev 7. I ran into the same error when I tried to start the SAP gui. I simply looked for javafx in the software center and installed Javafx/openjfx 8 - rich client application platform for java. Now it runs like a charm.


3

You seem to be using a development version of java : Java 9 has not been released yet. So, first of all, you should remove this version of java, and install the default one : sudo apt-get remove openjdk-9-* sudo apt-get install default-jre Depending on your version of Ubuntu, it should be a version 7 or 8. If you're on a development version of Ubuntu, ...


2

Click in Ubuntu icon (the first bottom in side menu). Write gedit Open Text Editor clicking in its icon. Click in Open. In the list, write: ~/.bashrc Enter Clean your failing .bashrc file. Save and you can open terminal again.


1

I see the problem you dont have libXext.so.6 so try reinstalling it with this command sudo apt install --reinstall libxext6 Or if that doesn't work: sudo apt remove libxext sudo apt install libxext If even that doesn't work: sudo apt purge libxext sudo apt install libxext This should work :)


0

It looks like libawt_xawt.so requires libXext.so.6 but can't find it. To fix it, try: sudo apt install --reinstall libxext6 Source: http://packages.ubuntu.com/search?searchon=contents&keywords=libXext.so.6&mode=filename&suite=raring&arch=any


0

Assuming you have the installation file in .rpm format(that oracle jdk ships with) sudo apt-get install alien alien <filename>.rpm dpkg -i <filename>.deb Note - Alien is the a package that converts rpm to deb Or what I would actually suggest you to do is sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install ...


6

You have it removed. Bash is just telling you, hey, if you want to run java, here are the packages you can install. Try running which java. If no output, then you don't have any JDK installed. You can install any one of the packages suggested.


0

This may be because you are using an x64 system. If you are, install the 32 bit libs with: sudo apt-get install lib32z1 Then try to run the self extraction file again. Hope that helps.


0

I was able to solve it. First I had to download all the packages on the link I mentionded Ubuntu Secure Proposed team I did it using the following commands: sudo wget https://launchpad.net/~ubuntu-security-proposed/+archive/ubuntu/ppa/+build/5935007/+files/openjdk-7-jre_7u55-2.4.7-1ubuntu1~0.12.04.2_amd64.deb sudo wget https://launchpad.net/~ubuntu-...



Top 50 recent answers are included