Tag Info

New answers tagged

0

For some reason, the comment option is not available on my iPhone 6 using the StackExchange app. So I don't have an answer for you. I have this question as well, mine crashes too.


0

Try do disable iptables: sudo service iptables stop && sudo service ip6tables stop Then restart hadoop. If this helped you need make proper configuration for your firewall.


-1

I can confirm that this is related to xfce 4.12. I am using Xubuntu 14.04 and after I updated xfce from 4.10 to 4.12, I got the exact same error messages. I am very sorry for posting this as an answer, but this website forbids me to post a comment. Please do not downvote.


0

Replace Runtime.getRuntime().exec("spd-say \"" +message+ "\" -p 100 -i 100 -t female1"); with Runtime.getRuntime().exec(new String[]{"spd-say",'\"'+message+'\"',"-p 100 -i 100 -t female1"); and it will work. Cheers!


0

Switching java to Oracle JDK is just a workaround in my opinion, as the OP wanted to know why it doesn't work anymore with OpenJDK. Anyway, I fixed it myself using this answer on ask.fedoraproject.org. Basically you first have to create a file javajar.desktop with following contents in /usr/share/applications/. [Desktop Entry] Encoding=UTF-8 Version=1.0 ...


0

I think here is the correct solution for this problem. For you and other people who are facing the same problem.


0

if you are able to run java commands like java --version from the terminal, the PATH is correct and in turn, the JAVA_HOME variable is correct.


0

It appears that this is a 32 bit executable even though it is from a 64 bit jdk for Linux. I found the solution here: No such file or directory? But the file exists! Using file suggested by Gilles confirmed the problem. The answer by Ravinash Raj was specific and fixed my install. Thanks.


-1

Can confirm this bug. I assume it is caused by XFCE 4.12 (it was working with XFCE 4.10) and the corresponding xfwm4. Causes troubles with all tested versions of eclipse. Since this is a new bug in XFCE 4.12 you can not "search for an error" because its not your fault. I am not aware of any workarounds. I would recommend you to open a bug report on ...


0

If you have update-java-alternatives installed, just type $>update-java-alternatives -l From the manual man update-java-alternatives DESCRIPTION update-java-alternatives updates all alternatives belonging to one runtime or development kit for the Java language. A package does provide these information of it's alter‐ natives ...


1

Your $JAVAHOME is pointing to the correct location. But the path should have $JAVAHOME/bin directory and not $JAVAHOME itself. JAVA_HOME="/opt/jdk1.7.75" export JAVA_HOME PATH="$PATH:$JAVA_HOME/bin" You should consider using the Oracle Java PPA instead. It usually does more than what a manual installation would do. You don't have to worry about setting ...


0

Eventually, I managed to make my service listen to the port 9000 by adding to the /etc/ssh/sshd_config file the following line: Port 9000 I followed this serverguide/openssh-server (it contains also some important remarks about making a copy of the original file, restarting the sshd server application etc.) After this I can see: telnet output: ...


0

TL;DR first, more details following: "Connection refused" is the error you get when you try to connect to a service on a computer or server (or locally on your own computer) when the said service is either not listening on the specified TCP port (wrong port or service not started), or when a firewall explicitly rejects a connection instead of ignoring the ...


0

Right click - properties Click on the "Permissions" tab and make sure the "Allow executing file as program" checkbox is checked.


0

This PPA is to get Unity AppMenu and HUD support for applications like NetBeans IDE, IntelliJ IDEA, Android Studio etc., as described here. So, unless you want this you can delete the package using sudo apt-get remove jayatana (and as the stackoverflow thread suggests, removing /usr/share/upstart/sessions/jayatana.conf and restarting your computer). I am not ...


1

Create a .desktop file: [Desktop Entry] Name=Icy Exec=/bin/bash -c "cd /path/to/script/directory&&./icy.sh" Type=Application Terminal=false Copy it into an empty file, save it as icy.desktop Replace /path/to/script/directory by the actual path to the script's directory Make it executable Explanation Desktop files (with the extension .desktop) ...


1

when you open that icy.sh file, you can see java -jar updater.jar So you can just modify (leafpad, gedit or any other text editor)your icy.desktop file to: [Desktop Entry] Name=ICY Exec=java -jar '/your/path/to/file/updater.jar' Icon=your/path/to/icon Terminal=false Type=Application With icy.sh set as executable and with shortcut ...


0

You can open the "shortcut" as a plain text using any text editor. When opened, you must change the path of the file. Probably now it's a relative path, so make it absolute to look like "./home/user/pathtofile/file.sh"


2

A major convenience upgrade would be to use a background script, automatically setting the resolution per application, while you can set different resolutions for different (multiple) applications at once. That is exactly what the script below does. An example of a default resolution of 1680x1050: Running gedit, automatically changing to 640x480: ...


0

Both things are happening because minecraft.jar is not marked as executable by your user; assuming that you are the owner of the file, run this command from the command-line to mark it as executable by you: chmod u+x <path_to_jar_file> *<path_to_jar_file> = full path to the .jar file If you want it to be run from the member of your user's ...


0

Why does this message appear? Apparently it's reporting that the environment variable JAVA_TOOLS_OPTIONS has been set. Does anybody else observe this? Yes, I see it and am annoyed by it as well. Can it be disabled? A couple of sites suggest uninstalling jayatana, but I'm reluctant to do that since I don't really know why Ubuntu installed it ...


0

There is an elegant way, with dpkg-divertcommand (override a package's version of a file, see this). dpkg-divert --divert /full_path/file_to_preserve.packaged --rename /full_path/file_to_preserve Please consider having putting together different versions of files of a given package it might be risky...


1

I also tried to install NetBeans IDE 7.0.1 in Ubuntu 14.04 with OpenJDK Development Kit 7 and had the same problem as you have. I searched for a solution and found a Launchpad bug report: Bug #1360100: NetBeans IDE cannot create a project, so I gave up and installed IntelliJ IDEA Community Edition from the Ubuntu Software Center instead. IntelliJ IDEA ...


1

"Everyone" is right ;) To use servlets, you need to a web container. XAMPP includes the Apache HTTP server as a webserver, and the Apache HTTP server does not offer a web container. You need something like Tomcat or JBoss/WildFly.


1

Purge all you old versions and install a latest Oracle JDK. Just follow the steps given in this site to install JDK


1

I would recommend using the ppa-purge tool to remove the old ppa. You could also download the java distribution straight from Oracle's website and use the debian alternatives system to maintain multiple versions simultaneously. Let me know if you want to know how to do that.


3

Try to purge the old package. sudo apt-get purge oracle-java8-installer Add the webupd8team Java PPA repository in your system and install Oracle Java 8 using following set of commands. sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer source


0

I just recently had the same problem - the way I fixed it was to uninstall OpenJDK 7 and install OpenJDK 6. I have no idea why OpenJDK 7 doesn't want to work but it started glitching when I installed it via the Terminal. Installing OpenJDK 6 is like installing a fresh new version of Java. I had tried many different other commands and they didn't seem to ...


0

I actually had this problem, too. I had Java installed and marked the jar as executable, but it still didn't work. Here's how I fixed it (kind of a workaround): Right-click on the jar you want to open and select Properties. Click File Type Options, under the Type section. Click Add under the Application Preference Order and search jar. Select the result, ...


0

Try this. Open a terminal and try running java -version As long as it returns something, you have java installed. You likely haven't marked the .jar files as executable. To do so open a terminal, navigate to where the .jar files are located and run chmod u+x name-of-file.jar Replacing name-of-file.jar with the .jar file you're wanting to run.


0

Check if some JDK is installed in your system: $ java -version Installing JDK 7 solved my problem: $ sudo apt-get install openjdk-7-jre-headless If the problem persists, log as root, then execute: $ xhost + Switch back to another user and run installation again.


0

If You have Ubuntu Tweak, you can create asociation in card File Types Manager Select line "Archive Java" and change the record by double click: Add > Use own command > type "/usr/bin/java -jar " and press enter. After that you can easily run java app by double-clicking on it. Happy clicking!


1

For some reason the desktop file for OpenJDK is not installed, even though this file is listed. $ apt-file list openjdk-8-jre | grep desktop openjdk-8-jre: /usr/share/applications/openjdk-8-java.desktop openjdk-8-jre: /usr/share/applications/openjdk-8-policytool.desktop $ ls -l /usr/share/applications/openjdk-8-java.desktop ls: cannot access ...


0

Make a run.sh file in the directory with the Minecraft.jar containing #!/bin/sh java -jar Minecraft.jar or anywhere you like changing Minecraft.jar to the correct filepath. Mark the file as executable and run it.


0

Install Java with this commands and you have an entry in open with: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer and then sudo apt-get install oracle-java8-set-default And in order to do things more easily, use the Minecraft Installer. sudo add-apt-repository ...


0

If you remove OpenJDK, it will break dependencies, but these dependencies are only related to Java. If you uninstall it, anything that requires Java to run will not work until you install OpenJDK again. Also, there's not big reason to uninstall OpenJDK 7. It still works with everything v8 does, and is more stable.


0

It is not as complicated as the other answers make it out to be. You have to add the manual installed java to the alternatives list, then switch to is: (replace jdk1.7.0_79 with your version) sudo /usr/sbin/alternatives --install /usr/java/jdk1.7.0_79/bin/java 20000 sudo /usr/sbin/alternatives --config java


0

At the moment, icedtea-8-plugin is not available in the official Ubuntu repositories. Maarten Fonville offers a PPA repository with a working icedtea-8-plugin package. sudo add-apt-repository ppa:maarten-fonville/ppa sudo apt-get update sudo apt-get install icedtea-8-plugin Bug report: https://bugs.launchpad.net/ubuntu/+source/icedtea-web/+bug/1385842 ...


0

Could you please try to run with arguments without quotes? It works in my case: svyatoslav@svyatoslav-DNS:~$ sudo update-alternatives --config java [sudo] password for svyatoslav: Есть 4 варианта для альтернативы java (предоставляет /usr/bin/java). Выбор Путь Приор Состояние ...


0

I ended up solving this by replacing the version of Java that I had downloaded from 32 bit to 64 bit


0

I had exact the same problem under openSUSE13.2 with eclipse. Solution was to move the jfxrt.jar file (can be found in Java SE Development Kit 8u45 tarball) to: /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/jre/lib/jfxrt.jar Not to /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0/jre/lib/ext/jfxrt.jar as I did before.


1

Install Oracle JDK 8 using this set of commands: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer Then restart firefox/chrome


1

Short Answer (TL;DR): Use Java-Gnome bindings, it is a native library that enables Java applications to use GTK and GNOME APIs/Services. Long Answer: Java official slogan is "write once, run anywhere", where it states that Java programs can be run on various platforms (processors) and operating systems. To do that, the Java programming language provides a ...


0

I've built Openjdk 8u40 on my own and applied tuxjdk patches. Moreover, i had to create a file called local.conf in /etc/fonts/ to override java's fontmap for its logical fonts like Dialog, Monospaced, etc. After that, Swing based applications improved a lot. Take a look HERE.


4

Note – This will only work with 14.10 or later: 1 year late, but as today it works as expected with apt-get: $ sudo apt-get install openjdk-8-jdk Or: $ sudo apt-get install openjdk-8-jre How to set the default JDK Fastest way Run $ sudo update-alternatives --config java and enter the number for which JDK to use of your choice. Second way ...


1

I assume this is because Calc isn't able to access the PostgreSQL database. Double-check if PostgreSQL is running: sudo service postgresql status should return something like 9.3/main (port 5432): online If PostgreSQL is running, check the credentials. By default, there's no admin password set for PostgreSQL. Calc assumes postgres as admin password, ...


0

You shouldn't install JDK for all system (java for all system on Russian), install it for specified user - it's more flexible: Download any JDK (*.tar.gz or *.sh) Install it to any folder (basically *.sh script will only unpack archive, so new JDK can be manually unpacked to any folder), so java will be located here - ...


0

you faced with 1 warning and 1 error: 1) The APR based Apache Tomcat Native library - is a library, it's optional and all should working without it but with less perfomance on production system. This is a warning 2) Apr 17, 2015 2:13:58 AM org.apache.catalina.core.StandardContext startInternal SEVERE: Error listenerStart - this is a root cause of your issue. ...


0

Using the Iced Tea sudo apt-get install icedtea-netx followed by javaws ~/Downloads/cgoban.jnlp


0

You need to set up CLASSPATH in /etc/environment. Execute the following command in a terminal (Ctrl+Alt+T) sudo gedit /etc/environment Add the following lines (all four lines at the end of /etc/environment) JAVA_HOME="/usr/lib/jvm/oracle_jdk8" export JAVA_HOME CLASSPATH="/usr/lib/jvm/oracle_jdk8/lib" export CLASSPATH Alternatively you can add ...



Top 50 recent answers are included