Tag Info

Hot answers tagged

4

Note – This will only work with 14.10 or later: 1 year late, but as today it works as expected with apt-get: $ sudo apt-get install openjdk-8-jdk Or: $ sudo apt-get install openjdk-8-jre How to set the default JDK Fastest way Run $ sudo update-alternatives --config java and enter the number for which JDK to use of your choice. Second way ...


4

The method dateChooser.getDate() returns null. You've just instantiated the object dateChooser, but never assigned a Date object. This is the implementation of the method getDate() in JDateChooser.java /** * Returns the date. If the JDateChooser is started with a null date and no * date was set by the user, null is returned. * * @return the current ...


3

Try to purge the old package. sudo apt-get purge oracle-java8-installer Add the webupd8team Java PPA repository in your system and install Oracle Java 8 using following set of commands. sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer source


2

You will probably want to edit your sudoers file with sudo visudo, find the line Defaults env_reset and add a line Defaults env_keep = "JAVA_HOME" below it. See below for explanation, details, and alternatives. Why sudo Is Clearing JAVA_HOME When you run a command with sudo, by default your environment is not passed intact. Most environment ...


2

I would suggest you to try: sudo apt-get autoremove sudo apt-get clean sudo apt-get update sudo apt-get upgrade sudo apt-get remove -f and then install Java8 again.


2

A major convenience upgrade would be to use a background script, automatically setting the resolution per application, while you can set different resolutions for different (multiple) applications at once. That is exactly what the script below does. An example of a default resolution of 1680x1050: Running gedit, automatically changing to 640x480: ...


2

i had the same problem with Matlab 2014a, i tried to change permissions of the sys/java/jre/glnxa64/jre/bin/java but it wouldn't i still don't know the reason why, so i took the whole sys/java/jre/glnxa64/jre directory and copied it to my Desktop where i changed the permissions to chmod 777 /home/$USER/Desktop/jre/bin/java and i started the ...


1

Try whit this code in terminal to remove java 8 sudo apt-get purge oracle-java8-installer after type javac -version output have to be jvac: command not found and to install java 7 in ubuntu I use this code in terminal sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java7-installer after type java ...


1

Maybe this has been solved for you already, but I just ran into the same problem (Ubuntu 14.04, yEd & Unity). I have no idea what causes the problem, but the following workaround worked for me: Select the running yEd using the icon in Unity's sidebar. Hit Alt+Space. This should show the window menu, but for me it came up empty. Hit the up or down arrow ...


1

It is not as complicated as the other answers make it out to be. You have to add the manual installed java to the alternatives list, then switch to is: (replace jdk1.7.0_79 with your version) sudo /usr/sbin/alternatives --install /usr/java/jdk1.7.0_79/bin/java 20000 sudo /usr/sbin/alternatives --config java


1

You can try running this command from your terminal: $ sudo apt-get install openjdk-6-jre. See more info here: http://openjdk.java.net/install/


1

I assume this is because Calc isn't able to access the PostgreSQL database. Double-check if PostgreSQL is running: sudo service postgresql status should return something like 9.3/main (port 5432): online If PostgreSQL is running, check the credentials. By default, there's no admin password set for PostgreSQL. Calc assumes postgres as admin password, ...


1

Short Answer (TL;DR): Use Java-Gnome bindings, it is a native library that enables Java applications to use GTK and GNOME APIs/Services. Long Answer: Java official slogan is "write once, run anywhere", where it states that Java programs can be run on various platforms (processors) and operating systems. To do that, the Java programming language provides a ...


1

Install Oracle JDK 8 using this set of commands: sudo add-apt-repository ppa:webupd8team/java sudo apt-get update sudo apt-get install oracle-java8-installer Then restart firefox/chrome


1

For some reason the desktop file for OpenJDK is not installed, even though this file is listed. $ apt-file list openjdk-8-jre | grep desktop openjdk-8-jre: /usr/share/applications/openjdk-8-java.desktop openjdk-8-jre: /usr/share/applications/openjdk-8-policytool.desktop $ ls -l /usr/share/applications/openjdk-8-java.desktop ls: cannot access ...


1

Switching java to Oracle JDK is just a workaround in my opinion, as the OP wanted to know why it doesn't work anymore with OpenJDK. Anyway, I fixed it myself using this answer on ask.fedoraproject.org. Basically you first have to create a file javajar.desktop with following contents in /usr/share/applications/. [Desktop Entry] Encoding=UTF-8 Version=1.0 ...


1

TL;DR first, more details following: "Connection refused" is the error you get when you try to connect to a service on a computer or server (or locally on your own computer) when the said service is either not listening on the specified TCP port (wrong port or service not started), or when a firewall explicitly rejects a connection instead of ignoring the ...


1

Try do disable iptables: sudo service iptables stop && sudo service ip6tables stop Then restart hadoop. If this helped you need make proper configuration for your firewall.


1

I would recommend using the ppa-purge tool to remove the old ppa. You could also download the java distribution straight from Oracle's website and use the debian alternatives system to maintain multiple versions simultaneously. Let me know if you want to know how to do that.


1

Purge all you old versions and install a latest Oracle JDK. Just follow the steps given in this site to install JDK


1

"Everyone" is right ;) To use servlets, you need to a web container. XAMPP includes the Apache HTTP server as a webserver, and the Apache HTTP server does not offer a web container. You need something like Tomcat or JBoss/WildFly.


1

I also tried to install NetBeans IDE 7.0.1 in Ubuntu 14.04 with OpenJDK Development Kit 7 and had the same problem as you have. I searched for a solution and found a Launchpad bug report: Bug #1360100: NetBeans IDE cannot create a project, so I gave up and installed IntelliJ IDEA Community Edition from the Ubuntu Software Center instead. IntelliJ IDEA ...


1

when you open that icy.sh file, you can see java -jar updater.jar So you can just modify (leafpad, gedit or any other text editor)your icy.desktop file to: [Desktop Entry] Name=ICY Exec=java -jar '/your/path/to/file/updater.jar' Icon=your/path/to/icon Terminal=false Type=Application With icy.sh set as executable and with shortcut ...


1

Create a .desktop file: [Desktop Entry] Name=Icy Exec=/bin/bash -c "cd /path/to/script/directory&&./icy.sh" Type=Application Terminal=false Copy it into an empty file, save it as icy.desktop Replace /path/to/script/directory by the actual path to the script's directory Make it executable Explanation Desktop files (with the extension .desktop) ...


1

Your $JAVAHOME is pointing to the correct location. But the path should have $JAVAHOME/bin directory and not $JAVAHOME itself. JAVA_HOME="/opt/jdk1.7.75" export JAVA_HOME PATH="$PATH:$JAVA_HOME/bin" You should consider using the Oracle Java PPA instead. It usually does more than what a manual installation would do. You don't have to worry about setting ...


1

sudo add-apt-repository ppa:minecraft-installer-peeps/minecraft-installer sudo apt-get update sudo apt-get install minecraft-installer Once installed, run Minecraft from the menu / Dash, login with your Minecraft account and the installation should start automatically. Source ... and you can play Minecraft


1

Try this: sudo rm -rf ~/.local/share/Trash/* Of course replace the * with the folder that you wish to delete or else everything in the trash will be deleted.


1

From a Terminal Window run the following: sudo rm -rf ~/.local/share/Trash/*



Only top voted, non community-wiki answers of a minimum length are eligible