Tag Info

Hot answers tagged

11

Ctrl-Shift-U is the short-cut to start entering a full unicode character by hand. For example, here I've typed: Ctrl-Shift-U 0 0 b 0 enter to get the degree symbol: ° which is unicode 00b0. Here is 2665, the heart: ♥ For a list of unicode symbols start here: http://en.wikipedia.org/wiki/Unicode


10

You need to add ibus-daemon to your startup applications: Open startup applications from the power cog Add ibus-daemon


7

You can't. What you can do is start a new X-session on a different tty (screen) which should leave the apps running in the first session untouched. (This is how some display managers [e.g., KDM] allow multiple log-ins of different users using the the same physical display/keyboard.) Source: ...


3

A quick search on alternative.to to ukelele led me to Keyboard layout editor whose latest version (although built three years ago almost) is at github here. According to the site, Keyboard Layout Editor is a pygtk program that helps create or edit XKB keyboard layouts. To run the application, you need the python binding packages for Cairo ...


3

You need to enable IBus and select the method of input. Restart X-server or reboot. Right click on the applications when opened ie: Gedit, to change input method. Let me attach the windows options you should have:


3

Ubuntu keeps all it's plans in a system on launchpad called blueprints, each feature or plan is carefully laid out and given a time line. Searching this database I can find no release targeted specifications for handwriting. But I did find this user created specification back in Boston-UDS 2007: ...


3

Did you read the edubuntu wiki? Please check whether "QT_IM_MODULE" and "GTK_IM_MODULE" are defined.


3

Thanks for those who suggested possible solutions. The following suggestion works for LibreOffice, gedit, and terminal. (It still doesn't work in Thunderbird, though.) http://user.services.openoffice.org/en/forum/viewtopic.php?f=16&t=37863&sid=6cd6626c2ec5ddf283d4d6043b11acfb Re: Language issues after switching to Standard OOo Postby Robert ...


3

Check: https://fcitx-im.org/wiki/FAQ#Root_application_under_normal_user_X Root application in general cannot communicate with user application by user session dbus, but xim only has the restriction of things need to be run under same X. BTW, X application is in general broken with sudo, it's highly recommended not to do that.


2

The ComposeKey sequences used by Gnome to enter special characters are hard coded into the program, so your modified settings will work with X programs, and apparently KDE programs, but not with Gtk programs. Source: GtkComposeTable, which lists the Gnome compose key table. Gnome dead key settings are given at GtkDeadKeyTable More information about using ...


2

Ubuntu already comes with a brilliant language input tool called iBus 1) Open Terminal and run: sudo apt-get install ibus-m17n This will install, keyboard layout schemes for Asian languages. 2) Now you need to logout from the system & login back. (Or simply restart) 3) Click on the language applet at top right side of the sceen, and ...


2

First remove all the said scim pacakages, im-config. Install the "ibus" ,"Adjust methods for keyboard input"tools. Make sure to install the following pakages ibus-m17n ibus-table-extraphrase ibus-gtk ibus-gtk3 ibus-qt4 ibus-table ibus-clutter Choose the input method switch and make ibus as the choice. A dialalogue box to restart X session appears ...


2

The apps started over X will be killed if you restart X. You cannot avoid that.


2

I'm pretty new to using IME for Japanese myself. Like you, I've been studying Japanese but have little experience with IME's yet (except on Windo$e hehe). But I found this link to be a good starting point for some research into the matter. I haven't had much luck finding a straight up comparison myself, yet but I'll check back here and let you know if I find ...


2

OK, I started to figure it out. Part of it was related to installation issues. Mainly, a logout is required before the IME is functional! How to completely uninstall/disable Korean input: I uninstalled Nabi the same way I installed it: via Ubuntu Software Center. Languages can be enabled/disabled via "System Settings" > "Language Support". How to identify ...


2

Please type the following in terminal: sudo apt-get install ibus-m17n


2

Installing ibus-qt4, then logging out and back in fixed it for me. I also found this thread: https://bbs.archlinux.org/viewtopic.php?id=111087


2

Install the package iBus from the kubuntu repository, info here: http://code.google.com/p/ibus/. This is just an input method and doesn't change your system settings. for pinyin input install ibus-pinyin for handwriting recognition install ibus-tegaki the fonts are available from the package language-pack-kde-zh-hans Afterwards go to your system ...


2

You may want to take a look here: http://code.google.com/p/ibus/wiki I had exactly same problem as Yours but thanks to Your post and webmarwells reply I have found solution :) Was missing also the trigger to actually start input of pinyin. So after playing with ibus-setup etc, I did: sudo apt-get update sudo apt-get install ibus-gtk ibus-qt4 ...


2

Install Input Method Switcher from Software Center and select ibus as the default method for your locale. I also had the same problem with the Greek language and this solved it. Or from terminal use the command "im-switch -s ibus", after installing of course the package "im-switch"


2

I think a better way of enabling ibus should be the following im-switch -s ibus There is no need to manually add startup entry for ibus-daemon


1

Am using Ubuntu 12.04 with ibus 1.4.1. Once I setup the input methods, they stay across reboots and are working fine. Is the ibus-daemon running after your reboots? $ ibus-daemon current session already has an ibus-daemon Did you make sure you are in an editable environment (somewhere you can type) when checking if the input methods are available? ...


1

Open Keyboard Input methods and go to Advanced tab. Select the checkbox next to Share the same input method among all applications. You should now be able to type in Tamil in both Gedit and LibreOffice Writer at the same time. If you don't want to use the same input method across all applications, one simple solution would be to just momentarily the ...


1

Open the Keybord Input Methods settings application. Wait for the settings window to appear. In the "Font and Style" section of the "General" tab, enable the "Use a custom font" checkbox. You can then change the typeface and size of the input preview font with the button to the right.


1

As stated by @von, you CANNOT use your .XCompose with IBUS for now. You can use uim as Input Method, which supports Unicode, both GTK+ and Qt immodules with legacy XIM support. A good way to handle your .XCompose and keep existing global Compose is: Install uim: sudo apt-get install uim Make it the default Input Method: im-config -n uim Edit your ...


1

I think what you are looking for is in the Unicode composition section of the Ubuntu documentation for the ComposeKey. The next bit is based on the instructions in that section. Another means to enter non-keycap characters is to enter them as a Unicode character number. Press ShiftCtrl+U. Release U while continuing to hold down ShiftCtrl. Enter the ...


1

No, this hasn't changed in gtk+ 3. Back in 2001, a bug was reported that dropdown comboboxes couldn't be navigated using the keyboard (even the arrow keys and Enter). All parts of this bug were fixed except the part about typing text while the combobox has focus and having the list select the correct item alphabetically. More recently, a new bug was filed ...


1

Mozc can be used by QT applications, if you will install ibus-qt4 : sudo apt-get install ibus-qt4 and an environment variable will be changed by using this comannd : export QT_IM_MODULE=ibus If you want to set up this to an global environment variable, describes as follows to ~/.xprofile. export GTK_IM_MODULE=ibus export XMODIFIERS=@im=ibus export ...


1

In the Character Map, you can type (or paste) the letter β into the input field at the bottom and then double click the combining character. β̂ However, you can pretty much assume that this won't get rendered correctly. It looks good in Inkscape.


1

ibus-m17n and ibus-anthy both provide BoPoMoFo input methods. Ibus input methods are for both traditional and simplified characters. To switch, you need to show the language panel. Right click the Ibus indicator on the menubar >> Choose Preferences. In the Preferences dialog, change the Show language panel setting from the default Embedded in menu to ...



Only top voted, non community-wiki answers of a minimum length are eligible