Tag Info

Hot answers tagged

11

Original Solution Go to Realtek official site, accept the disclaimer, then download the audio driver for linux/unix. You need to select version 3 for Kernel 3 or later. Setup necessary tools to compile this driver. sudo apt-get install build-essential gcc make Extract the downloaded file, run sudo ./install file from a terminal after going to the ...


7

We have the optional application paprefs that allows to install a virtual output device to pulseaudio. This enables simultaneous output to all attached sound cards/devices: The additionally created audio output device for simultaneous output may be selected in the "Output" tab from pulseaudio sound preferences menu: From the command line we can also ...


5

I also had this problem on my hp laptop. I found a post and take one of the advice, which suggests adding two lines to the bottom of the file /etc/modprobe.d/alsa-base.conf : options snd-hda-intel model=laptop options snd-hda-intel position_fix=1 enable=yes save it and reboot. It works for me!


5

I placed: options snd-hda-intel model=hp-dv5 options snd_hda_intel model=hp-dv5 In my /etc/modprobe.d/alsa-base.conf I don't know which syntax is the correct one, but I left them both in for good measure. I did NOT restore my heaphones option, however it did mute the speakers when I plugged in my headphones and that was good enough for me.


4

I posted the same question on Launchpad. Here was the answer I received from Mark Rijckenberg: Please run the following command in a Terminal session: gksudo gedit /etc/modprobe.d/alsa-base.conf Using the gedit editor, add this line in the /etc/modprobe.d/alsa-base.conf file: options snd-hda-intel model=dell-m6-dmic Save the change, ...


4

This is a pulseaudio bug, still present on 11.10 As a workaround edit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf : gksu gedit analog-output-headphones.conf Than search for and comment this line like here: [Jack_InputDevice] #code = Headphone Save the file and close gedit. Than restart pulseaudio with: pulseaudio -k Most ...


4

I know that some bluetooth devices will not connect with a phone I used to have. There seems to be some incompatibilities between different BT devices, and there is not much that could be done there. So far, Bluetooth was more trouble that it was worth it. I also had issues with such keyboards that would always disconnect. I know this is not the answer you ...


4

I had the same issue. It appears that the new kernel did not correctly detect the sound card model that you have. You will have to edit the /etc/modprobe.d/alsa-base.conf file and set the model manually with options snd-hda-intel model=<model> Unfortunately, finding the correct sound card model can take a little guess work. I took me several tries ...


3

During the UDS for Oneiric there has been a session about jack detection. See the blueprint for details. It sounds like this will exactly do what I'm looking for: different volume levels for different devices - just not on every hardware: <htorque> something i'm curious about: will i be able to have different volume levels for different devices (eg., ...


3

As far as I know PulseAudio is an audio server with the ability to route sound in the way you want. Install PulseAudio Volume Control to be able to change where inputs and outputs go. sudo apt-get install pavucontrol In this manner I have routed Skype output to my headset only and my mic solely into Skype, Whilst having everything else running through ...


3

I experienced the same problem and I have written a post about the solution I found here. Basically what I did was this: Open the file /etc/pulse/default.pa by typing the following in a terminal: gksudo gedit /etc/pulse/default.pa Change the line that says load-module module-udev-detect into load-module module-udev-detect ignore_dB=1 Save and close ...


3

Unable to add comments; so here is an "answer" that is partially a question (I'll might delete it): On my install I sometimes have an issue with this and to resolve it I go into sound settings and select "Output volume" to OFF then ON and sound gets OK. Edit: Have you tried sudo apt-get install pavucontrol Run pavucontrol and check settings. I.e. ...


3

In a terminal execute alsamixer then with the arrow keys go to the column "Auto-Mute", once selected set with the up arrow the option "Enabled". Seems like the interface to my alsamixer is a bit different, but using the M key on my speaker changed a previously mysterious (grey-ed out) MM to ungreyed out 00 and re-enabled the speaker. The secret was ...


3

As ALC1200 and ALC888 seem to be very similar (see this German Wiki Entry) you can try my solution for the Intel HDA ALC1200 on my Acer Aspire 5920 G laptop. After upgrading to Ubuntu 12.04 Precise Pangolin from 11.10 my speakers continued to output the sound when plugging in headphones. In 11.10 the speakers were muted automatically when a headphone was ...


3

I found a solution that works here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/921397/comments/9 You can also see the whole discussion regarding this bug here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/921397 To summarize: Edit sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf and modify the ...


3

In a terminal, reinstall alsa-base and pulseaudio, following next steps: Remove alsa-base and pulseaudio: sudo apt-get remove --purge alsa-base pulseaudio Reinstall alsa-base and pulseaudio: sudo apt-get install alsa-base pulseaudio For them to load: sudo alsa force-reload


3

I don't have a full and fool-proof solution that I can offer, but I do know that this happens with some hardware, where the headphone jack sense is "muted" by ALSA. To turn it back on, you can use alsamixer: My screenshot does not display the option for headphone jack sense because my card does not support it, but it is similar to the S/PDIF option. ...


3

I would first check to see if Ubuntu is detecting both (Headphones and Speakers) in the system settings: If you see something like one the following images, then you know both were detected: In my case I have support for my headphones and my stereo output. If in one case I would like to disable sound for the speaker, I would first select the output I ...


3

There is no sound card generally available for PCs that detects the change in resistance caused by such a button press (certainly not anything AC97-based), so this won't work with desktop apps. But the kernel support for the most part is there though.


3

A friend of mine has a dv6-2153el, and he solved this problem running echo "options snd-hda-intel model=hp-dv5" | sudo tee /etc/modprobe.d/snd-hda-intel.conf then rebooting. If this doesn't work for you, you can undo with rm /etc/modprobe.d/snd-hda-intel.conf


3

First, use alsamixer to find out which mixer controls must be changed to get the desired effect. Then write a script that runs amixer to set those controls. For example: amixer set "Headphone" mute amixer set "Speaker" unmute In this case, it's likely that you also need to disable Auto-Mute Mode.


2

I have had this problem on my Asus K55vm laptop since 12.04. Although your solution does work, in laptops it will cause the sound to be transmitted by both the plugged headphones and the speakers. To make them work properly and only have sound come out of the headphones when plugged in or the speakers when headphones are not plugged in: Run in terminal: ...


2

I don't have a system which I can test this out on, but I believe this section from the Arch Linux PulseAudio website should help you: https://wiki.archlinux.org/index.php/PulseAudio/Examples#Splitting_front.2Frear To sum up what you should do: Open a terminal and make a back up of /etc/pulse/default.pa like this: cp /etc/pulse/default.pa ...


2

Have you tried this? echo "options snd-hda-intel model=asus" | sudo tee -a /etc/modprobe.d/alsa-base.conf Source: http://ubuntuforums.org/showthread.php?t=2022151


2

I've figured out how to set up IceCast2 for the master and stream from there, but the latency is far too much (roughly 7s what I've measured). So this isn't going to work. If someone knows a way to do something like this with much lower latency (at the very least <1s, but something like 100ms is more reasonable), that would be a solution.


2

Pulseaudio always tries to switch to a newly available audio port when it becomes available. To stop this we can edit our default.pa. This file is located in /etc/pulse (defining settings for all users) or in ~/.pulse (to override these settings for a single user). Just comment out this line to stop pulseaudio from switching ports as follows: # load-module ...


2

I don't know how much coding experience you have, but you mentioned inotifywait so I'm going to assume you're at least comfortable with shell scripting. The following C program, based on this article, should be able to detect your headphones being plugged or unplugged, after which you can perform whatever actions you want. #include <linux/input.h> ...


2

I was having the same problem... I updated from Ubuntu 11.10 to 12.04 and my frontpanel stoped working. The sound was only coming out from the rear panel. I opened the terminal, typed alsamixer and pressed ENTER Inside the Alsa mixer, I pressed right arrow until I get to an option called "Loopback Mixing". It was disabled... Enabling it solved my problem. ...


2

I have the same computer as you. I even had the same problem with the audio playing out of the headphones and the speakers! I looked everywhere for a fix and kept coming up short in my search for an actual solution. I finally found it. Short answer if you have an HP Pavilion dv6-2155dx all you have to do is this. In terminal type or paste: gksudo gedit ...


2

Open up a terminal and enter alsamixer. Navigate with the left and right arrows, unmute by pressing m and change the volume by using up or down. Out of all of the solutions I have tried this is the only one that worked on my Intel® Core™2 CPU T7600 @ 2.33GHz × 2 Macbook Pro. And it is so easy to do!



Only top voted, non community-wiki answers of a minimum length are eligible