Tag Info

Hot answers tagged

45

Both packages provide the same application, but compiled with different dependencies (e.g. vim-gnome depends on libgnome2). Vim-gtk is important only to people who use Kubuntu (or some lightweight desktop environment) and don't want to install GNOME libraries. If you use the standard Ubuntu desktop, the dependencies are already present, and you can safely ...


33

Solution 1: Make the global menu for gvim work To get global menu for gvim and to get rid of the warning message, add this to ~/.bashrc and restart the terminal: function gvim () { (/usr/bin/gvim -f "$@" &) } Solution 2: Disable global menu for gvim To just get rid of the warning message, you can disable the global menu, at least for gvim: How do ...


16

For gEdit there does not seem to be a way to disable having a newline inserted at the end. However, for Vim (and gVim ) you can - by executing the following option: :set binary. Setting to binary will save the file as is and not insert a newline at the end of the document (Unless there already is one, in which it will be retained). At anytime you can ...


14

Close. Set the font through the gui, then use the command (: to get the prompt) set gfn? to get the current font string. It should look something like this: guifont=Mono Uralic 10 Then edit/create ~/.gvimrc and add the line: set gfn=Mono\ Uralic\ 10 Note: You need to escape the spaces from the output (as I have above)


12

Besides the vim package, there appear to be at least six "vim-variants"(not including available documentation, or plugin packages) to be found within the main and universe repositories. Below is a brief summary of each(links go to package description and dependencies): jvim-canna - Japanized VIM (Canna version) This package allows the entering of Kanji ...


8

Everyone else has excellent advice, I thought I'd fill in with some of the basics: 1. GVim for vim outside the console, and how to install it You asked whether vim can only be run from the console. GVim (GUI-Vim) is the standalone version. From your screenshot, it looks like you're using Ubuntu, you can find gvim in the Software Centre and install it from ...


7

I'd suggest you start studying .vimrc's just like the one above. Everyone's needs and preferences are different so you should denfinitely go with manually installing stuff instead of just copying someone elses configurations. Some resources about learning VIM itself: Learn Vim Progressively, a great guide about learning Vim. Vim Novice Tutorials, a series ...


7

It is a known issue. The workaround is mentioned in the gnome-look.org Faenza page: Some applications are configured to always use the same icon regardless of the selected theme: e.g. vim, emacs23, gcolor2, bluefish, hardinfo, defcon, gufw, pithos, goldendict, rssowl, picasa, netbeans, gazpacho. To display the Faenza icon, edit as root the ...


7

I assume you mean you want to change the editor that Quickly loads when you ask it to. Well I did some sleuthing... I'll show you what I did followed by the answer. I fired off this command: sudo find / -name "*quickly*" -exec grep gedit {} \; That searches for all files with quickly in and then greps them for gedit. It was a long shot -- I should have ...


5

There is a workaround here: https://bugs.launchpad.net/ubuntu/+source/vim/+bug/776499 Create an alias at the top of your shell init file (e.g. ~/.bashrc): alias gvim="UBUNTU_MENUPROXY=0 gvim"


4

This should work (thanks @Braiam): UBUNTU_MENUPROXY=0 gvim Running the above command from a terminal will launch a gvim instance with its own menus. So, to create a launcher on your desktop, open a file called ~/Desktop/gvim.desktop with the following contents: [Desktop Entry] Name=gvim Comment=Run gvim with menus Exec=env ...


4

I'm also seeing this delay with gvim and rox-filer on 12.04. I added scim recently so that I could use chinese input. I have a little keyboard icon in my tray whose about box tells me is IBus 1.4.1. Selecting 'quit' off that same menu (so that the keyboard icon disappears) gives me instant gvim startup again. Starting ibus-daemon again (by "ibus-daemon -d"), ...


4

The EASIEST way for you to do this would be to install the program Ubuntu Tweak, this can be downloaded from here: Ubuntu Tweak Download Instructions Once you have it downloaded you simply open it up, change to Admins tab and then under System choose File Type Manager. Once in here select the file category Text and using shift-click and/or control-click ...


4

Ok so setting this in my .gtkrc-2.0 alleviates the problem: style "vimfix" { bg[NORMAL] = "#242424" # this matches my gvim theme 'Normal' bg color. } widget "vim-main-window.*GtkForm" style "vimfix" Screenshot: This still doesn't fix the resize triangle in the lower right.


4

Make a file called ~/.local/share/applications/gvim.desktop and copy the following into it: [Desktop Entry] Name=gvim GenericName=Text Editor Comment=Edit text files Keywords=Plaintext;Write; Exec=gvim %U Terminal=false Type=Application MimeType=text/plain; Icon=gvim Categories=Utility;TextEditor; It should now be in the applications list and you can add ...


4

Update: I searched a bit and found that you can use any monospaced font in vim but if you choose a non-monospaced font, the results will be ugly because vim has a fixed character cell. So, you can't use Devanagari fonts in gvim. It seems to me that gVim treats every font as monospaced and that is creating the problem. You can try other editors which can ...


3

Run the following commands in the terminal. sudo apt-get build-dep vim-gnome to get all the build dependencies you need. Then sudo apt-get install mercurial to get the Mercurial version control system needed to download the latest Vim source code. Then hg clone https://vim.googlecode.com/hg/ vim to download the Vim source code to the subdirectory ...


3

I found a workaround at this blog. Using gvim -f doesn't have this problem, apparently, so aliasing gvim to setsid /usr/bin/gvim -f works. For bash, you can put gvim(){ setsid /usr/bin/gvim -f "$@"; } in your .bashrc.


3

I'm not quite sure about that error message but seems like your vimrc file cannot find your colorscheme. Have you tried using color scheme from your home folder ?(/home/your_home_folder/.vim/colors/ir_black.vim) If you have some colorscheme files in that folder then you can activate from edit->ColorScheme->ir_black. If you want "ir_black" as your ...


3

iconv is probably what you'll want to use. iconv -l will show you the available encodings and then you can use a couple of commands to recode them all: # all text files are in ./originals/ # new files will be written to ./newversions/ mkdir -p newversions cd originals for file in *.txt; do cat $file | iconv -f ASCII -t utf-8 > ../newversions/$file; ...


2

It's "+y, not +y The "+ prefixes tell vim to use the X11 clipboard instead of vim's internal clipboard. You only need them if you want to exchange text with other programs. Usually you can just use y to yank the marked text (if you are in visual mode) or append some move commands to yank a text range, like y2w to yank the next two words. Then use p or gP ...


2

You'll need to check your sources. I see that libruby1.8 1.8.7.352-2 is available through main while it seems that the newest version you have is: 1.8.6.111-2ubuntu1. This probably means that you dist-upgrade failed or that you still need to update your sources. $ apt-cache policy libruby1.8 libruby1.8: Installed: 1.8.7.352-2 Candidate: 1.8.7.352-2 ...


2

It's a bug in gtk2 (gnome bugzilla, launchpad). Unfortunately, as you can see in the gnome bug report, gnome developers are no longer supporting gtk2, and the tear-off menu is a deprecated feature in gtk3. This means the bug is unlikely to be resolved upstream. The author of vim is aware of the issue, so I'd expect it to be resolved in a future version of ...


2

When you launch gvim, it uses your current directory as its current directory. You could change how you launch it by using a longer command or a small script like #!/bin/sh cd $HOME gvim "$@" Or you set vim to always change its current directory by adding cd $HOME/Desktop to your .vimrc file.


2

Try another font. http://vim.wikia.com/wiki/Change_font: In gvim, you can change the font using the Edit menu, Select Font. An alternative is to enter the command: :set guifont=* Once you have a font you like, you want to make it the default in the future. Do :set guifont? and Vim will display something like guifont=Lucida_Console:h11 ...


2

This seems to be mostly expected behaviour. When ibus is active and one, say, moves up to the menu or exits input mode, ibus switches to input method off since it no longer sees a gui element with focus and where entering text is possible. The error message you saw ("no focused input context") is consistent with this. Ibus stays on when you go back to the ...


2

Yes, this is possible with vim's server mode. Start a vim-server with: vim --servername somename Now you can send commands to it with --remote, --remote-send and others. To achieve what you want, start a server with a known name, send the :tabe commands with: vim --servername somename --remote-send ':tabe filename<cr>' Note the same commands ...


2

Okay, I guess the instructions that I read for vim server were not accurate. After digging a bit more into it, I found a line that works. I Initialized a vim server with the following command in terminal: vim --servername LSLEditor And then in the Second Life viewer external editor text I put: /usr/bin/X11/vim --servername LSLEditor --remote-tab "%s" ...


2

speaking about how things works globally, for the entire system, the most important thing is /usr/share/gnome/applications/defaults.list which is the file that holds the associations between a given mime type and the application that is supposed to handle that kind of file. If you don't know the mime type of a file simply use the command mimetype like ...


1

Try to remove "vim-common": $ sudo apt-get autoremove vim-common And then install "vim" with: $ sudo apt-get install vim This will install correct version of "vim-common", and later you can install GVim through the software package manager.



Only top voted, non community-wiki answers of a minimum length are eligible