Hot answers tagged

7

To achieve this we will edit nautilus.css. We will do this for the current user and not system-wide. Copying your theme to your home folder Open a terminal: mkdir ~/.themes/ cp -R /usr/share/themes/Ambiance/ ~/.themes/ (if you are not using the Ambiance theme (default), you will need to adapt the last command) Editing nautilus.css In a terminal open ...


5

This is a known issue. This theme doesn't support Ubuntu 14.04, because its GTK version (3.10) is too old. I'm working on GTK 3.14 support, which will make the theme compatible with Ubuntu 15.04. I'm sorry about this, but I don't have enough resources to backport the theme to older GTK versions. Source: https://github.com/horst3180/Arc-theme/issues/7 ...


5

As described here: As a workaround to fix the background transparency issue (#169), I've edited the .desktop file so that the Corebird window will use the old fat scroll bars instead of the Overlay scroll bars. Therefore use another PPA or upgrade the installed version of Corebird sudo apt-add-repository ppa:ubuntuhandbook1/corebird sudo apt-get ...


5

Create a splash window You can use GTK's gtk_window_set_decorated() to create a splash window without (any) decorations. Combined with gtk_window_set_position(), you can pretty much create a custom splash screen. An example (script1, the splash window): #!/usr/bin/env python3 from gi.repository import Gtk, Gdk, Pango class Splash(Gtk.Window): def ...


4

Since VTE 0.38, vte_terminal_fork_command_full () has been renamed to vte_terminal_spawn_sync (). So if you are using newer versions, you have to change @ADcomp's answer into the following: terminal.spawn_sync( Vte.PtyFlags.DEFAULT, os.environ['HOME'], ["/bin/sh"], [], GLib.SpawnFlags.DO_NOT_REAP_CHILD, None, None, )


3

My solution was to change tools, xdotool works fine. This seems because GTK3 has switched to X Input 2.0 which xvkbd does not support. My new key bindings are: xdotool key "Return" xdotool key "Control_L+u" Which replace: xvkbd -xsendevent -text "\r" xvkbd -xsendevent -text "\Cu"


3

I have struggled with this issue in a few cases, and found that calendars are usually not displaying the expected language in case of a mixed locale. I'm not 100% sure as regards Ubuntu GNOME, but assuming that you want to keep Polish formats for other aspects (number formats, currency symbol, etc.), you may want to add this line to your ~/.profile file: ...


3

They are different ABI versions of GTK+. As mentioned in comments, some things still require GTK+ 2.x, and haven't been ported to GTK+ 3.x. Likewise, you may have both Qt 4.x and 5.x installed, as different applications require different versions.


2

After working around for hours with help of theme developer I finally came up with a solution for Nautilus, so to change background entry color when renaming a folder or a file you need to create a small code inside theme folder exactly at: sudo gedit /usr/share/themes/name-of-the-theme/gtk-3.0/nautilus-entry-section.css and paste this code: ...


2

I found what was wrong. I had previously tried to build from source the latest version of Glade 3.18.3. But that required my gtk to be be 3.12.0 . But my gtk was 3.10.0 and that seemed to be the latest version acquirable through apt-get install. So I downloaded the source of the actual latest version 3.12.2 and built that from source and executed a make ...


2

Most likely you following a PyGtk 2 guide when trying to implement this: According to the GTK 3 documentation there is no function named gtk_window_add_accelerator, but there is a function named gtk_accel_group_connect that looks like its going to get the job done. When working with GTK documentation it's usually 80% gut feeling and 20% checking the docs to ...


2

You need the development packages, they should be available in 14.04 from the trusty main repository. Try running: sudo apt-get install libgtk2.0-dev


2

Create a copy of your theme in ~/.themes, e.g. for the Ambiance theme cp -r /usr/share/themes/Ambiance/ ~/.themes sudo chown -R $USER:$USER ~/.themes And customize ~/.themes/Ambiance/gtk-3.0/gtk-main.css Start gnome-tweak-tool and select your theme.


1

First, make sure the needed GTK engines are installed. sudo apt-get install gtk2-engines-murrine If that works after restarting the shell (Alt+F2 & r & Enter), great! Otherwise, disable the theme for now and continue. You can then install it from source if needed to get the latest version: By using the package from here or the repoistory here. ...


1

Install the development libraries: sudo apt-get install libgtk-3-dev and compile your code with (replace test.c with your file name): gcc test.c -export-dynamic `pkg-config --cflags --libs gtk+-3.0` -o test and run with ./test


1

The GNOME Headerbars are themed using the GTK+ Theme and Icon Set that you have applied on the desktop environment your using, so to change the theme and icons on GTK+ Headerbars, you'll need to use a Tweak Tool e.g: unity-tweak-tool to be able to change the theme. Once there, select a GTK Theme of your choice and the headerbars' look will change in rhythm ...


1

Method 1: Enable the shortcut: Install dconf-editor with sudo apt-get install dconf-editor Navigate to org > gtk > settings > debug Set enable-inspector-keybinding to true I don't know if is necessary to reboot, but I recommend to do it (or at least log out/in). Try the shortcut. Method 2: Run the program to debug with the GTK_DEBUG variable: ...


1

You could try pastebinit, you'll get a link to open the json file in your browser: sudo apt-get install pastebinit cat data.json | pastebinit -b http://paste.ubuntu.com


1

Umm it seems you can't: I'm still searching for another solution... gsettings has a nautilus config line (among others): org.gnome.nautilus.icon-view captions and has the value ['none', 'size', 'date_modified'] I tried changing this to include type: ['none', 'size', 'date_modified', 'type'] but it still didn't work. I'm not sure how it can be ...


1

As @xangua pointed out, pantheon-terminal is using the new "header bars" client-side decoration component of GTK. Unity in Ubuntu 15.04 doesn't appear to support this. An unofficial workaround for the issue I experienced is to disable client-side decorations for the affected app: sudo add-apt-repository ppa:nilarimogard/webupd8 sudo apt-get update sudo ...


1

The last section of your log is the one that will help you to find the packages to install as debian packages are not (always) exactly named as stated in the error logs. So you have to install: I: No native package found for espeak (/usr/include/espeak/speak_lib.h) I: No native package found for mpfr (/usr/include/mpfr.h) I: No native package found for ...


1

Another way that I use personally is apt-file sudo apt-get install apt-file apt-file update Now you can search the packages for the missing files, eg: % apt-file search /usr/include/sasl/sasl.h libsasl2-dev: /usr/include/sasl/sasl.h therefore: sudo apt-get install libsasl2-dev Or another example % apt-file search /usr/bin/cups-config libcups2-dev: ...


1

You need GNOME >= 3.15 and the development libraries of libdbus-1 sudo apt-get install libdbus-1-dev



Only top voted, non community-wiki answers of a minimum length are eligible