Tag Info

New answers tagged

0

The 1 mb bios_grub partition is for bios booting, not efi. For EFI, you need one disk to have a 100 mb fat32 partition flagged as bootable and mounted to /boot/efi. You do not need a /boot partition at all, so you just need two partitions on each disk, combined into two raid arrays, one for / and one for swap. The server installer should set this all up ...


0

This will only work if Windows still is installed. If you deleted Windows when installing Ubuntu, you will have to reinstall Windows. Boot Ubuntu, open a terminal. $ df -h In the column "mounted on" there is one entry with only a slash (/). Look at what's in the "filesystem" column of that row. It's something like /dev/sda6 or /dev/sda1. Then enter ...


0

The 'main partition' referred in this answer is the partition on which your Ubuntu is installed. It is the one you mount as file system root (/ directory) when you boot Ubuntu normally. So yes, in your case it would be /dev/sda2. Your other option was to use boot repair instead of manually reinstalling GRUB. Probably you forgot to install the PPA (sudo ...


0

Forgive me if I'm wrong, but if /dev/sda1 is already mounted at /boot, wouldnt you get a redundant /boot in your path when you're also specifying it in the $isofile variable? I think GRUB is looking for the image in /boot/boot/, so maybe try changing to: set isofile="ubuntu-14.10-desktop-amd64.iso"


0

I can see that you don't have an UEFI boot partition, but I don't like the "unknown" partition, so the easiest thing to do for you now is: Boot an Ubuntu LiveDVD Make a full system backup and a data backup! re-install Windows using 2 drives: a 64 GB System drive and a ensuring it only takes maximum 180 GB Data drive Re-install Ubuntu and create a 32 GB /, ...


1

Here are the key steps and information bits to get an HP laptop to dual boot between Windows 8/8.1 and Ubuntu 14.04.02. This laptop is a pretty modern Pavilion g7-2215dx. The BIOS of this laptop (and probably most modern HP laptops) has a UEFI boot menu that you can access by pressing ESC and then F9 when that menu shows up. This menu DOES PROPERLY WORK ...


0

It's critical to know if you're booting in BIOS mode or in EFI mode. Boot to Linux and type the following commands (shown here with possible outputs): $ sudo parted /dev/sda print | grep Table Partition Table: gpt $ ls /sys/firmware/ acpi efi memmap The first command reveals (by proxy) your Windows boot mode. (Note that this assumes you've got one disk, ...


1

With two installs you have to normally do two updates. Whichever system's grub is in MBR must be booted and sudo update-grub run to find newer kernel in second install. But since you have two drives, put main working install's grub into the MBR of sdb. And keep test install's grub in MBR of sda. When you install grub defaults to sda. Better to use Something ...


0

When your machine boots, on the BIOS splash screen , just go to the BIOS boot menu (which is different from the BIOS menu) and choose USB. The PC will then just boot from the USB stick... (As you didn't specify the exact machine and BIOS version, I can't look it up and tell you, but on most machines it's F9 or F12)


0

OK, got this working. No translation of the partition numbering is needed at all - logical partitions starting at #5. Therefore, the correct entry looks like this: menuentry "Work" { insmod part_msdos insmod ntfs set root='(/dev/mapper/isw_hjcbchkb)' parttool (hd0,1) hidden- parttool (hd0,2) hidden+ parttool (hd0,5) hidden- ...


0

Have you tried update-grub , if not open a terminal (CTRL+ALT+T) and type sudo update-grub and restart. If the issue is still there try clearing cmos. ( with jumper resetting ) And it should work.


0

I found something that worked. I plugged an old PS2 keyboard into my computer and everything returned to normal. I dont know why or how, but Bios/motherboard/grub seems to treat PS2 keyboard differently than USB keyboard.


0

Try this: At boot time choose to go to recovery mode in the GRUB menu. Then choose to repair filesystems, when it finishes then reboot. Now you'll see booting will be fine until sooner or later it'll happen again and then you've to repeat the procedure. If you're a little more into tinkering with your computer try to install the newest kernel from: ...


0

Very late answer but in case anyone ever runs into this type of problem again you can type "fwsetup" into the Grub Bootloader Rescue text terminal and then enter the BIOS through that command.


0

I solved the problem using the Lenovo One Key recovery software from within my Windows 8 OS after entering my UEFI firmware settings and moving the GRUB Boot Loader down the list behind Windows Boot Manager.


0

The suggested actions at the bottom of the Boot-Repair script actually look like the right thing to do here, but you said it got stuck, so we'll need to look for a manual solution. The Grub boot loader appears to be alive and well, but the boot menu has no entries, so you'll need to follow the instructions of this answer to repopulate it. Check the output ...


0

I'm not entirely sure about the reasons, but currently (with the fully updated packages), the issue is gone. It was most likely a bug in one of the packages (perhaps some incompatibility related to the third party drivers). If anyone is still having the problem, just try updating all the packages.


0

Have you tried using the lts-utopic d-i images linked from http://cdimage.ubuntu.com/netboot/trusty/ rather than trying to hack it up in a preseed from a d-i booting with 3.13?


1

For EFI booting move all MS content under /EFI to another folder, call it /EFI.ms for example, with BOOT and Microsoft subfolders; this is to disallow certain UEFI firmwares to force boot Windows when they see it. Now under the EFI folder copy the BOOT and Ubuntu folders created for your bootable stick. Under /EFI/Ubuntu append this menu entry to the file ...


0

You should have a Ubuntu folder inside Windows. Maybe you can use a USB stick with ubuntu to boot your system so you can see the files inside that folder. IMHO you should install ubuntu properlly because wubi is not a good solution. See this link Installation from USB stick Or you can try this: How to restore the wubi ubuntu bootloader


0

Short of entirely encrypting your root partition (with a separate boot partition obviously) there's very little you could do to prevent an attack by someone who has physical access to your system. Physical access==root access.


1

If the attacker has physical access to system, which they need to change the kernel parameters, it's a lost cause without encryption. However, I guess you can limit that particular method (init=/arbitrary/command), by commenting out these lines in the kernel source, and compiling your own kernel: if (execute_command) { ret = ...


0

If they are both booting to the same OS then I don't see a huge problem, my solution simply involves editing the grub menu in order to get rid of the other option. First of I would check your grub.cfg file. This can be accessed typically via the following commands: cd /boot/grub/ **insert favorite text editor here** grub.cfg (you may need root access to ...


0

My recommended solution is: Download the USB flash drive or CD-R version of my rEFInd boot manager. Prepare a boot medium from this download. If it's not already disabled, disable Secure Boot. (You can re-enable it later, if you like, although you'll probably need to jump through some extra hoops to do so.) Boot rEFInd. You should see at least one option ...


0

The warnings and errors concerning a corrupt/invalid GPT (GUID partition table) pertain to a 2 GiB drive, so probably neither the hard drive nor the SSD, and can be safely ignored. Unfortunately that doesn't explain why Boot-Repair doesn't fix the boot loader. To resolve your issue, I recommend a manual re-installation of Grub, which will be slightly more ...


0

Do you use Windows 8.1 or 8 ? Because Windows 8.1 is the worsе edition of Windows I'd ever tried. It doesn't support many useful programs of Windows 8 and Windows 7 (You can just emulate Win 7 and 8, but as you know, it very bad affects to the perfomance). It doesn't work "very well". And the second possible problem is in repairing of grub. In your BIOS, ...


0

If you are trying to boot from a flash drive then you probably don't want to load the grub menu at all. Instead you can just put the USB higher in the boot order than the HDD and then boot directly off the USB drive. When you first turn the machine on there should be a manufacturer screen that lists a setup keys. Press this key to enter the bios. In the ...


1

The correct syntax is to use an x: widthxheightxdepth Interestingly, at the top of the file it mention a command to get help with this file :) info -f grub -n 'Simple configuration' This command will give you the following information at 15.1.10: There is also web documentation in HTML format. About the depth value, as long as it is an integer ...


0

Use your Ubuntu CD Live and launch a terminal console where you are going to type these commands: sudo su [Enter] gparted [Enter] Take a picture of gparted and post the link to the image (for privileges reasons in this forum you can not include an image directly in your post). We will see if you still have a Windows 7 partition in your hard disk drive. If ...


0

Try to press f9 Immediately on boot...It would take you to the EFI Bios boot screen, See if "OS Boot Manager" is an option there, and if it boots. There is also the option of Manually selecting an EFI file Use it to browse the EFI System Partition to locate the EFI files with the .EFI extension and try to boot from it.


0

Make sure you set both GRUB_TIMEOUT_STYLE and GRUB_TIMEOUT. Finally, make sure you run sudo update-grub after editing Grub. If the GRUB_TIMEOUT_STYLE option is set to menu, then GRUB will display the menu and then wait for the timeout set by GRUB_TIMEOUT. Make a backup... cp /etc/default/grub ~/grub.original Edit Grub with a text editor. gksudo gedit ...


2

Since the automatic ways aren't working, I tried googling for "manually add windows to grub" and found this. The linked answer suggests the following: The first step is to edit /etc/grub.d/40_custom (using SUDO) and add the following lines to the bottom of the file: menuentry ‘Windows 7′ { set root='(hd0,msdos2)’ chainloader +1 } Then running sudo ...


-1

You can use BIOS to select other HDD as primary, then install Ubuntu on it. Then from BIOS you can easily switch in between HDDs and boot into Windows or linux


0

If you have a laptop and your Windows is preintalled, you need to enable in bios "UEFI Boot". All the good!


0

The easiest way to accomplish this is to: boot with the Windows 8 repair disk repair sda Use the BIOS to boot.


0

You can copy all the ISO contents to the flash drive and make it bootable. So, first of all, install GParted from software center or from terminal: sudo apt-get install gparted Then, open it from dash or terminal: gksudo gparted After that, choose the flash drive from the menu in top right corner. There should be one partition. If you haven't ...


0

If you weren't sure, then how can you say that the dd method worked? Also, that ain't the way. You have to use Rufus to make the USB drive bootable;not that I discourage the dd practices, since it is Windows we are talking about, I believe it is best to use Rufus to handle this for you. If you have a Windows installation already, then boot into it and ...


0

What I have done is: mounted root.disk to /dev/1 modified ro to rw in /dev/1/boot/grub/grub.cfg reboot successfully loaded Ubuntu Details: sudo mkdir /dev/1 sudo mount -t ext4 -o loop /host/ubuntu/disks/root.disk /dev/1 sudo vi /dev/1/boot/grub/grb.cfg replace the ro to rw in lines which looks like linux /vmlinuz-2.6.28-13-generic ...


0

Windows always needs to be installed on the first partition of the first drive of the computer... (and that's what you get from a near-monopoly) So you need to install Windows first and then Ubuntu. :-(


0

Have a look at this post: How to Install Ubuntu 14.04 with RAID 1 using desktop installer? It worked for me. For those who want to use the RAID array only for storage (for example, only for the /home file), you can use the graphical installer, install GRUB on the device with / and the swap, provided this one is not a RAID array, and then do the chrooting, ...


0

In BIOS, changing the setting for USB initialization from "Partial initialization" to "Full initialization" could resolve the problem. I've had the same problem and other solutions didn't work out. (Didn't try BIOS update yet)


2

Run this in a terminal grep "^[[:space:]]*menuentry " /boot/grub/grub.cfg | awk -F\' '{c[$2]++} END{for (w in c) print w}'


0

If you want to one-time reboot selection consider using grub-reboot command; If you want to set selection permanently use grub-set-default command. Bot these commands require MENU-ITEM as parameter, for listing yours see: How to list GRUB's “menuentries” in command-line? But, you can always hold Shift while booting, to show Grub Menu, isn't it possible ...


0

Edit your grub configuration as necessary - if you want to use it for longer, and install the new grub setup then to disk(s). This I believe will help you understand grub configuration: https://help.ubuntu.com/community/Grub2/Setup Otherwise I think kexec may also help you. Install kexec with: sudo apt-get install kexec-tools


0

So I was able to solve this problem by simply deleting the EFI/Microsoft folder. I'm guessing that boot repair created this folder, but it is not needed on my Ubuntu only setup.


1

Ended up installing an older version of Ubuntu 10.04.4 LTS - Lucid Lynx; after first disabling UEFI in the BIOS. Then, installed the latest Ubuntu 14.04.2 LTS - Trusty Tahr over it. This remedied the boot issue and am now able to boot into Ubuntu on my X120e.


1

Fifteen seconds? 15secs? That is really impressive! And you actually want to optimise that??? :-O I would say: take a system back-up now (You're definitely user type 4!) and don't touch anything!!! (except maybe remove bootchart as that takes time as well) Your boot is faster then 99.75% of all users on this site and faster then 99.999% of all user on ...


1

As per the comment offered by @oldfred, I ran update-grub from within the 14.04 system. It automatically added entries for the 14.10 system. So, I boot using windows MBR and select 14.04, then from the grub screen I pick wither 14.04 or 14.10. The one gotcha was that update-grub was not in my path. I ended up having to install the grub2-common package ...


0

Try this: With the PC turned off: Turn the PC on Right after the BIOS splash screen (if any) hit Esc to boot into grub2 Select Advanced options for Ubuntu Select Ubuntu, with kernel * (recovery mode) Select root (Drop to root shell prompt) to get to a root shell Run mount -o remount,rw / to remount / as read/write Run apt-get purge gnome-shell to ...


0

You might have accidentally erased the partition which grub (the boot loader) is installed into. The suggestion is to run Ubuntu with your usb flash drive without installing Ubuntu. And when you are shown the desktop, please run the following commands in the terminal (you should have internet connected). sudo add-apt-repository ppa:yannubuntu/boot-repair ...



Top 50 recent answers are included